Css Handbuch

CSS Unitec Home Page

Commercial Spooling System

Release 4.1

Das vorliegende CSS Handbuch enthält folgende Kapitel:

1. Einführung
2. Installation
3. Befehle
4. Konfiguration
5. Programmierung

Copyright © by Unitec Informatik, www.unitec.ch. All rights reserved.

Zurück zum Anfang


Einführung

Kapitel 1 - Einführung

1.1. Übersicht
1.2. Aufbau dieses Handbuches
1.3. Änderungen in dieser Version
1.4. Migration zu diesem Release
1.5. Konventionen zur Notation
1.6. Syntax der Befehlszeilen
1.7. Unterstützung, Anregungen, Feedback

1.1. Übersicht

Das Produkt CSS Commercial Spooling System ist ein Software-Paket zur einfachen Verwaltung und Steuerung der gesamten Druckausgabe von UNIX Systemen. Die Funktionen und die Bedienung von CSS sind speziell auf die Bedürfnisse der kommerziellen EDV zugeschnitten. Die Benutzer-Schnittstelle ist durch ein Dialog-Programm gegeben, welches die Verwaltung von mehreren Druckern, Formularen und Auswertungs-Warteschlangen auch für den weniger erfahrenen Anwender leicht verständlich macht. Die Programme von CSS sind alle in der Sprache C geschrieben und somit mit geringem Aufwand auf alle UNIX-Systeme portierbar.

Die wichtigsten Eigenschaften von CSS sind:

  • Unterstützung für mehrere virtuelle Server Umgebungen. Damit kann im Rechenzentrumsbetrieb für jeden Kunden oder jede Benutzergruppe ein eigener Druckserver eingerichtet werden.
  • Möglichkeit der geräteunabhängigen Programmierung
  • Definitions-Datenbank für Drucker und Formulare
  • Formular-Definitions Utility / Laserdrucker Makroverwaltung
  • Einfach zu bedienendes Dialogprogramm für alle Verwaltungsaufgaben
  • Lpr Optionen innerhalb der Druckdatei
  • Verwaltung von Formular-Warteschlangen
  • Report Preview (Anzeige von Druckdateien mit Suchfunktion)
  • Testdruck (Richttest)
  • Integrierte Druckdatei Verwaltung mit Aufbewahrungsdatum
  • Druckerumleitung
  • Automatisches aktivieren von Ersatzdruckern
  • Übersetzungstabellen für Zeichen- und Zeichensequenzen
  • Multiuser Tauglichkeit
  • Kompression der CSS Zwischendateien
  • Unterstützung der Netzwerk Druckprotokolle lpd, rtel, pros und raw
  • Grafische Oberfläche für Windows Workstations
1.2. Aufbau dieses Handbuches

Die CSS Dokumentation ist 5 Kapitel aufgeteilt:

Kapitel | Name | Inhalt
1 | Einführung | gibt einen Überblick der wichtigsten Eigenschaften von CSS, beschreibt die Organisation des Handbuches, die Änderungen in der aktuellen Version sowie Hinweise zur verwendeten Notation.
2 | Installation | enthält die Informationen, wie CSS auf Ihr System zu bringen ist.
3 | Befehle | enthält die Beschreibung der CSS Programme im UNIX-Stil.
4 | Konfiguration | dient als Referenz für die Definition der verwendeten Drucker und Formulare sowie der CSS Umgebung.
5 | Programmierung | enthält Informationen für den Software-Entwickler. Darin sind die Steuermöglichkeiten des Ausdruckes sowie das C-Interface zur Geräte- und Formularunabhängigen Programmierung beschrieben.
1.3. Änderungen in dieser Version

In der vorliegenden CSS-Version sind alle Erweiterungen implementiert, die bereits in der READ.ME Datei der vorhergehenden Version beschrieben wurden und das Handbuch ist entsprechend angepasst. In der folgenden Aufstellung sind die weiteren Änderungen aufgeführt:

  • Die Unterstützung von mehreren virtuellen CSS Druckservern wurde implementiert. Details sind im Kapitel Konfiguration beschrieben.
  • Für Software mit fest programmierten Drucker-Steuersequenzen, können neu spezielle Drucker zur Aufbereitung der Ausgabe der Vorschau in css(U) und WinCss(U) definiert werden. Für Details siehe unter css.default(C), Parameter VIEW_DEVICE und WINCSS_VIEW_DEVICE sowie unter css.devices(C), vd-Eigenschaft.
  • Das Produkt CssNT wurde eingestellt. In Installationen mit einem oder mehreren Windows NT/2000 Applikationsservern empfehlen wir ein Linux System mit der CSS und der Samba Software installiert. Diese Konfiguration stellt den kostengünstigsten, flexibelsten, zuverlässigsten und schnellsten Druckserver dar.
  • Im weiteren wurden - wie bei jedem Releasewechsel - mehrere "kleine" Änderungen, Korrekturen und Verbesserungen vorgenommen sowie alle bekannten Fehler eliminiert.
1.3.1. Änderungen in Version 4.0
  • Die WinCss Release Nummer wurde an diejenige von CSS angepasst.
  • Der TCP/IP Server cssws(U) für die Grafische Oberfläche von WinCss wurde zur Unterstützung der erweiterten Funktionalität überarbeitet. Die Menge der Erweiterungen erforderte die Implementierung eines neuen Kommunikationsprotokolls. Um Kompatibilität mit älteren Versionen zu gewährleisten, unterstützt die vorliegende Version auch das Protokoll der Vorgängerversion. Die älteren Protokolle werden ab der nächsten CSS Version nicht mehr unterstützt.
  • Der Vorgabewert der Dialogsprache von css(U) wurde bei Neuinstallationen von Deutsch auf Englisch gewechselt. Für eine Änderung dieser Grundkonfiguration siehe unter css.default(C), Parameter LANGUAGE.
  • Bedingt durch die im Lauf der Jahre gewachsene Anzahl von CSS Versionen, verzichtet das setup(I) Programm darauf, statistische Auswertungsdaten (wie z.B. das Datum des letzten Ausdrucks) zu erhalten. Die Wiederherstellung der Auswertungsdatenbank aus dem Spool Verzeichnis funktioniert weiterhin wie gewohnt.
1.3.2. Änderungen in Version 3.4

Änderungen in Version 3.4 sind in der folgenden Aufstellung aufgeführt:

  • Der TCP/IP Server cssws(U) für die Grafische Oberfläche von WinCss wurde zur Unterstützung der erweiterten Funktionalität überarbeitet.
  • Das csu(U) Programm hat neue Optionen um das Keep-Datum von Auswertungen anzuzeigen.
  • Die Möglichkeit Drucker umzuleiten wurde implementiert. Für Details siehe unter css(U), die o-Option von csu(U) sowie die wfc und wft Eigenschaften in css.devices(C).
  • Die Syntax der bo x und eo x Eigenschaften in css.devices(C) wurden um zusätzliche Bedingungen erweitert. Neu kann deren Gültigkeit auf bestimmte Auswertungskopien und Inhalte von Ordnungsvariablen eingeschränkt werden.
  • Die Grösse der CSS Fehler Log Datei kann neu in der Konfigurationsdatei css.default(C) definiert werden.
  • Die Navigation von Bildfolgen in css(U) kann neu im Parameter WRAP_SCREEN in css.default(C) auf das Verhalten von Release 3.2x (von der letzten zur ersten Seite) und früher gesetzt werden.
  • Im weiteren wurden - wie bei jedem Release-Wechsel - mehrere "kleine" Änderungen, Korrekturen und Verbesserungen vorgenommen.
1.4. Migration zu diesem Release

Die hier aufgeführten Punkte sind für Benutzer von älteren CSS Versionen bestimmt und geben die notwendigen Hinweise wie Inkompatibilitäten beseitigt werden können. Erweiterungen, welche keine Inkompatibilität bewirken sind hier nicht beschrieben.

Wichtig! Wenn Sie eine ältere CSS Version durch diese aktuelle Version ersetzten, raten wir dringend dazu, eine Datensicherung durchzuführen! Falls Sie keine vollständige Sicherung durchführen können, stellen Sie sicher, dass Sie im Fehlerfall auf Ihre jetzige Version zurückkehren können. Dazu benötigen Sie die alte Software inkl. setup Programm und eine Sicherung der Steuerdaten im CSS Basisverzeichnis (normalerweise /usr/lib/css), sowie der Druckdaten im Spoolverzeichnis (normalerweise /usr/spool/css). Für Betriebsunterbrüche bei Installationsproblemen kann Unitec keinerlei Haftung übernehmen. Bitte lesen Sie auch den Unitec Lizenzvertrag.
1.4.1. Migration von Release 2.7

Dieser Abschnitt ist nur für Benutzer der CSS Version 2.7 oder älter wichtig.

  • Da bei den tr-Parametern in css.devices(C) neu auch ein Dateinamen angegeben werden kann, muss bei Kontrollsequenzen, die mit dem Zeichen '/' (Slash) beginnen, dieses als '\/', '\057' oder '\x2f' angegeben werden:
    alt: tr=abc=/xy/z
    neu: tr=abc=\/xy/z

  • Neu können bei den bor-, eor- und tr-Parametern in css.devices(C) auch Ordnungsbegriffe angegeben werden. Daher müssen einzelne '%' Zeichen als '\%', '\045' oder '\x25' definiert werden:

    alt: bor=\E%5x
    neu: bor=\E\%5x
    alt: tr=abc=mn%p
    neu: tr=abc=mn\%p

  • Die Funktionalität der if1-, if2-, tf1- und tf2-Parameter in css.devices(C) ist durch die Möglichkeit mehrere bor-, resp. eor-Paramter anzugeben, redundant geworden. Aus Gründen der Kompatibilität wird deren Verwendung weiterhin unterstützt. Da dies in einem späteren Release nicht mehr garantiert ist, empfehlen wir jedoch, sie entsprechend zu ersetzen:

    alt: if1=/usr/css/if1
    neu: bor=/usr/css/if1

    Die Reihenfolge der Definitionen, bestimmt auch die Reihenfolge der Ausgabe.

  • Die Syntax der Ordnungsbegriffe wurde geändert und erweitert. Siehe unter css.devices(C).

  • Die Methode des 'external locks' (el-Parameter) kann in css.default(C) festgelegt werden. Der Default weicht von der bisherigen Methode ab, ist jedoch sicherer. Die bisherige Methode (sema) kommt nur bei der Synchronisation mit anderen Softwarepaketen zur Anwendung (jedoch nicht zur logischen Mehrfachbelegung eines physischen Druckers).

1.4.2. Migration von Release 3.3

Dieser Abschnitt ist nur für Benutzer der CSS Version 3.3 oder älter wichtig.

  • Die Verwendung der Condition-Flags, welche mit der C-Option des Spooler Frontends lpr(U) gesetzt werden, wurde geändert. Ab Release 3.4 werden diese Flags auf die mittels C-Option gesetzten Werte für jede gedruckte Kopie neu initialisiert. Um Kopie spezifische Varianten zu steuern, steht die erweiterte Syntax der bo x und eo x Druckereigenschaften zur Verfügung. Um das Verhalten vorhergehender CSS Versionen zu simulieren, kann der Parameter JOB_FLAGS in css.default(C) auf true gesetzt werden.

1.4.3. Migration von Release 3.4 oder höher

Es sind keine speziellen Punkte zu beachten.

1.5. Konventionen zur Notation

Diese Konventionen zur Notation werden im gesamten CSS Handbuch verwendet:

  • Namensbezeichnungen im Text werden fett geschrieben, wie z.B. /etc/css.devices, lpr, READ.ME.
  • Syntaktische Einheiten werden als italics dargestellt und bedeuten, dass Sie an deren Stelle eine der gleichen Kategorie zugehörige Namensbezeichnung einsetzen müssen, wie z.B. filename.
  • In Syntax-Beschreibungen werden fakultative Objekte innerhalb eckiger Klammern ([ ]) dargestellt.
  • Argumente die mehrmals angegeben werden können werden von drei Punkten (... / sog. Ellipsis) gefolgt.
  • Stehen mehrere mögliche Eingaben zur Wahl werden sie durch einen vertikalen Strich ( | ) getrennt dargestellt.

Um Referenzen auf andere Stellen dieses oder des UNIX Handbuches so klar und unstörend wie möglich zu machen, gelten folgende Konventionen:

Eine Referenz auf einen Abschnitt im selben Kapitel wird durch den fett geschriebenen Namen dargestellt.

Eine Referenz auf einen Abschnitt in einem anderen Kapitel oder im UNIX Handbuch wird durch den fett geschriebenen Namen unmittelbar gefolgt von einer in Klammern gesetzten Kapitel-Identifikation.

Die in diesem Handbuch verwendeten Identifikationen sind:

ID | Referenz auf
(I) | Kapitel 2 / Installation
(U) | Kapitel 3 / Befehle (Utilities)
(C) | Kapitel 4 / Definition / Konfiguration
(P) | Kapitel 5 / Programmierung, Interface
(1) | UNIX Standartbefehle
(2) | UNIX System-Calls
(3) | UNIX Library Subroutines
(4) | UNIX Special Files
(5) | UNIX File Formats
1.6. Syntax der Befehlszeilen

Das allgemeine Format von CSS Befehlszeilen ist:

command [option...] [file...]

  • command

Name des Befehles

  • option

Wir unterscheiden zwischen Optionen ohne Argument (sog. Switches) und solchen mit Argument.

    Optionen ohne Argument

    Switches werden in der Form -s, d.h. einem Bindestrich '-' unmittelbar gefolgt von einem Buchstaben eingegeben. Zwischen Gross- und Kleinschreibung wird unterschieden. Um die Wirkung eines z.B. im Shell Environment vordefinierten Switches unwirksam zu machen, kann die Form -+s verwendet werden. Mehrere Switches können nach einem Delimiter '-' zusammengefasst werden (z.B. -af).

    Optionen mit Argument

    Verlangt die Befehls-Syntax ein Options-Argument, so ist dieses - sofern die Option gewählt wird - immer zwingend einzugeben. Leerzeichen zwischen Options-Bezeichner und dem Argument sind fakultativ. Enthält das Argument Leerzeichen, so ist es zwischen einfache oder doppelte Anführungszeichen zu setzen (z.B. -t 'Kunden 1993'). Sind mehrere Argumente möglich, werden diese durch Kommas oder Doppelpunkte - ohne dazwischenliegende Leerzeichen - voneinander getrennt. Das als erstes gewählte Trennzeichen gilt für die gesamte Argumenten-Gruppe (Beispiel -r 15:LaserJet). Bei einigen Programmen (z.B. etr(U)) werden mehrstellige Options-Bezeichner verwendet. Bei solchen Optionen muss zwischen dem Bezeichner und dem Argument ein Leerzeichen gesetzt werden (z.B. -e20 arg).

    Spezielle Optionen

    Durch einen doppelt gesetzten Bindestrich '--' kann die Optionen-Liste eines Befehles abgeschlossen werden. Dadurch wird auch möglich, Dateien anzugeben, deren Name mit einem Bindestrich beginnt.
    Bei gewissen Programmen können numerische Optionen angegeben werden. Dabei steht die Option zugleich als Argument. Speziell kann dabei in einigen Fällen auch das Plus-Zeichen als Options-Delimiter gelten (z.B. cssdate +7).
    Die Option -help ist bei allen CSS Programmen verfügbar und gibt eine kurze Zusammenfassung der Befehls-Syntax und der möglichen Optionen aus.

  • file

Datei-Argumente sind fakultativ. Bei allen Befehlen, die Datei-Argumente vorsehen, wird ein fehlendes Argument als 'Standard-Input' interpretiert. Ein einzeln eingegebener Bindestrich '-' steht - je nach Kontext - für die Datei Standard-Input, resp. -Output. Die Eingabe etr f2 | lpr f1 - f3 bewirkt z.B. dass die Datei f1 gefolgt von der durch etr(U) bearbeiteten Datei f2 und schliesslich der Datei f3 der Spooler-Verwaltung übergeben werden.

Mehrere CSS Programme erlauben es, Optionen auch ausserhalb der Befehlszeile anzugeben. Am Beispiel des Programmes lpr(U) wird im folgenden die Reihenfolge der Optionsverarbeitung dargestellt. Je später diese Verarbeitung erfolgt, um so höher ist die Priorität der Option, d.h. bei einer mehrmals eingegebenen Option, gilt die in der Reihenfolge zuletzt angetroffene.

Quelle | Beschreibung
$HOME/.lprrc | Ist im Home-Directory die Datei .lprrc (Punkt - lpr - remote-control) vorhanden, werden die darin eingegebenen Optionen verarbeitet. Die Optionen können auf mehrere Zeilen verteilt werden. Zeilen, die mit dem Zeichen '#' beginnen, gelten als Kommentar.
LPROPT | Ist im Shell-Environment die exportierte Variable LPROPT (lpr options) definiert, werden die darin eingegebenen Optionen verarbeitet.
lpr Befehlszeile | siehe oben
Input-Datei | CSS erlaubt in den Dokumenten eingebettete lpr-Optionen (document embedded control). Siehe dazu auch unter CSS(P).
1.7. Unterstützung, Anregungen, Feedback

Die meisten Probleme die beim Betrieb von CSS auftauchen könnten, sind mit Hilfe dieses Handbuches leicht zu beheben. Das Kapitel Befehle enthält alle Informationen für den Normalbetrieb. Die Kapitel Installation und Konfiguration sind die primäre Informationsquelle zur Einrichtung der CSS Umgebung und das Kapitel Programmierung dient dem Softwareentwickler als Referenz für die Integration in die Applikations-Programme. Zusatzinformationen sind in gewissen Fällen in separaten Release-Notes, Technical-Notes oder in einer Datei READ.ME zu finden.

Sollten Sie jedoch mit einem Problem konfrontiert werden, welches Sie weder mit der gelieferten Dokumentation noch mit der Hilfe Ihres Lieferanten lösen können, benachrichtigen Sie uns bitte. Wir werden uns bemühen, Ihnen so rasch wie möglich Hilfe zu leisten.

Wir bitten Sie, uns Ihre Erfahrungen, Anregungen und Erweiterungsvorschläge mitzuteilen. Sie helfen uns damit, das Produkt CSS weiter auf Ihre Bedürfnisse auszurichten. Sollten Sie Drucker verwenden, welche nicht in der mitgelieferten Datei css.devices enthalten sind, nehmen wir Ihre Definition gerne unter Hinweis der Urheberschaft darin auf. Sie helfen damit allen CSS Benutzern, auf eine ständig wachsende Anzahl Drucker-Definitionen zugreifen zu können. Bitte senden Sie Ihr Schreiben an die im Lizenzvertrag aufgeführte Adresse.


Copyright

Copyright / Trademarks

Copyright © 1990-2000 by Unitec Informatik. All rights reserved.

Die in diesem Dokument enthaltene Information kann ohne vorherige Ankündigung geändert werden und beinhaltet keinerlei verpflichtende Zusagen der Firma Unitec Informatik. Die hier beschriebene und durch Copyright geschützte Software wird mit einer Garantie von 90 Tagen geliefert und darf nur im Rahmen des Lizenzvertrages benutzt oder kopiert werden. Es ist ungesetzlich, diese Software zu benutzen oder zu kopieren, ausser wen im Lizenzvertrag dieses Recht ausdrücklich zugestandenen ist.

Unitec Informatik
Thomas Madörin
Leerüti 797

CH-8625 Gossau

Switzerland

Unix is a registered trademark of AT&T Bell Labs Incorporated.
Unitec is a registered trademark of Unitec Informatik, Switzerland.
Windows and Windows NT are registered trademarks of Microsoft Corporation


Lizenz

Unitec Lizenzvertrag

Wichtiger Hinweis

Lesen Sie diesen Lizenzvertrag bevor Sie das beiliegende Produkt CSS-Spooler installieren! Die Installation resp. jegliche Verwendung der gelieferten Software setzt die Annahme des Vertrages voraus.

Dieser Vertrag besteht zwischen dem Käufer des Produktes CSS-Spooler (CSS für Unix, CssNT und WinCss), nachfolgend Kunde genannt und

Unitec Informatik
Thomas Madörin
Leerüti 797

CH-8625 Gossau

nachfolgend Unitec genannt und erstreckt sich auf sämtliche gelieferten Programme und die gesamte Dokumentation.

Unitec liefert dem Kunden das Produkt CSS-Spooler in Form einer nicht übertragbaren und nicht ausschliesslichen Benutzungs-Lizenz zum Eigengebrauch unter nachfolgenden Bedingungen:

  1. Das Produkt CSS-Spooler wird dem Kunden unter Lizenz geliefert und darf ausschliesslich auf einem einzigen Computersystem oder Netzwerkknoten, sowie - zeitlich begrenzt - auf einer eventuell notwendigen Ausweichanlage benutzt werden. Der dauerhafte Einsatz des Lizenzproduktes auf einem anderen Computersystem bleibt auch dann lizenzpflichtig, wenn die Software auf dem Bestimmungssystem gelöscht wurde. Mit Ausnahme dieses Nutzungsrechts bleiben sämtliche Rechte am Lizenzprodukt dauernd bei Unitec, auch wenn der Kunde daran Änderungen vornimmt.

  2. Der Kunde verpflichtet sich, das Produkt CSS-Spooler, einschliesslich Dokumentation, Dritten weder ganz noch teilweise zu überlassen oder sonstwie zugänglich zu machen, sowie - ausser zu Sicherungszwecken - keine zusätzlichen Kopien irgendwelcher Art zu erstellen.

  3. Die Verantwortung für den Gebrauch der Programme, sowie für die daraus erzielten Resultate liegt beim Kunden. Er ist zudem verantwortlich für die Sicherheitsmassnahmen zum Schutze gespeicherter Daten vor Zerstörung, Diebstahl oder Missbrauch, sowie für die Bereitstellung von Ausweichlösungen. Ausdrücklich ausgeschlossen sind Regressansprüche, die aus dem Aufwand zur Wiederherstellung zerstörter Daten, aus Folgeschäden oder indirekten Schäden, wie entgangener Gewinn, nicht realisierter Einsparung, Mehraufwendungen oder Ansprüche Dritter abgeleitet werden.

  4. Unitec verpflichtet sich, allfällig auftretende Fehler in Lizenzprogrammen während einer Frist von 90 Tagen gratis und innert nützlicher Frist zu beheben. Unitec's Verpflichtung besteht darin, ihr bestes zu tun, den Kunden innert nützlicher Frist mit den Spezifikationen übereinstimmenden Programmen zu beliefern. Die Kosten für Datenträger sowie Versandspesen solcher Korrekturen, gehen zu Lasten des Kunden. Diese Garantie erlischt, wenn an den beanstandeten Lizenzprogrammen vom Kunden oder von Dritten Änderungen vorgenommen wurden.

  5. Unitec steht dem Kunden zu den jeweils gültigen Honorarsätzen und nach Absprache zur Verfügung für:
    - Installation des Lizenzproduktes
    - Änderungen und Anpassungen des Lizenzproduktes
    - Instruktion und Schulung

  6. Das Öffnen des versiegelten Datenträgers oder jegliche Benutzung des Lizenzproduktes setzt die Annahme des vorliegenden Lizenzvertrages voraus. Der Kunde ist dadurch jedoch nicht davon befreit, sein Einverständnis mit diesem Vertrag Unitec schriftlich zu bestätigen.

  7. Sollten Teile dieses Vertrages nichtig sein oder rechtsunwirksam werden, so gilt der Restvertrag weiter. Die Vertragspartner werden den Vertrag so auslegen und gestalten, dass der mit den nichtigen oder rechtsunwirksamen Teilen angestrebte wirtschaftliche Gedanke soweit wie möglich erreicht wird.

  8. Sämtliche das Lizenzprodukt dieses Vertrages betreffenden Abmachungen sind im vorliegenden Vertrag enthalten. Etwaige weitere Vereinbarungen sind nur dann rechtsgültig, wenn sie schriftlich festgelegt werden und darin ausdrücklich auf diesen Vertrag Bezug genommen wird.

  9. Erfüllungsort für die Zahlungen aus diesem Vertrag und Gerichtsstand ist Zürich. Dieser Vertrag untersteht schweizerischem Recht.


Installation

Kapitel 2 - Installation

2.1. Übersicht
2.2. Unix Installation
2.3. Windows NT (CssNT) Installation
2.4. Windows Client Installation
2.5. Installationsprogramme

2.1. Übersicht

Diese Kapitel beschreibt die Installation von CSS. Das setup Programm bietet zudem die Möglichkeit, bei einem Upgrade auf diese Version, die Vorversion vom System zu entfernen.

Bei einem Upgrade werden die Steuerdateien im Directory /etc belassen. In allen anderen Fällen erfolgt eine Minimal-Installation mit einem Drucker auf /dev/lp. Um alle Möglichkeiten von CSS auszunützen, sind die lokalen Gegebenheiten in den Steuerdateien entsprechend zu definieren.

Hinweis! Alle Unitec Produkte benötigen für den ordnungsgemässen Ablauf den Lizenz Manager ULM. Das setup(I) Programm der CSS Software installiert alle benötigten Komponenten in den dafür vorgesehenen Verzeichnissen.
2.2. Unix Installation

Um alle CSS Dateien auf dem Harddisk zu installieren, muss ein temporäres Directory erstellt werden. In den folgenden Abschnitten verwenden wir als Basis der Installation dazu /tmp/css. Falls Sie ein anderes Directory wählen möchten, sollten Sie den vorgegebenen Pfadnamen jeweils mit Ihrer Wahl substituieren.

login als root
mkdir /tmp/css

Als nächstes müssen die auf dem Datenträger gespeicherten Daten im Directory /tmp/css gespeichert werden. Normalerweise wird CSS auf 3½" MS-DOS DD oder HD Disketten vertrieben. Spezielle Formate sind auf Wunsch erhältlich:

3½" DD oder HD Disketten, Unix tar(1) Format
5¼" MS-DOS Format, 720KB oder 1.2MB
5¼" 96 Tpi, 720KB oder 1.2MB, Unix tar(1) Format
QIC 24 Tape Cartridge, Unix tar(1) Format

MS-DOS Format

Auf den MS-DOS Disketten ist eine Datei, css.tar oder css.tzr enthalten. Diese Datei muss auf das Unix Filesystem gebracht werden. Mehrere Methoden sind möglich. Falls Sie PC/TCP, Pathworks oder PC-NFC verwenden, kann der standart DOS copy Befehl verwendet werden, um die Software auf einen, im Netz verfügbaren Unix Disk, zu kopieren. Falls ftp verwendet wird, muss der Kopiervorgang im binary Modus durchgeführt werden. Einige Unix Systeme verfügen über einen Befehl zum Kopieren von DOS Disketten (z.B. SCO doscp -r).

Wichtig! Einige Kopierprogramme unterscheiden zwischen Text- und Binär-Dateien. Die CSS Software muss im binären Modus übertragen werden um cr/lf Konversionen zu verhindern. Zum Beispiel muss der SCO doscp Befehl mit der r-Option verwendet und ftp auf den binären Modus gesetzt werden.

Nach Abschluss des Transfers der CSS Software, sollten Sie als User root in das /tmp/css Directory wechseln (cd(1) Befehl). Endet der Dateiname mit dem Suffix .tzr, sind folgende Shell Befehls einzugeben:

mv css.tzr css.tar.Z
uncompress css.tar

Um alle Dateien zu extrahieren, verwenden Sie:

tar xvf css.tar

Meldet der tar(1) Befehl den Fehler Directory checksum error, sollte

dd if=css.tar conv=swab | tar xvf –

Abhilfe schaffen.

Wichtig! Wenn Sie eine ältere CSS Version durch diese aktuelle Version ersetzten, raten wir dringend dazu, eine Datensicherung durchzuführen! Falls Sie keine vollständige Sicherung durchführen können, stellen Sie sicher, dass Sie im Fehlerfall auf Ihre jetzige Version zurückkehren können. Dazu benötigen Sie die alte Software inkl. setup Programm und eine Sicherung der Steuerdaten im CSS Basisverzeichnis (normalerweise /usr/lib/css), sowie der Druckdaten im Spoolverzeichnis (normalerweise /usr/spool/css). Für Betriebsunterbrüche bei Installationsproblemen kann Unitec keinerlei Haftung übernehmen. Bitte lesen Sie auch den Unitec Lizenzvertrag.

Nun kann das Setup Programm ausgeführt werden:

./setup

Hinweis: Wird eine ältere CSS Version mit WinCss Clients aufgerüstet, muss das Programm cssws(U) gestoppt und neu gestartet werden. Da setup(I) keine Kenntnis über die gewählte Integrationsmethode des Serverprozesses hat (siehe WinCss(C)), kann diese Aktion nicht automatisch durchgeführt werden. Bitte verwenden Sie ps(1) um die Prozess ID herauszufinden (befindet sich in der PID Spalte) und kill(1) um das alte Programm zu stoppen. Danach kann die neue Version nach der bei Ihnen üblichen Methode gestartet werden. Wurde cssws(C) mittels /etc/inittab(4) implementiert, wird das neue Serverprogramm vom Unix init(1) Prozess ohne manuellen Eingriff sofort automatisch neu gestartet. Werden diese Hinweise nicht beachtet, ist ein Fehler (Versionskonflikt oder Protokollkonflikt) auf den angeschlossenen Windows Clients wahrscheinlich.

Unix Format

Ist die Software auf Ihrem Datenträger im Unix Format gespeichert, können die CSS Dateien mit folgendem tar(1) Befehl extrahiert werden:

tar xvf /dev/x

wobei anstelle von /dev/x der Device-Name des Eingabegerätes erwartet wird (z.B. /dev/tape, /dev/ct0, /dev/fd, /dev/fd0135ds18). Bei Unsicherheit kann der ganaue Device-Name im UNIX Handbuch nachgeschlagen werden. Einige Systeme verwenden für den tar(1) Befehl einen Default Device, also kann die Datenextraktion ev. mit tar xv erledigt werden.

Meldet der tar(1) Befehl den Fehler Directory checksum error, kann das Problem mit

dd if=/dev/x conv=swab | tar xvf –

behoben werden. Wird lediglich eine Datei css.tar.Z extrahiert, verwenden Sie:

uncompress css.tar
tar xvf css.tar

und danach

./setup

Setup

Der Dialog des CSS setup Programmes führt Sie durch alle Schritte der Installation. Eine vollständige Beschreibung von setup finden Sie weiter unten in diesem Kapitel.

Der Inhalt der verschiedenen Directories nach erfolgter Installationen ist in der folgenden Tabelle aufgeführt:

Name | Inhalt
/etc | Konfigurations-Dateien css.* und ulm.default. Programme csa(U) und ulm(I).
/usr/lib/css | Default CSS Basis-Directory gemäss der Konfigurations-Variablen CSS_BASE_DIR. Beinhaltet die CSS Datenbanken, eine Kopie von setup(I) für ev. Deinstallation und interne Informationsdateien.
support | Subdirectory von CSS_BASE_DIR: read.me und andere Informationsdateien.
/usr/lib/ulm | Default ULM Basis-Directory gemäss der Konfigurations-Variablen ULM_BASE_DIR. Beinhaltet die ULM Datenbanken, eine Kopie von setup für ev. Deinstallation und interne Informationsdateien.
support | Subdirectory von ULM_BASE_DIR: read.me und andere Informationsdateien.
cwd | CSS Dateien, Beispielprogramme und Funktionen.

Nach der Installation finden Sie weitere Informationen über CSS in der READ.ME Datei.

Damit ist die Basisinstallation und Konfiguration abgeschlossen. Viele Parameter beeinflussen die Verarbeitung der CSS Software. Die Beschreibung aller Konfigurationsdateien sind in diesem Handbuch enthalten.

Hinweis! Um das Server-Programm cssws(U) auszuführen, muss das TCP/IP Netzwerk entsprechend konfiguriert sein. Bitte beachten Sie die entsprechenden Hinweise im Kapitel 4, Konfiguration.
2.3. Windows NT (CssNT) Installation

Die CssNT Installation erfolgt auf dem unter Windows üblichen Weg mittels Setup Programm. Alle benötigten Informationen werden im Dialog erfragt.

login als Administrator
starten des Setup Programmes

Die CssNT Software wird als selbstextrahierendes ZIP Archiv oder auf Disketten geliefert.

Setup

Der Dialog des CssNT Setup Programmes führt Sie durch alle Schritte der Installation.

Der Inhalt der verschiedenen Directories die während der Installation im CssNT Folder erstellt werden, ist in der folgenden Tabelle aufgeführt:

Name | Inhalt
etc | Konfigurations-Dateien css.* und ulm.default. Programme csa(U) und ulm(I).
lib | Default CSS Basis-Directory gemäss der Konfigurations-Variablen CSS_BASE_DIR. Beinhaltet die CSS Datenbanken, ein Programm für ev. Deinstallation und interne Informationsdateien.
support | Subdirectory von CSS_BASE_DIR: ReadMe.txt und andere Informationsdateien.
ulm | Default ULM Basis-Directory gemäss der Konfigurations-Variablen ULM_BASE_DIR. Beinhaltet die ULM Datenbanken und interne Informationsdateien.

Damit ist die Basisinstallation und Konfiguration abgeschlossen. Viele Parameter beeinflussen die Verarbeitung der CssNT Software. Die Beschreibung aller Konfigurationsdateien sind in diesem Handbuch enthalten.

Konfiguration für Eilige

Die Konfigurationsdateien liegen im Directory etc. Speziell zu beachten ist, dass in etc\css.devices für jeden Drucker ein dv Parameter angegeben wird. Die Drucker Devices werden in der Universal Naming Convention (UNC) angegeben:

//host-name/printer-share-name

Bitte beachten Sie, dass in css.devices(C) alle Dateinamen mit dem Unix Separator '/' eingegeben werden müssen. Nach dem Laufwerkbezeichner muss dem ':' ein Backslash '\' (BS) vorgestellt werden, da andernfalls das Ende des Parameters angenommen wird, z.B.

C\:/dev/printer1

Das Setup Programm installiert einen Drucker mit dv=C\:/CssDev1.txt. Die Ausgabe erfolgt demnach auf die Disk Datei C:\CssDev1.txt.

Änderungen in etc\css.devices und etc\css.forms werden erst nach erfolgreicher Kompilation mittels csa(U) aktiv.

Fehlerursache ermitteln

Treten Fehler auf, kann mit dem NT Event Viewer im Application Log nach Hinweisen gesucht werden. Ausserdem werden in der Datei lib\CssErrlog.txt fehlerhafte Verarbeitungen protokolliert.

Kann CssNT nicht mehr betrieben werden, sollte im Control Panel, Services Applet, überprüft werden, ob der CssNT Prozess aktiv ist. Dieser Service kann gegebenenfalls manuell neu gestartet werden.

2.4. Windows Client Installation
  • Starten Sie MS-Windows und legen Sie die WinCss Setup Diskette in Laufwerk A: ein
  • Im Programm Manager wählen Sie File - Run
  • Geben Sie a:\setup ein und betätigen <Return>

Information zur Konfiguration ist unter WinCss(C) zu finden.

2.5. Installationsprogramme

In diesem Abschnitt sind die CSS Installations Programme in alphabetischer Reihenfolge beschrieben. Die Titelzeile enthält den Programmnamen sowie eine Kurzbezeichnung.

Der Synopsis Abschnitt zeigt die Syntax des Befehlsaufrufes mit allen möglichen Optionen und Argumenten.

Der Abschnitt Beschreibung gibt Auskunft über die Verarbeitung des Programmes und über dessen Argumente.

Unter Optionen werden die Aufruf-Optionen erklärt.

Programm | Titel
setup | Produkt Installation.
ulm | Lizenz Manager.


Setup

CSS Installation

setup(I)
Synopsis Plattform Beschreibung Optionen Hinweise Siehe auch

Synopsis

setup [-t] [-v]

Plattform

Unix

Beschreibung

Setup installiert oder deinstalliert die Unix CSS Software auf dem Zielsystem. Vor dem Aufruf von setup, müssen alle Files auf dem Datenträger in ein temporäres Directory (z.B. /tmp/css) kopiert werden. Was dabei speziell zu beachten ist, ist oben in diesem Kapitel beschrieben.

Nach dem Aufruf startet das setup Installationsprogramm im interaktiven Modus. Hauptmenu (erster Aufruf):

CSS 3.30 Setup Program

Commands:
1 - Install CSS
q - Quit

Enter Command:
Hauptmenu (folgende Aufrufe):
CSS 3.30 Setup Program

Commands:
1 - Reinstall/Update CSS
2 - Uninstall CSS
q - Quit

Enter Command:

Jede Menuwahl öffnet ein Untermenu oder fordert die Angabe von Installations-Parametern. Auf allen Ebenen bringt Sie die Eingabe von ‘q’ oder die <Return> Taste eine Stufe zurück resp. beendet das Programm.

Wahl 1 Installiert oder Aktualisiert die CSS Software. Setup überprüft das Vorhandensein aller erforderlichen Dateien im aktuellen Directory. Sind nicht alle Installationsdateien vorhanden gibt setup eine Fehlermeldung aus und beendet die Verarbeitung. Befolgen Sie bitte die Instruktionen auf dem Bildschirm.

Wahl 2 Deinstalliert die CSS Software vom System. Einige Dateien werden dabei allerdings belassen. Um CSS vollständig zu entfernen, müssen die angegebenen Dateien manuell gelöscht werden. Eine allfällig spätere Neuinstallation wird durch diese Dateien jedoch erleichtert.

Alle Aktionen von setup werden in der Datei setup.log aufgelistet.

Optionen

-t | Die Test-Option veranlasst setup alle Aktionen in setup.log aufzulisten, jedoch diese nicht auszuführen.
-v | Zeigt die Softwareversion an.

Hinweise

Bedingt durch die im Lauf der Jahre gewachsene Anzahl von CSS Versionen, verzichtet setup darauf, statistische Auswertungsdaten (wie z.B. das Datum des letzten Ausdrucks) zu erhalten. Die Wiederherstellung der Auswertungsdatenbank aus dem Spool Verzeichnis funktioniert weiterhin wie gewohnt.

Nach erfolgreicher Installation mit setup muss die abschliessende Konfiguration durchgeführt werden:

• Upgrade von einer früheren CSS Version

Der Upgrade mit einem aktiven cssws(U) Server Programm bedarf spezieller Beachtung. Da das cssws Programm ev. via /etc/inittab(4) gestartet wurde, ist es für setup nicht möglich die alte Programmversion zu löschen. Auch das Abbrechen durch kill(1) hilft nicht weiter, da die respawn Option init(1) veranlassen würde, sofort eine neue Kopie von cssws zu starten. Das setup Programm bennent cssws in cssws.old um. Nach erfolgter Installation kann mit ps(1) die Prozess-ID (PID) ermittelt und mit kill(1) cssws gestoppt werden. Ist cssws in Ihrer /etc/inittab registriert, wird danach die neue Version automatisch gestartet. Verwenden Sie eine andere Methode um den Windows Server Prozess zu starten (z.B. via /etc/rc), können Sie ihn manuell neu starten. Das cssws Programm liegt im CSS Basis-Directory (normalerweise /usr/lib/css).

• Deaktivieren des vom Hersteller gelieferten Spoolers

Bei den meisten Systemen kann dieser Punkt übersprungen werden. Hinweise sind allenfalls in speziellen Installation Notes zu finden.

• Device-Definitionen

Die mitgelieferten Steuerparameter veranlassen CSS , auf den Device /dev/lp zu schreiben. Mit Hilfe des dv-Paramters von css.devices(C) kann jedoch jedes beliebige Device- oder Disk-File als Ausgabekanal definiert werden. Falls Sie /dev/lp verwenden möchten und dieser Device auf Ihrem System nicht vorhanden ist, müssen zur Definition die Major- und die Minor-Devicenummer bekannt sein. Ist kein System-Configuration Manual vorhanden, kann zur Bestimmung dieser Nummern wie folgt vorgegangen werden:

ls -l /dev/tty* ergibt z.B. die Ausgabe:

crw-rw-rw- 1 root 1, 0 Jan 16 13:27 /dev/tty
crw-rw-rw- 1 root 0, 1 Jan 18 08:24 /dev/tty2
crw-rw-rw- 1 root 0, 2 Sep 14 09:32 /dev/tty3
...
crw-rw-rw- 1 root 0, 7 Aug 30 17:11 /dev/tty8

Die erste Zahl nach der Benutzerkennung (hier root) bezeichnet die Major-Devicenummer und die nächste Zahl die Minor-Devicenummer.

Der Drucker 1 soll z.B. an Port 8 angeschlossen werden (d.h. an dem Port, an dem auch der Bildschirm 8 via /dev/tty8 angesprochen werden könnte).

/etc/mknod /dev/lp c 0 7 # 0 = Major / 7 = Minor

Es muss nun noch sichergestellt werden, dass auf diesem Port keine Login-Meldungen ausgegeben werden. Dazu wird bei Xenix und Unix Version 7 im File /etc/ttys der entsprechende tty-Eintrag (im Beispiel tty8) gelöscht oder das erste Zeichen der Zeile auf '0' (Zahl Null) geändert:

02tty8

Xenix stellt dazu auch das Hilfsprogramm disable(1) zur Verfügung. Bei Unix System V wird im File /etc/inittab die getty-Zeile gelöscht oder modifiziert:

t08:1:respawn:/etc/getty /dev/tty8 ...

löschen oder ändern in:

t08:1:off:/etc/getty /dev/tty8 ...

Um spezielle Schnittstellen-Attribute wie Parität, Anzahl Stop-Bits usw. zu definieren, kann das mitgelieferte Programm setmode(U) eingesetzt werden.

• Konflikte bei der Namengebung

Bei Konflikten in der Namensgebung werden die vorhandene lp- und lpr-Programme durch den setup-Script auf lp.unix resp. lpr.unix umbenannt.

• Integrität

Um dauerhaft einen gesicherten Ablauf zu gewährleisten ist im File /etc/rc der folgende Befehl zu integrieren:

csa -S >/dev/null

• Integration

Der Spooler ist sofort benutzbar (via /dev/lp). Um alle Möglichkeiten der vorhandenen Drucker auszunützen, muss jedoch die Definitions-Datenbank /etc/css.devices gemäss css.devices(C) erweitert werden. Als Muster sind verschiedene bekannte Drucker-Modelle bereits vordefiniert.

In der Definitions-Datenbank /etc/css.forms sollte mindestens das Standartformular (Typ 'A') an das am häufigsten verwendete Formular angepasst werden. Änderungen werden jedoch erst nach erfolgter Kompilation mittels csa -f aktiv.

Zur Einrichtung weiterer Drucker ist folgendermassen vorzugehen:

  1. Definition des Druckers in /etc/css.devices:

    z.B. 2|Drucker 2:dv=/dev/tty5:# Device '/dev/tty5'
    Kompilation der Definitions-Datenbank mit csa -d

  2. Herstellung der Verbindung Drucker « Device

    Falls das mittels dv-Parameter angegebene Device-File nicht existiert, ist wie oben beschrieben die Major- und Minor-Devicenummern des zu verwendenden Ports zu ermitteln und mit /etc/mknod(1) das gewünschte Device-File (z.B. /dev/tty5) zu erstellen.
Das User-Interface Programm css(U) verwendet die Bildschirm-Definitionen in /etc/termcap. Dazu muss die Environment-Variable TERM auf die Bildschirm-Bezeichnung gesetzt werden und allgemein zugänglich sein (sh(1) / export). Treten ungewöhnliche Dialogbilder auf, sollte die Definition in /etc/termcap speziell auf folgende Werte überprüft werden:

Tabelle 2-1: Termcap-Namen

bc | Steuersequenz für 'Backspace', falls nicht <Ctrl>-H.
cd | Steuersequenz um den BS von der aktuellen Position bis zum Ende zu löschen (Clear to end of display).
ce | Steuersequenz um den BS von der aktuellen Position bis zum Ende der Zeile zu löschen (Clear to end of line).
CF | Steuersequenz um den Cursor auszuschalten.
cl | Steuersequenz um den gesamten BS-Inhalt zu löschen (Clear screen). Von der Software wird dabei angenommen, dass nach dieser Operation der Cursor auf der ersten BS-Stelle positioniert ist. Es kann daher sinnvoll sein, hier die Steuersequenz 'Cursor home' gefolgt von 'Clear screen' anzugeben.
cm | Steuersequenz für direkte Cursor-Adressierung (gemäss termcap(5)).
CN | Steuersequenz um den Cursor einzuschalten (wird verwendet, falls CO nicht definiert ist / RM-Cobol Norm).
CO | Steuersequenz um den Cursor einzuschalten (Microsoft Norm).
co | Anzahl Zeichen pro Zeile (css(U) kann nur mit co#80 arbeiten).
do | Steuersequenz um den Cursor eine Zeile nach unten zu bewegen (Cursor down).
ho | Steuersequenz um den Cursor auf der ersten BS-Stelle zu positionieren (Cursor home). Hier kann auch die cm-Steuersequenz für Zeile 1, Position 1 angegeben werden.
li | Anzahl Zeilen des BS (css(U) kann nur mit li#24 arbeiten).
pc | Ersatz-Zeichen, falls der BS Padding-Zeichen vorschreibt und das entsprechende Zeichen nicht hex 00 entspricht (wird sehr selten benötigt).
se | Steuersequenz für das Attribut 'normal video' (löschen aller Attribute und setzen auf 'low intensity').
so | Steuersequenz für das Attribut 'reverse, low intensity'.
ti | Steuersequenz um den BS für direkte Cursor-Adressierung zu initialisieren (wird selten benötigt).
te | Steuersequenz um die direkte Cursor-Adressierung abzuschliessen (wird selten benötigt).
up | Steuersequenz um den Cursor eine Zeile nach oben zu bewegen (Cursor up).
us | Steuersequenz für das Attribut 'underline'.
ws | Steuersequenz für das Attribut 'high intensity'.
ys | Steuersequenz für das Attribut 'blink'.

Tabelle 2-2: Termcap-Linegraphics

Gx | Definition der Line-Graphic Steuerung nach Microsoft Norm:
GS | Graphic-Start (Line-Graphic Modus einschalten)
GE | Graphic-End (Line-Graphic Modus ausschalten)
GH | horizontal Char
GV | vertical Char
GD | down Tic
GU | up Tic
GL | left Tic
GR | right Tic
GC | junction Char
G1 | upper right corner
G2 | upper left corner
G3 | lower left corner
G4 | lower right corner
gx | Definition der Line-Graphic Steuerung nach Unify Norm (gelangt zur Anwendung, falls die Definition gemäss Microsoft Norm nicht vorhanden ist):
gs | Graphic-Start (Line-Graphic Modus einschalten)
gx | Graphic-End (Line-Graphic Modus ausschalten)
gk | horizontal Char
gj | vertical Char
gn | down Tic
go | up Tic
gl | left Tic
gm | right Tic
gi | junction Char
gg | upper right corner
gf | upper left corner
ge | lower left corner
gh | lower right corner

Um das Programm css(U) zu veranlassen, für das Zeichnen von horizontalen Linien spezielle Grafikzeichen zu verwenden, müssen die GS, GE und GH Termcap-Eigenschaften definiert werden. Die folgende Tabelle enthält Beispiele solcher Definitionen für die am häufigsten verwendeten Terminals:

Terminal | Definition
xterm | :GS=^N:GE=^O:GH=q:\ if this does not render the desired results, try:
xterm | :GS=\E(B\E)0\E(B\E)U^N:GE=\E(B\E)0^O:GH=q:\
linux | :GS=\E(0:GE=\E(B:GH=q:\
ansi | :GS=\E[12m:GE=\E[10m:GH=D:\
vt100, vt220 | :GS=\E(0:GE=\E(B:GH=q:\

Bitte beachten Sie das Fortsetzungszeichen '\' am Ende jeder Definition. Es ist angefügt, um das Übertragen mit Cut und Paste zu erleichtern. Stellen Sie sicher, dass die in Termcap eingefügte Zeile NICHT am Ende einer Bildschirmdefinition zu stehen kommt. Falls dies trotzdem der Fall sein sollte, entfernen Sie das Zeichen '\' (Backslash).

Siehe auch

csa(U), css.devices(C), css.forms(C),
      inittab(5), mknod(1), setmode(U), termcap(5),
      tty(4), ttys(5)


Ulm

Unitec License Manager

ulm(I)
Synopsis Plattform Beschreibung Optionen Files Siehe auch

Synopsis

ulm [-a key -c name [-d date] -p prod -r rel -s serno] [-v]

Plattform

Unix, Windows NT

Beschreibung

Das ulm Programm ist die Hauptsteuerung des ULM Lizenz Managers. Seine Aktionen werden durch Optionen gesteuert, oder - falls keine Optionen angegeben wurden - im interaktiven Modus durch manuelle Eingabe. Eine Batch Serialisierung kann mittels Angabe aller Optionen -a, -c, -p, -r und -s durchgeführt werden.

Werden beim Aufruf keine Optionen angegeben, startet das ULM Lizenz Administrations Programm im interaktiven Modus.

Hauptmenu:

Unitec License Manager

Select Product:
1 - CSS Commercial Spooling System
2 - WinCss / CSS Windows Interface
3 - UDM Unitec Data Manager
q - Quit

Enter Selection:

Jede Menuwahl öffnet ein Untermenu oder fordert die Angabe von Installations-Parametern. Auf allen Ebenen bringt Sie die Eingabe von ‘q’ oder die <Return> Taste eine Stufe zurück resp. beendet das Programm.

Nach der Produkte-Wahl wird das nächste Menu sichtbar:

Unitec License Manager

Commands:
1 - Serialize <Product>
2 - Set <Product> License Unit Assignment
q - Quit

Enter Command:
Dabei zeigt <Product> den Namen des im Hauptmenu gewählten Produktes an.

Wahl 1 startet den Produkte Serialisierungs-Prozess (auch Branding genannt). Um diese Sektion erfolgreich durchzuführen, halten Sie bitte Ihren Activation Key bereit. Folgende Daten müssen eingegeben werden:

Aufforderung | Eingabe
Activation Key | Der Aktivierungs-Schlüssel besteht aus acht Zeichen und dient dazu, die weiteren Eingaben zu überprüfen. Der Schlüssel kann in Gross- oder Kleinschreibweise angegebenen werden.
Serial Number | Die Seriennummer des Produktes besteht aus drei Teilen, welche durch Bindestriche ‘–’ getrennt sind. Im ersten Teil steht die dem Kunden zugeteilte, eindeutige Produktnummer, der zweite Teil enthält den Lizenztyp und der dritte Teil zeigt die Anzahl Lizenzeinheiten, d.h. die Anzahl Benutzer, welche berechtigt sind, mit der Software zu arbeiten. Für fehlende Teile gelten vordefinierte Defaults.
Company Name | Kundenname. Um Probleme mit unterschiedlichen Zeichensätzen zu vermeiden, können Umlaute auch als ae, oe und ue angegeben werden.
Street Address | Adresszeile 2 (Strasse). Fehlt die Strassenangabe, muss ein Bindestrich ‘–’ eingegeben werden.
ZIP / City | Postleitzahl und Ortschaft.
Release Number | Releasenummer des Produktes.
Date Period | Wird für zeitlich begrenzte Demoversionen verwendet. Dieser Eingabe muss bei normalen Lizenzen nicht gemacht werden. Der Zeitbereich hat das Format jjjjmmtt–jjjjmmtt

Nachdem alle Angaben gemacht wurden, sind nochmals individuelle Modifikationen möglich. Die Eingabe wird mit der <Return> Taste abgeschlossen.

Wahl 2 erlaubt dem System-Administrator manuell Benutzer zu definieren, welche die Berechtigung habe, das entsprechende Produkt zu verwenden. Jede Benutzer-Identifikation besteht entweder aus der IP Adresse des Client-Systems (bei Client-Server Produkten wie WinCss und UDM), oder aus dem Devicenamen des aufrufenden Bildschirmes (für Unix Produkte wie CSS und CssLib).

Eine manuelle Zuweisung ist jedoch nicht notwendig. Beim aufstarten lokalisiert jedes Unitec Programm die Produkte Beschreibung in der Lizenz-Datenbank und durchsucht alle Lizenz-Einheiten nach der aktuellen Benutzer-Identifikation. Wird kein solcher Eintrag gefunden, erfolge eine automatische Zuweisung in die erste unbelegte Einheit. Sind alle Einheiten belegt, kann die Software von weiteren Benutzern nicht verwendet werden.

In seltenen Fällen, z.B. wenn das Netzwerk neu ausgelegt wird, oder eine IP Adresse geändert hat, kann der Eintrag einer Lizenz-Einheit geändert oder gelöscht werden.

Optionen

-a key | Aktivierungs-Schlüssel für Batch Branding.
-c name | Kunden-Information. Drei in Anführungszeichen gesetzte Teile müssen angegeben werden ‘Name:Strasse:Ort’. Fehlt die Strassenangabe, muss sie trotzdem leer vorhanden sein ‘Name::Ort’.
-d date | Zeitbereich der Gültigkeit jjjjmmtt-jjjjmmtt.
-p prod | Produkt CSS, WinCss oder UDM. Gross- oder Kleinschreibweise erlaubt.
-r rel | Releasenummer des Produktes.
-s serno | Seriennummer.
-v | Zeigt die Software-Version an.

Files

ulm.dat

Lizenz-Datenbank in ulm_base_dir

Siehe auch

ULM.DEFAULT(C)


Befehle

Kapitel 3 - Befehle

3.1. Übersicht

In diesem Kapitel ist die Funktionsweise aller CSS Programme ausführlich beschrieben. Müssen beim Betrieb spezielle Probleme gemeistert werden, dient es als primäre Informations-Quelle. Es folgt eine kurze Aufzählung der verfügbaren Programme:

Programm | Beschreibung
csa | Dient zur Administration aller Bereiche von CSS. Sollte weder vom Anwender noch zur Erledigung alltäglicher Funktionen eingesetzt werden.
css | Dialog-Programm zur Steuerung aller Verwaltungs-Aufgaben des Drucker-Betriebes. Ist speziell auf den End-Benutzer zugeschnitten.
cssdate | Hilfsprogramm zur Erzeugung eines Datums im CSS Format.
CssNTSrv | Windows NT Service Programm.
cssws | Windows Server Programm.
csu | Bietet eine etwas erweiterte Funktionalität des Programmes css. Ist eher auf den Entwickler zugeschnitten.
etr | Hilfsprogramm zur Einbettung von CSS Steuersequenzen in Textdateien.
fdu | Programm zur Erstellung von HP-LaserJet Makros für eine erweiterte Formulargestaltung.
lpdrestart | Administrations-Programm zur Reaktivierung blockierter Drucker.
lpr | Frontend zur Bereitstellung von Druckaufträgen.
setmode | Hilfsprogramm zur Konfiguration von seriellen Schnittstellen.
ulp | Hilfsprogramm zur Steuerung spezieller Druckeffekte bei Drucker-Modellen mit reduzierten Möglichkeiten.
WinCss | Grafisches Windows Steuerprogramm.


Csa

Administrator Utility

csa(U)
Synopsis Plattform Beschreibung Optionen Hinweise Siehe auch

Synopsis

/etc/csa option...
bin\csa option... (Windows NT)

Plattform

Unix, Windows NT

Beschreibung

Mit csa werden alle speziellen Arbeiten der Spooler-Verwaltung durchgeführt. Das Programm kann nur vom System-Administrator aufgerufen werden. Alle Reorganisations-Optionen (-RDSK) sollten nur mit äusserster Vorsicht, wenn möglich im Single-User-Mode, verwendet werden.

Optionen

-a | Ausgabe der Anzahl momentan aktiver Drucker auf den Standard-Output, sowie als Return-Code (Anwendung in Shutdown-Scripts).
-d | Compile-Lauf der in /etc/css.devices definierten Drucker.
-f | Compile-Lauf der in /etc/css.forms definierten Formulare.
-i dev | Start des Druckers dev falls bereit und Arbeit vorhanden. (Drucker die mit csu -s dev gestoppt wurden, werden nicht gestartet.)
-I | Start aller bereiten Drucker falls Arbeit vorhanden.
-k date | Löschen aller gedruckten Auswertungen mit Keep-Datum date und älter (Datum-Format: jjjjjmmtt / siehe auch cssdate).
-K date | Löschen aller Auswertungen mit Keep-Datum date und älter. Diese und die obige Funktion kann auch via css.default(C) automatisch durchgeführt werden.
-l file | Auswertungs-File file (UNIX Filename) am Bildschirm ausgeben. Zeilen über 80 Zeichen werden dabei abgeschnitten.
-L file | dito. / ohne Reduktion der Zeilenlänge.
-x dev | Aktivieren des Druckers dev (Durch diese Option werden auch gestoppte (on hold) oder aus irgendwelchen anderen Gründen nicht mehr ansteuerbare Drucker aktiviert. Siehe auch lpdrestart).
-X | Aktivieren aller Drucker.
-D | Initialisierung und - falls nötig - Reorganisation der Druckerverwaltung. Ist die Steuerdatei korrupt und kann deshalb nicht mehr reorganisiert werden, muss sie mit rm /usr/lib/css/dev (CssNT: del lib\dev) gelöscht und mit csa -d neu erstellt werden.
-E file | Auswertungs-File file (UNIX Filename) auf den Standard-Output ausgeben. (Bei der Ausgabe wird eine Dekomprimierung durchgeführt. Häufigste Anwendung: Recovery von verlorenen Auswertungen mittels einer Pipe csa -E file | lpr...).
-R | Initialisierung und - falls nötig - Reorganisation der Auswertungs-Warteschlange. Ist die Steuerdatei korrupt und kann deshalb nicht mehr reorganisiert werden, muss sie mit rm /usr/lib/css/rep (CssNT: del lib\rep) gelöscht und mit csa -R neu erstellt werden.
-S | Kurzform für -RDi 1.
-U | Generiert CSS Wiederherstellungs-Befehle für die aktuelle Auswertungs-Warteschlange.
-y dev | Zeigt Definitionsparameter für Drucker dev.
-Y | Zeigt Definitionsparameter für alle Drucker.
-z form | Zeigt Definitionsparameter für Formular form.
-Z | Zeigt Definitionsparameter für alle Formulare.

Hinweise

Csa wird unter Unix in der Regel im File /etc/rc, nach der Bestimmung des Systemdatums aufgerufen:

csa -RDK `cssdate` -i 1;
oder, falls die Auswertungs-Verwaltung mittels Keep-Datum nicht verwendet wird:
csa -S;

Siehe auch

cssdate, css.default(C), csu, lpdrestart, lpr


Css

User Interface

css(U)
Synopsis Plattform Beschreibung Optionen Hinweise Siehe auch Dialog

Synopsis

css [-a] [-d devlist] [-f] [-l n] [-s] [-u] [-w] [-x] [-L lang] [-5]

Plattform

Unix, Windows NT

Beschreibung

Mit css können alle bei der Spooler-Verwaltung anfallenden Arbeiten wie z.B.: Status-Abfragen, Formular-Wechsel, Prioritäten-Steuerung usw. in einem einfachen, benutzerfreundlichen Dialog erledigt werden.

Folgende Hauptfunktionen sind verfügbar:

Formular-Wechsel | vorgenommenen Formularwechsel dem Spooler mitteilen und Testdruck starten
Drucker-Steuerung | Drucker stoppen, Druckvorgang abbrechen, Drucker starten
Warteschlange | Auswertung beschleunigen, blockieren (Druck aufschieben), zum Druck freigeben, umleiten, stoppen, anzeigen und löschen

Die Sprache des CSS Dialoges kann mittels L-Option und den langenv und language Parametern in CSS.DEFAULT(C) gsteruert werden. Das erste Zeichen des Options- resp. Variablen-Inhaltes dient dabei als Bestimmung der Sprache:

d, D | Holländisch (Dutch)
g, G | Deutsch (German)
e,E, Default | English
f,F | Französisch
i, I | Italienisch

Das Format des im Dialog dargestellten Datums kann mit der Environment-Variablen DATETP auf dieselbe Weise gesteuert werden:

AM, US | MM/DD/YY
IN | YY/MM/DD
EU, Default | DD.MM.YY

Zur Steuerung der Sprache und des Datum-Formates siehe auch unter css.default(C).

Optionen

-a | Im Bild 'Warteschlange' werden nur die Auswertungen angezeigt, auf die Zugriffsberechtigung besteht.
-d devlist | Diese Option schränkt den Zugriff im 'Druckersterung' Dialog auf die in devlist angegebenen Drucker ein. Devlist wird als eine durch Kommas getrennte Menge von Druckernummern angegeben. Leerstellen sind dabei nicht zugelassen. Die Option kann auch pro Benutzer in der Datei ~/.cssrc gestzt werden.
-f | 'fast mode' / Bildschirm-Eingaben müssen nicht mit <Return> abgeschlossen werden. Eine Eingabe gilt als beendet, sobald das Eingabefeld vollständig gefüllt ist (Default).
-l n | setzt die Anzahl Zeilen des Bildschirmes auf n.
-s | 'slow mode' / Bildschirm-Eingaben müssen mit <Return> abgeschlossen werden.
-u | Im Bild 'Warteschlange' werden nur die Auswertungen angezeigt, die mit derselben User-ID erstellt wurden.
-w | Schlägt die Navigation von der letzten Seite auf die erste Seite einer Bildfolge vor. Diese Option kann auch global mit dem Parameter WRAP_SCREEN in css.default(C) gesetzt werden.
-x | Zeigt die Auswertungen im Bild 'Warteschlange' in umgekehrter Prioritätsfolge.
-L lang | setzt die Sprache des Dialoges auf lang. Siehe auch oben.
-n | Bei der Aktion 'Drucker-Verwaltung' ist eine automatische Aktualisierung des Bildschirminhaltes vorgesehen (Monitor Funktion). Das Default Zeitintervall ist 5 Sekunden (0 = keine Aktualisierung).

Hinweise

Die Bildschirmnummer im Bild 'Warteschlange' entspricht den letzten zwei Zeichen des via ttyname(3) ermittelten Device-Namens resp. co für /dev/console.
Drucker-Status | Bedeutung
*bereit* | wartend, ohne Arbeit
*aktiv* | druckend
*besetzt* | Drucker wird von einem anderen virtuellen Server oder Softwarepaket mit integriertem Spooler benutzt (siehe auch el-Eintrag im css.devices(C))
*stopp* | druckend, Drucker wird nach der aktuellen Auswertung gestoppt
*gestoppt* | Drucker gestoppt / bedeutet bei parallelen Schnittstellen auch 'offline'
*umgeleitet* | Drucker auf den in der Kolonne 'Auswertung' angegebenen Device umgeleitet

Bei der Anzeige von Auswertungen am Bildschirm werden Folgen von mehreren Leerzeilen komprimiert und zusammengefasst.

Die Bildschirm-Steuerung von css ist sehr sorgfältig ausgetestet. Bei ungewöhnlichem Verhalten ist die Definition in /etc/termcap zu überprüfen. Css ist nur für Terminals mit Cursor-Steuerung geeignet. Um das Erscheinungsbild der css Bildschirme zu verbessern, können Sie in der Termcap-Definition Ihres Bildschirms die Steuerzeichen für Semigrafik eingeben. Für weitere Information und Beispiele siehe setup(I), Abschnit Hinweise.

Css Optionen können auch in der Datei $HOME/.cssrc sowie in der Shell Environment-Variablen CSSOPT gesetzt werden. Die Reihenfolge der Evaluation ist unter Abschnitt 'Befehlszeilen’ auf Seite 1-4 beschrieben.

Siehe auch

csu, setup(I), termcap(5)

Dialog

Um die Dialogbeschreibung möglichst kompakt zu halten, sind die folgenden Bildschirm-Masken z.T. in der Höhe verkleinert dargestellt.

Auswahl-Menu

CSS                Spooler-Verwaltung      Datum: 12.01.98
ID: root           Aktions-Wahl

           Action: 1 Formular-Wechsel
                   2 Drucker-Steuerung
                   3 Warteschlange
                   4 CSS-Info

             Wahl: . (0 = Ende)

1. Formular-Wechsel

CSS-Spooler        Spooler-Verwaltung      Datum: 12.01.98
ID: root           Formular-Wechsel
DNr Bezeichnung             Status         Formular

1   Siemens PT 89           *bereit*       L
2   Brother HL-8            *gestoppt*     A
3   Daisy M45               *aktiv*        A

Wahl: ... (0 = Ende)

Der Formular-Wechsel dient dazu, der Drucker-Verwaltung einen vorgenommenen Papier-Wechsel mitzuteilen. Als erstes wird der betroffene Drucker ausgewählt.

Als nächstes wird eine Auswahl der möglichen Formulare angezeigt. Das momentan aktive Formular ist im Statusbereich ersichtlich.

Durch die Wahl des Formular-Namens wird das gewünschte Formular zugeteilt und der Drucker aktiviert.

CSS-Spooler        Spooler-Verwaltung      Datum: 12.01.98
ID: root           Formular-Wechsel
Drucker:   2 / Brother HL-8
Formular:  A / Zebra A4-Quer            Status: *gestoppt*
A   / Zebra A4-Quer
B   / Zebra A4-Hoch
C   / Zebra A3-Quer
G   / Giro-Formular
K   / Karteikarten A5
L   / Lieferscheine
M   / Mahnungen
P   / Paketetiketten
R   / Rechnungen/Gutschriften
VSR / VESR Einzahlungsscheine
Wahl: ... (0 = Ende)

Nach der Formularwahl folgt die Frage:

» Testdruck ? . (j/n)

und falls mit ja geantwortet wurde:

» Anzahl Seiten: 1

2. Drucker-Steuerung

CSS-Spooler      Spooler-Verwaltung        Datum: 12.01.98
ID: root         Drucker-Steuerung
DNr Status       Auswertung   Seite/von Kopie/von  MKZ  BS

1   *aktiv*      Mahnungen    5/23      1/1        Mad  2
2   *gestoppt*
3   *bereit*
Wahl: ... (0 = Ende)

Je nach Druckerstatus werden folgende Aktionen zur Auswahl vorgeschlagen:

  • Drucker inaktiv setzen
  • Drucker aktivieren
  • Formular-Wechsel
  • Umleiten der aktuellen und zukünftiger Auswertungen auf einen anderen Drucker

    auf diese Aktion folgt die Frage:

    » Umleiten auf Drucker: ...
  • Ausdruck stoppen

    auf diese Aktion folgt die Frage:

    » Auswertung für späteren Druck aufbewahren ? . (j/n)

Mit der <Tab> Taste kann auf eine alternative Form der Darstellung gewechselt werden. Eine nochmalige Betätigung der Taste stellt den Bildschirm auf den Ursprungszustand zurück.

Um einen Papier-Wechsel vorzunehmen, sollte der betreffende Drucker inaktiv gesetzt werden. Damit wird verhindert, dass während des Wechsels ein Ausdruck gestartet wird. Der vorgeschlagene Ablauf ist:

  1. Drucker inaktiv setzen
  2. Papierwechsel am Drucker vornehmen
  3. Formularwechsel und ev. Testdruck durchführen

3. Warteschlange

CSS-Spooler        Spooler-Verwaltung         Datum: 12.01.98
ID: root           Warteschlange
Nr  Auswertung      Frm St DNr  Seiten Kop. Datum  Zeit  MKZ

1   /etc/passwd     A   B            1   1  11.01  16:58 root
2   Kunden-Umsatz   A               48   1  12.01  14:24 Mad
3   Währungskurse   A                1   2  12.01  14:24 VN
4   Lieferscheine   L      2       107   1  12.01  11:55 BS
5   Mahnungen       M   D  1        23   1  12.01  15:08 Mad

> Frm Formular / St Status: D = druckend, B = blockiert / Dr Drucker

Wahl: . (0 = Ende)

Je nach Auswertungsstatus werden folgende Aktionen zur Auswahl vorgeschlagen:

  • Ausdruck beschleunigen
  • Auswertung umleiten

    auf diese Aktion folgt die Frage:

    » Umleiten auf Drucker: . (0 = beliebiger Drucker)
  • Auswertung löschen
  • Auswertung am Bildschirm zeigen
  • Auswertung blockieren
  • Auswertung freigeben

    auf diese Aktion folgen die Fragen:

    » Druck ab Seite: 1
    » Druck bis Seite: x
    » Anzahl Kopien: 1
    » Auswertung nach Druck aufbewahren: . (j/n)
  • Ausdruck stoppen

    auf diese Aktion folgt die Frage:

    » Auswertung für späteren Druck aufbewahren ? . (j/n)

Zusätzlich kann mit der Eingabe von i weitere Information verlangt und mit der Wahl s Selektions-Kriterien zur Reduktion der angezeigten Auswertungen gesetzt werden. Im Selektions-Dialog können mit a Aktionen auf die ausgewählte Gruppe durchgeführt werden. Bei Lösch-Operationen werden Auswertungen mit Keep-Datum nicht berücksichtigt.

Binäre Auswertungen (lpr B-Option) und Auswertungen die einem binären Drucker zugewiesen wurden, können nicht am Bildschirm angezeigt werden. Bei allen anderen stehen folgende Anzeige-Aktionen zur Verfügung:

Befehl | Aktion
a, HOME | erste Seite zeigen
z, END | letzte Seite zeigen
+, PGDN | vorwärts blättern
–, PGUP | rückwärts blättern
d, â | Zeile vorwärts
u, á | Zeile rückwärts
g, p | gehe nach Seite...
t, TAB | Anzeige-Fenster abwechslungsweise an den rechten und linken Rand schieben
l, L, ß, BACKSP Anzeige-Fenster nach links schieben um:
Key | Anz. Positionen
BACKSP | 1
ß | 5
l | 20
L | 40
r, R, à, SPACE Anzeige-Fenster nach rechts schieben um:
Key | Anz. Positionen
SPACE | 1
à | 5
r | 20
R | 40
=, / Text suchen: = mit, / ohne Unterscheidung zwischen Gross- und Klein-Schreibweise
n | letzte Suche wiederholen
i | Information anzeigen
s | Zeichen- und Zeilenlineal ein- resp. ausblenden (scale)
h, ?, HELP | Hilfe anzeigen
0, q | Anzeige beenden

Alle obigen Funktionen können ohne Spezialtasten durchgeführt werden. Um alle Möglichkeiten auszuschöpfen, müssen unter Unix in /etc/termcap jedoch folgende Definitionen vorhanden sein:

Termcap-Name | Zeichen-Sequenz der Taste...
kl | Cursor left
kr | Cursor right
ku | Cursor up
kd | Cursor down
kh | Home
ke | End
kp | Page Up
kn | Page Down
KH | Help (oder k1)


CssDate

Date Utility

cssdate(U)
Synopsis Plattform Beschreibung Optionen Hinweise Siehe auch

Synopsis

cssdate [-n] [+m]

Plattform

Unix, Windows NT

Beschreibung

Das Programm cssdate schreibt das Systemdatum im Format yyyymmtt auf seinen Standard-Output. Spezielle Anwendung in Shell-Scripts mit den Programmen lpr (k-Option) und csa (K-Option).

Optionen

-n | das Ausgabedatum wird um n Tage vermindert
+m | das Ausgabedatum wird um m Tage erhöht

Hinweise

Um z.B. unter Unix eine Spooler-Verwaltung einzurichten, die jede Auswertung bis zum Morgen des übernächsten Arbeitstages aufbewahrt, ist wie folgt vorzugehen:

  1. Das lpr Programm wird umbenannt:

    mv /bin/lpr /bin/lpr.css;
  2. Ein Shell Script /bin/lpr übernimmt dessen Platz:

    /bin/lpr.css -k `cssdate +    1` $@;
  3. Im File /etc/rc wird das csa Programm nach dem Initialisieren des Systemdatums aufgerufen:

    csa -RDK `cssdate` -i     1;

Siehe auch

csa, lpr


CssNTSrv

Windows NT Service

CssNTSrv(U)
Synopsis Plattform Beschreibung Optionen Hinweise Files Siehe auch

Synopsis

CssNTSrv [-i][-u]

Plattform

Windows NT

Beschreibung

CssNTSrv versorgt als NT Service Prozess das WinCss grafische Interface mit aktuellen Daten und steuert den Ausdruck auf alle CSS Drucker (lpd Despooler unter Unix). Dieses Programm wird beim Systemboot automatisch gestartet.

Optionen

-i | Installiert das Programm als Windows NT Service. Dies wird in der Regel vom Setup Programm durchgeführt. Die Programmbezeichnung im Control Panel Services Applet ist CssNT.
-u | Stoppt das Service Programm und entfernt es aus der Windows NT Service Verwaltung.

Hinweise

Treten Funktionsstörungen auf, kann mit dem NT Event Viewer im Application Log nach Hinweisen gesucht werden. Ausserdem werden in der Datei lib\CssErrlog.txt fehlerhafte Verarbeitungen protokolliert.

Kann CssNT nicht mehr betrieben werden, sollte im Control Panel, Services Applet, überprüft werden, ob der CssNT Prozess aktiv ist. Der Service kann gegebenenfalls manuell neu gestartet werden.

Die Funtionalität von CssNTSrv ist bei Unix Css in den Programmen cssws und lpd implementiert.

Files

lib\CssErrlog.txt

Service Error Log

Siehe auch

cssws, WinCss(C)


CssWs

Windows Server

cssws(U)
Synopsis Plattform Beschreibung Optionen Hinweise Files Siehe auch

Synopsis

cssws [-i]

Plattform

Unix

Beschreibung

Cssws versorgt als Server-Prozess das WinCss grafische Interface mit aktuellen Daten. Dieses Programm wird normalerweise beim Systemstart via /etc/rc(4) oder /etc/inittab(4) aktiviert. Konfigurations-Details sind unter WinCss(C) beschrieben.

Optionen

-i | Diese Option muss gesetzt werden, falls cssws unter der Kontrolle des inetd(1) Super-Servers gestartet wird.
-p port | Definiert die zu verwendende TCP/IP Portnummer. Default is 6801, resp. der im css.default(C) Parameter WINCSS_PORT definierte Wert.
-r secs | Definiert die Aktualisierungsrate in Sekunden. Der Vorgabewert ist 5.

Hinweise

Die Funtionalität von cssws ist bei CssNT im CssNTSvr Service Programm integriert.

In der Regel wird cssws durch einen standart Systemservice aufgestartet:

/etc/rc

/usr/lib/css/cssws 2>/dev/null 1>&2

Nur Unix System V

Dieselbe Verarbeitung kann unter System V durch folgenden Eintrag in /etc/inittab(4) erreicht werden:

cssws:1:respawn:/usr/lib/css/cssws 2>/dev/null 1>&2

Internet Super Server (inetd)

Da der Internet Superserver inetd(1) symbolische Service Namen erwartet, muss in der Datei /etc/services folgende Zeile eingefügt werden:

cssws   6801/tcp    # WinCss server

Danach fügen Sie folgende Zeilen in der Datei /etc/inetd.conf ein:

# CSS Service
cssws stream tcp nowait root /usr/lib/css/cssws -i

Files

/usr/lib/css/css.errlog

Server daemon error log

Siehe auch

CssNTSrv, WinCss(C)


Csu

Spooler Utility

csu(U)
Synopsis Plattform Beschreibung Optionen Hinweise Siehe auch

Synopsis

csu [option...]

Plattform

Unix, Windows NT

Beschreibung

Mit csu können alle bei der Spooler-Verwaltung anfallenden Arbeiten wie z.B.: Status-Abfragen, Formular-Wechsel, Prioritäten-Steuerung usw. erledigt werden.

Optionen

-a | Ausgabe der Anzahl momentan aktiver Drucker auf den Standard-Output, sowie als Return-Code (Anwendung in Shutdown-Scripts).
-c rep:n | Anzahl zu druckende Kopien von Report rep auf n ändern.
-d | Ausgabe des aktuellen Drucker-Status (Normalformat)
-D | dito. Spezialformat
-E rep | Report rep ungedruckt aus seiner Formular-Queue löschen.
-f | Ausgabe der verfügbaren Formulare
-g r[:n] | Report r ab Seite n zum Druck freigeben (go)
-h rep | Hold (nonprinting) Report rep.
-H dev:r | Stop Ausdruck Report r auf Drucker dev; setze Report (Liste) in hold.
-i dev | Start (init) Drucker dev (1..999 oder Name)
-I | Start (init) aller Drucker.
-k dev:r | Kill Report y auf Drucker dev. Die Report-Nr r wird angegeben um zu verhindern, dass versehentlich ein falscher Report (Liste) abgebrochen wird.
-K d[:r] | wie Option k; die Report-Nr r ist jedoch fakultativ.
-l rep | Report rep am Bildschirm ausgeben; Zeilen über 80 Zeichen werden dabei abgeschnitten.
-L rep | dito., jedoch ohne Reduktion der Zeilenlänge.
-m dev:f | Mount Formular f auf Drucker dev.
-o dev1:dev2 | Leitet alle aktuellen und zukünftige Auswertungen für Drucker dev1 auf Drucker dev2 um. Die Umleitung kann durch die Eingabe desselben Wertes für dev1 und dev2, d.h. durch eine Umleitung auf sich selbst, aufgehoben werden.
-p f[:m] | Ausgabe der Anzahl Zeilen und der Zeilenlänge des Formulars f. Ist m=p, wird nur die Anzahl Zeilen ausgegeben. Ist m=l, wird nur die Zeilenlänge ausgegeben.
-q | Ausgabe der Report-Queue
-Q | dito. mit Programmname, jedoch ohne Bildschirm-Nr und Zeit
-r dev | Umleiten (route) des Reports r auf Drucker dev (0..999)
-R dev:f | Umleiten aller Reports mit Formular f auf den Drucker dev.
-s dev | Stop (hold) Drucker dev nach dem Ausdruck
-S dev | Kill Ausdruck und Stop Drucker dev
-t | Zeigt die Report-Queue in einem Format, welches das Keep-Datum enhält.
-T | Zeigt alle Auswertungen, welche mit einem Keep-Datum versehen sind.
-w f | Löschen aller Auswertungen mit Zugriffsberechtigung und Formular f.
-W | Löschen aller Auswertungen mit Zugriffsberechtigung. Warnung: csu -W mit User-ID root löscht alle pendenten Auswertungen!
-x f | Löschen aller Auswertungen mit Zugriffsberechtigung und Formular f. Im Gegensatz zur w-Optionen wird das Keep-Datum ignoriert.
-X | Löschen aller Auswertungen mit Zugriffsberechtigung. Im Gegensatz zur W-Optionen wird das Keep-Datum ignoriert. Warnung: csu -W mit User-ID root löscht alle pendenten Auswertungen!
+ rep | Report rep mit der höchsten Priorität innerhalb seiner Formular-Queue versehen.

Hinweise

Default-Option ist -q.

Die in einigen Optionen verwendete Report-Nummer wird von CSS automatisch verteilt (in freier Folge) und ist mit csu -d oder csu -q zu ersehen.

Informationen bei Verwendung der Optionen d und D:

D | logische Drucker-Nummer (1..999)
F | aktuelles Formular
Status
**waiting** | aktiv, ohne Arbeit
**on hold** | gestoppt (auch 'offline')
**locked** | gesperrt (via Lock-File)
**starting** | am Aufstarten
**report nn** | druckend / Auswertung nn
**routed** | umgeleitet auf den in der Kolonne 'Report' angegebenen Drucker
Report | Auswertungs-Bezeichnung (falls eingegeben)
No | Report-Nr (falls Drucker aktiv)
Who | Mitarbeiter-Kurzzeichen
TT | Bildschirm-Nr
Program | Programm-Name (falls eingegeben)
Date | System-Datum (MMJJ)
Copy | Anzahl Kopien (gedruckt : zu drucken)
Page | Anzahl Seiten (gedruckt : zu drucken)

Informationen bei Verwendung der Option f:

F | Formular-Bezeichnung
D | logische Drucker-Nr (0 = beliebiger Drucker)
PP | Page-Parity (yes/no)
PS | Anzahl Zeilen pro Seite (bei 6 LPI)
LL | Anzahl Zeichen pro Zeile (bei 10 CPI)

Informationen bei Verwendung der Optionen q und Q:

F | Formular
Report | Auswertungs-Bezeichnung (falls eingegeben)
No | Report-Nr (zur Verwendung bei div. Optionen)
Status: | ' ' | ungedruckt
 | 'P' | druckend auf Drucker D
 | 'H' | on hold / gestoppt
 | 'K' | gedruckt / keeping (lpr -k xx)
D | logische Drucker-Nr (0 = beliebiger Drucker)
Who | Mitarbeiter-Kurzzeichen
TT | Bildschirm-Nr
Program | Programm-Name (falls eingegeben)
Date | System-Datum (MMJJ)
Time | System-Zeit (HH:MM)
Cpys | Anzahl Kopien
Page | Anzahl Seiten

Informationen bei Verwendung der Optionen t und T:

F | Formular
Report | Auswertungs-Bezeichnung (falls eingegeben)
No | Report-Nr (zur Verwendung bei div. Optionen)
Status: | ' ' | ungedruckt
 | 'P' | druckend auf Drucker D
 | 'H' | on hold / gestoppt
 | 'K' | gedruckt / keeping (lpr -k xx)
D | logische Drucker-Nr (0 = beliebiger Drucker)
Who | Mitarbeiter-Kurzzeichen
TT | Bildschirm-Nr
keepdate | Aufbewahrungsdatum der Auswertung
Date | System-Datum (MMJJ)
Cpys | Anzahl Kopien
Page | Anzahl Seiten

Siehe auch

csa, css, lpdrestart, lpr


Etr

Escape Translator

etr(U)
Synopsis Plattform Beschreibung Optionen Hinweise Beispiele Siehe auch

Synopsis

etr [-s] [-n] [-e1 x] [...] [-e127 x] [file...]

Plattform

Unix, Windows NT

Beschreibung

Etr liest die angegebenen Files (oder den Standard-Input, falls file fehlt) und übersetzt Zeichenfolgen x (1 bis 5 Zeichen) in die entsprechenden CSS Steuersequenzen (e1: ESC,1 / e2: ESC,2 / usw.).

Etr ist speziell dazu geeignet, in Textfiles die zur Druckersteuerung notwendigen Spezialzeichen einzubetten.

Etr bietet mit der s-Option die Möglichkeit, Standartzeichenfolgen zu verwenden:

e1 | @1 | Schreibdichte 10 CPI (characters per inch)
e2 | @2 | Schreibdichte 12 CPI
e3 | @3 | Schreibdichte 16.5 CPI
e4 | @4 | Schreibdichte 16.5 CPI (falls unterstützt)
e5 | +% | Korrespondenz-Qualität ein
e6 | –% | Korrespondenz-Qualität aus
e7 | +! | 'Near-letter'-Qualität ein
e8 | –! | 'Near-letter'-Qualität aus
e9 | +^ | Breitschrift ein
e10 | –^ | Breitschrift aus
e11 | +/ | Schrift 'italic' ein
e12 | –/ | Schrift 'italic' aus
e13 | +_ | Unterstreichen ein
e14 | –_ | Unterstreichen aus
e15 | +> | Halbzeile rückwärts (superscript)
e16 | –> | Halbzeile vorwärts (reset superscript)
e17 | +< | Halbzeile vorwärts (subscript)
e18 | –< | Halbzeile rückwärts (reset subscript)
e19 | +# | Zweit-Zeichensatz laden
e20 | –# | Erst-Zeichensatz zurückladen

Optionen

-s | Die oben aufgeführten Standartzeichenfolgen werden verwendet. Die Wirkung dieser Option ist gleich, wie wenn an derselben Stelle in der Befehlszeile die entsprechenden e1..e20 Optionen eingegeben worden wären. Diese Option ist ab Release 2.7 als Default gesetzt.
-n | Die oben aufgeführten Standartzeichenfolgen werden nicht verwendet.
-e1 x | Die Zeichenfolge x (1 bis 5 Zeichen) wird in die Zeichen ESC,1 übersetzt. Sinngemäss können -e2..-e127 definiert werden. Bei mehrmaliger Verwendung der gleichen Option gilt die in der Befehlszeile zuletzt eingegebene. Beginnt die Zeichenfolge x mit dem ASCII up-arrow "^", erkennt etr die weiteren (max. 4) Zeichen nur an einem Zeilenanfang (siehe Beispiel). Das Zeichen "^" selbst, muss an erster Stelle als "\^" eingegeben werden. Um Kollisionen mit Shell-Metazeichen zu vermeiden, ist es sinnvoll, die Zeichenfolgen in ASCII single-quotes "'" einzubetten.

Hinweise

Um unerwünschte Effekte zu verhindern, schreibt die Unix Version von etr nicht auf Bildschirm-Terminals. Für Monitorzwecke kann die Ausgabe mit etr | cat erzwungen werden.

Etr-Optionen können auch in der Datei $HOME/.etrrc sowie in der Shell Umgebungsvariablen ETROPT gesetzt werden. Die Reihenfolge der Evaluation ist unter Abschnitt 'Syntax der Befehlszeilen' auf Seite 1-4 beschrieben.

Die meisten Möglichkeiten von etr können auch mit dem tr-Eintrag der Drucker-Definition gelöst werden. Etr erlaubt hingegen, je nach Anwendungsgebiet, verschiedene Steuerzeichen zu benutzen.

Beispiele

etr -s <<!! | lpr
E = mc+>2–> / Copyright (C) 1916 by Albert +_Einstein-_ !
!!

Ausgabe:

E = mc2 / Copyright (C) 1916 by Albert Einstein!

etr -e13 '^.ul ' -e14 '^.ue ' <<!! | lpr
Das folgende Wort soll
.ul unterstrichen
.ue werden.
!!

(Hinweis: Die erste Eingabezeile enthält nach dem Wort 'soll' ein Leerzeichen.)

Ausgabe:

Das folgende Wort soll unterstrichen werden.

etr -e17 '\^-' -e18 '\^+' <<!! | lpr
Die chemische Bezeichnung von Wasser ist H^–2^+O.
!!

Ausgabe:

Die chemische Bezeichnung von Wasser ist H2O.

Siehe auch

css.devices(C), ulp


Fdu

Form Definition Utility

fdu(U)

Synopsis Plattform Beschreibung Optionen FDU Befehle Integration Hinweise Files Siehe auch

Synopsis

fdu [-I path] [-o file] [file]...

Plattform

Unix, Windows NT

Beschreibung

Das Programm fdu liest die im Aufruf angegebenen Files und übersetzt die darin enthaltenen Befehle in HP LaserJet II Steuersequenzen. Sind keine Files angegeben, verarbeitet fdu den Standard-Input. Das Resultat wird auf das via o-Option angegebene File resp. auf den Standard-Output ausgegeben.

Mit Hilfe der fdu-Befehle Macro und End_macro können LaserJet-Programme definiert werden, welche anschliessend durch den Load-Befehl aktiviert, d.h. auf jeder gedruckten Seite durchgeführt werden. Es kann gleichzeitig nur immer ein Macro aktiv sein: jeder Load-Befehl wirkt wie die Sequenz unload; load #;. Es ist jedoch ohne weiteres möglich, innerhalb derselben Auswertung verschiedene Macros in Sequenz zu laden (z.B. ein Seitenlayout für eine Statistik und ein zweites für deren Rekapitulation). Mit Hilfe des Include-Befehles können Macro-Bausteine zusammengefasst werden.

Die LaserJet Programmierung hat grosse Ähnlichkeit mit der Erstellung eines Bildschirm-Layouts. Die verschiedenen Fonts (Schriftarten) und Typefaces (Schriftbilder) stellen die Attribute dar. Der imaginäre Cursor kann mit dem Move-Befehl an jede gewünschte Stelle gebracht werden. Als Masseinheit dient dazu der sog. Punkt:

Punkte | Umrechnung
1 | 0.084666 mm
300 | 1 Inch (Zoll) / 25.4 mm
12 | ~ 1 mm
36 | 1 Zeichen bei 8.3 CPI (horizontal)
30 | 1 Zeichen bei 10 CPI
25 | 1 Zeichen bei 12 CPI
18 | 1 Zeichen bei 16.66 CPI
50 | 1 Zeile bei 6 LPI (vertikal)
37.5 | 1 Zeile bei 8 LPI

Optionen

-o file | Die Ausgabe erfolgt auf die Datei file (Default stdout)
-I path | Der angegebene Pfad wird verwendet um include-Dateien zu finden. Es können mehrere -I Optionen angegeben werden. Siehe auch FDUPATH unter Hinweise.

FDU Befehle

Fdu kennt folgende Befehle:
b_include file | An der entsprechenden Stelle wird das binäre File file ohne weitere fdu-Bearbeitung eingesetzt. Damit können z.B. mittels Scanner erzeugte LaserJet kompatible Files mit Firmen-Logos ausgegeben werden. Enthält der Name von file Sonderzeichen, muss er als String (z.B. "logo.mac") definiert werden.
box y, x | Zeichnet ein Rechteck mit einer Kantenlänge von y vertikalen und x horizontalen Punkten. Als Strichdicke wird der via Line_points-Befehl definierte Wert verwendet (Default 1). Die Position des Cursors bleibt unverändert.
charset id Wählt für die Textausgabe den Zeichensatz id. Die gültigen Zeichensätze sind in /usr/lib/css/fdu/charset definiert:
ansi_ascii | ISO 6 ANSI ASCII
french_25 | ISO 25 French
german | HP German
german_21 | ISO 21 German
ibm_pc | IBM-PC USA
ibm_norw | IBM Norwegian
roman_8 | Roman-8

Die entsprechenden sekundären Zeichensätze sind mit dem Präfix s_ versehen (z.B. s_ibm_pc).

copys #
copies # 		Anzahl Kopien, die von jeder Seite gedruckt werden sollen.
cpi id Wählt die für die Textausgabe gültige Zeichendichte in Zeichen pro Inch. Die gültigen Werte für id sind in /usr/lib/css/fdu/charpitch definiert:
8 | 8.3 CPI
10 | 10 CPI
12 | 12 CPI
16 | 16.66 CPI
c_move [[{+|-}]y][,[{+|-}]x] | Bewegt den imaginären Cursor an die Zeichen-Postion mit den Koordinaten y vertikal und x horizontal (character position move). Ist ein Koordinaten-Wert mit einem Vorzeichen angegeben, erfolgt eine relative Bewegung um die angegebene Anzahl Zeilen nach oben (-y) oder unten (+y), resp. um Zeichen-Positionen nach links (-x) oder rechts (+x). Fehlende Werte werden mit der Koordinate der gegenwärtigen Position substituiert und bewirken demnach keine Bewegung in der entsprechenden Richtung. Alle übrigen Positions-Befehle von fdu verwenden als Einheit den Punkt (300x300).
data d [[,] d]... Gibt die mittels den angegebenen Parametern definierten Daten auf das Output-File aus. Gültige Parameter-Typen für d sind:
'abc' Text-String abc. Strings können die von der Sprache C bekannten Escape-Folgen enthalten:
\a, \b, \f, \n, \r, \t, \v, \\, \', \", \xXXX, \OOO
wobei
XXX = 1..3 Hex-Zahlen
OOO = 1..3 Oktal-Zahlen
"abc" | dito.
123 | Byte (dezimal 0..255)
0123 | Byte (oktal 0..377)
0x12 | Byte (hex 0..ff)
ctl ASCII Kontrollzeichen Synonym:
Synonym | hex | Ctl
nul | 00 | ^@
soh | 01 | ^A
stx | 02 | ^B
etx | 03 | ^C
eot | 04 | ^D
enq | 05 | ^E
ack | 06 | ^F
bel | 07 | ^G
bs | 08 | ^H
ht | 09 | ^I
lf | 0a | ^J
nl | 0a | ^J
vt | 0b | ^K
ff | 0c | ^L
cr | 0d | ^M
so | 0e | ^N
si | 0f | ^O
dle | 10 | ^P
dc1 | 11 | ^Q
dc2 | 12 | ^R
dc3 | 13 | ^S
dc4 | 14 | ^T
nak | 15 | ^U
syn | 16 | ^V
etb | 17 | ^W
can | 18 | ^X
em | 19 | ^Y
sub | 1a | ^Z
e | 1b | ^[
esc | 1b | ^[
fs | 1c | ^\
gs | 1d | ^]
rs | 1e | ^^
us | 1f | ^_
sp | 20 | ^`
del | 7f |

Die Kommas zwischen den einzelnen Data-Argumenten sind fakultativ. Der Cursor befindet sich nach dem Data-Befehl am Ende des generierten Textes.

eject | Bewirkt einen Seitenvorschub
end_macro | Schliesst die mit dem Macro-Befehl eingeleitete Makro-Definition ab.
font id Wählt die für die Textausgabe gültige Schriftart. Die gültigen Werte für id sind in /usr/lib/css/fdu/font definiert:
i1 .. i18 | interne Schriftarten 1 bis 18
l1 .. l5 | linke Kassette Schrift 1 bis 5
r1 .. r5 | rechte Kassette Schrift 1 bis 5
p1 .. p5 | Download Schrift 1 bis 5

Die entsprechenden sekundären Schriftarten sind mit dem Präfix s_ versehen (z.B. s_i1).

gray id Wählt die für den Gray_box-Befehl gültige Graustufe. Die gültigen Werte für id sind in /usr/lib/css/fdu/grayscale definiert:
1 | 2%
2 | 10%
3 | 15%
4 | 30%
5 | 45%
6 | 70%
7 | 90%
8 | 100% (schwarz)
light | 10%
medium | 30%
dark | 70%
gray_box y,x | Zeichnet ein grau gefülltes Rechteck mit einer Kantenlänge von y vertikalen und x horizontalen Punkten. Als Graustufe wird der via Gray-Befehl definierte Wert verwendet (Default 2%). Die Position des Cursors bleibt unverändert. Das Rechteck wird ohne Umrandung gezeichnet (siehe dazu den Box-Befehl).
h_line x | Zeichnet ein horizontale Linie in der Länge von x Punkten. Als Strichdicke wird der via Line_points-Befehl definierte Wert verwendet. Die Position des Cursors bleibt unverändert.
h_move [{+|-}]x | Bewegt den imaginären Cursor an die horizontale Position x (in Punkten). Die vertikale Position bleibt unverändert. Ist der x-Wert mit einem Vorzeichen angegeben, erfolgt eine relative horizontale Bewegung um x Punkte nach links (-) oder rechts (+).
include file | An der entsprechenden Stelle wird das Fdu-Makro file eingelesen und interpretiert. Damit können oft verwendete Definitionen ausgelagert und zentral verwaltet werden. Enthält der Name von file Sonderzeichen, muss er als String (z.B. "zebra.mac") definiert werden.
init | Initialisiert den Drucker und stellt diverse Variablen auf ihren Default-Wert ein.
italic {on|off} | Stellt Italic-Schrift ein (on) resp. aus (off).
landscape | Stellt den Drucker auf Querformat-Ausgabe ein.
left_margin # | Definiert den linken Blattrand in Anzahl Zeichen. Die Zeichengrösse wird aus der zum Zeitpunkt des Left_margin-Befehles gültigen Zeichendichte abgeleitet.
line_pitch id Wählt die für die Textausgabe gültige Anzahl Zeilen pro Inch. Die gültigen Werte für id sind in /usr/lib/css/fdu/linepitch definiert:
1 | 1 LPI
2 | 2 LPI
3 | 3 LPI
4 | 4 LPI
6 | 6 LPI
8 | 8 LPI
12 | 12 LPI
24 | 24 LPI
48 | 48 LPI
lpi id | Synonym für das Line_pitch-Statement.
line_points # | Wählt die für den Box-, H_line- und V_line-Befehl gültige Strichdicke in Punkten.
lines # | Definiert die Seitenlänge in Anzahl Zeilen. Die Zeilenhöhe wird aus der zum Zeitpunkt des Lines-Befehles gesetzten Anzahl Zeilen pro Inch abgeleitet.
load # | Aktiviert das Makro Nummer # und startet die Makro-Überlagerung. Load 0 beendet die Makro-Überlagerung und ist gleichbedeutend mit unload.
macro # | Start der Definition des Makros Nummer #. Jede Definition muss mit dem End_macro-Befehl abgeschlossen werden.
move [[{+|-}]y][,[{+|-}]x] | Bewegt den imaginären Cursor an die Position mit den Punkt-Koordinaten y vertikal und x horizontal. Ist ein Koordinaten-Wert mit einem Vorzeichen angegeben, erfolgt eine relative Bewegung um die angegebene Anzahl Punkte nach oben (-y), unten (+y), links (-x) oder rechts (+x). Fehlende Werte werden mit der Koordinate der gegenwärtigen Position substituiert und bewirken demnach keine Bewegung in der entsprechenden Richtung.
page_size # | Synonym für den Lines-Befehl
pattern id Wählt das für den Pat_box-Befehl gültige Muster. Die gültigen Werte für id sind in /usr/lib/css/fdu/pattern definiert:
1 | horizontal lines
2 | vertical lines
3 | diagonal lines 1
4 | diagonal lines 2
5 | square grid
6 | diagonal grid
pat_box y, x | Zeichnet ein mit dem via Pattern-Befehl definierten Muster gefülltes Rechteck mit einer Kantenlänge von y vertikalen und x horizontalen Punkten. Die Position des Cursors bleibt unverändert. Das Rechteck wird ohne Umrandung gezeichnet (siehe dazu den Box-Befehl).
pitch id | Synonym für das Cpi-Statement
points # | Wählt die Schriftgrösse in Punkten
portrait | Stellt den Drucker auf Hochformat-Ausgabe ein.
pop | Bewegt den imaginären Cursor an die zuoberst auf dem Stack liegende, via Push-Befehl gesicherte, Stack-Position.
primary | Wählt für die Textausgabe den primären Zeichensatz (Default).
proportional {on|off} | Stellt Proportional-Schrift ein (on) resp. aus (off).
push | Sichert die aktuelle Position des imaginären Cursors auf einem Stack. Eine so gesicherte Position kann mit dem Pop-Befehl wieder angesteuert werden. Es sollten nicht mehr als ca. 10 Stack-Positionen belegt werden.
right_margin # | Definiert den rechten Blattrand in Anzahl Zeichen. Die Zeichengrösse wird aus der zum Zeitpunkt des Right_margin-Befehles gültigen Zeichendichte abgeleitet.
secondary | Wählt für die Textausgabe den sekundären Zeichensatz.
stroke id Wählt die für die Textausgabe gültige Anschlagstärke. Die gültigen Werte für id sind in /usr/lib/css/fdu/strokeweight definiert:
light | schwach
medium | mittel
bold | stark
stop | Stoppt die Makro-Übersetzung von fdu.
text d [[,] d]... | Synonym für das Data-Statement
text_lines # | Definiert die Dimension des Text-Bereiches in Anzahl Zeilen. Die Zeilenhöhe wird aus der zum Zeitpunkt des Text_lines-Befehles gesetzten Anzahl Zeilen pro Inch abgeleitet.
top_margin # | Definiert den oberen Blattrand in Anzahl Zeilen. Die Zeilenhöhe wird aus der zum Zeitpunkt des Top_margin-Befehles gesetzten Anzahl Zeilen pro Inch abgeleitet.
typeface id Wählt die für die Textausgabe gültige Schriftbild. Die gültigen Werte für id sind in /usr/lib/css/fdu/typeface definiert:

caslon, courier, dutch, elite, gothic, helvetic, lp (line printer), orator, pica, present (presentation), prestige, roman, times roman, script, swiss

Die entsprechenden sekundären Schrifttypen sind mit dem Präfix s_ versehen (z.B. s_pica).

underline {on|off} | Stellt den Unterstreichen-Modus ein (on), resp. aus (off).
unload | Schaltet eine mit dem Load-Befehl aktivierte Makro-Überlagerung aus.
v_line y | Zeichnet ein vertikale Linie in der Länge von y Punkten. Als Strichdicke wird der via Line_points-Befehl definierte Wert verwendet. Die Position des Cursors bleibt unverändert.
v_move [{+|-}]y | Bewegt den imaginären Cursor an die vertikale Position y (in Punkten). Die horizontale Position bleibt unverändert. Ist der y-Wert mit einem Vorzeichen angegeben, erfolgt eine relative vertikale Bewegung um y Punkte nach oben (-) oder unten (+).
x_line x | Synonym für das H_line-Statement
x_move [{+|-}]x | Synonym für das H_move-Statement
y_line y | Synonym für das V_line-Statement
y_move [{+|-}]y | Synonym für das V_move-Statement
# comment | Kommentar bis zum Zeilen-Ende

Die fdu-Befehle können in einem sehr freien Format eingegeben werden. Jeder Befehl muss mit einem Semikolon ';' abgeschlossen werden. Zwischen Gross- und Kleinschreibweise wird nicht unterschieden.

Integration

Mit fdu können HP LaserJet II Programme erstellt und übersetzt werden. Das Resultat der Übersetzung sollte nach bestimmten Ordnungs-Kriterien im File-System abgelegt werden. CSS unterstützt unter anderem folgende Ordnungsgrössen (für eine vollständige Liste der verfügbaren Ordnungsgrössen siehe auch css.devices(C)):
%F | Formular-Typ (lpr f-Option)
%S | Formular-Zusatz (dito.)
%D | Device-Nummer (lpr d-Option)
%L | LANG(UAGE) Environment-Variable oder lpr L-Option
%N | Device-Name gemäss dn-Parameter in css.devices(C) resp. lpr d-Option
%P | Programm-Name (lpr p-Option)
%O | lpr O-Option
%T | Device-Typ gemäss dt-Parameter in css.devices(C)
%V | Device-File gemäss dv-Parameter in css.devices(C)

Wird z.B. bei der Drucker-Definition in /etc/css.devices das Initialisierungs-File als

bor=/usr/lib/css/macros/%L/%P.%F

angegeben, wird von CSS bei einem Ausdruck mit den Optionen -p prog01 -f b versucht das File /usr/lib/css/macros/german/prog01.b in den Drucker zu laden (Annahme: LANGUAGE=german). Ist keine solche Datei vorhanden, wird von CSS der Initialisierungs-Befehl stillschweigend ignoriert. Die lpr-Optionen können selbstverständlich wie üblich auch im Druckfile eingebettet werden (siehe css(P)).

Ein Ausdruck läuft in folgenden Phasen ab:

  • Aktuelles Formular des Druckers überprüfen / siehe auch map- und xmap-Eintrag unter css.devices(C).
  • Verarbeiten aller bor-Sequenzen in der Reihenfolge ihrer Definition in css.devices(C). Vor der Ausgabe werden alle angegebenen Ordnungsbegriffe substitutioniert. Falls eine bor-Sequenz mit dem Zeichen '/' beginnt und eine Datei mit einem solchen Namen existiert, wird deren Inhalt an den Drucker gesendet. Bei bedingten bor-Sequenzen, findet vor der Ausgabe selbstverständlich eine Evaluation aller Bedingungen statt.
  • Generieren des Dateinamens if1 mit den im Moment geltenden Ordnungsgrössen. Falls eine solche Datei vorhanden ist, diese an den Drucker senden. (Hinweis: Die if- und of-Sequenzen werden nur noch aus Kompatibilitäts-Gründen unterstützt. Dieselbe Funktionalität bieten bor resp. eor.)
  • Dito. für if2.
  • Auswertung drucken.
  • Generieren des Dateinamens tf1 mit den im Moment geltenden Ordnungsgrössen. Falls eine solche Datei vorhanden ist, diese an den Drucker senden.
  • Dito. für tf2.
  • Verarbeiten aller eor-Sequenzen. Es gelten dieselben Regeln wie für die bor-Sequenzen.

Beispiel-Konfiguration:

/etc/css.devices:

#
# Brother HL-8
#
1|HL-8 (HP):as:cr:pg:dv=/dev/lp:\
:map=a,b,c,d:\
:bor=\E\rH\EE:#set HP-emulation mode, reset device:\
:bor=/usr/lib/css_mac/%L/%P:\
:eor=\EE:#reset device:\
:e1=\E&k0S:#10 cpi:\
...
:e50=\E&f5x2y4X:#load macro 2:

Programm prog_xy:

FILE *pFp, *popen();

/* open pipe to CSS */

if ((pFp = popen("lpr", "w")) == NULL)
{
    perror("prog_xy: popen lpr");
    exit(1);
}

/* write CSS instream options */

fprintf(pFp, "++CSS++ -f B -p prog_xy\n");

/* write report into file 'pFp' */
...
pclose(pFp);
exit(0);

Macro prog_xy:

#
# Fdu-Macro prog_xy
#
init; # initialize
landscape;
page_size 46;
macro 1;
    move 2300, 30; # 46 lines * 50,
                   # 1 char * 30
    h_line 540;    # 18 char * 30
    v_move +40;    # 4/5 line down
    text 'Printed by CSS/FDU';
end_macro;

#
# Final setup
#
top_margin 3;
text_lines 42;
left_margin 1;
right_margin 112;
load 1; # overlay on each page
#
# end macro prog_xyx

Umwandlung:

fdu -o /usr/lib/css_mac/german/prog_xy prog_xy

Hinweise

Bei CssNT sind alle Referenzen auf /usr/lib/css/fdu durch lib\fdu zu substituieren.

Viele der oben beschriebenen fdu-Befehle sind als Makros in /usr/lib/css/fdu/commands definiert. Bei Einhaltung der darin dokumentierten Regeln können beliebig Erweiterungen vorgenommen werden. Ebenso können die für diverse Befehle gültigen Paramter-Files an lokale Gegebenheiten angepasst werden.
Fdu-Optionen können auch in der Datei $HOME/.fdurc sowie in der Shell Environment-Variablen FDUOPT gesetzt werden. Die Reihenfolge der Evaluation ist unter Abschnitt 'Syntax der Befehlszeilen' auf Seite 1-4 beschrieben.
Mit der Shell Environment-Variablen FDUPATH können ein oder mehrere Pfad-Namen als Include-Directory definiert werden. Werden mehrere Namen angegeben, so sind sie durch Doppelpunkte abzutrennen.

Beispiel:

FDUPATH=/usr/fdu/include:/usr/css/include;
export FDUPATH

Files

/usr/lib/css/fdu

fdu control directory

Siehe auch

css.devices(P), lpr, HP LaserJet II User's Manual


LpdRestart

Restart Printer Daemon

lpdrestart(U)
Synopsis Plattform Beschreibung Optionen Hinweise Files Siehe auch

Synopsis

lpdrestart [-i dev] [-I]

Plattform

Unix

Beschreibung

Mit lpdrestart können Drucker aktiviert werden, die mit Hilfe von css nicht mehr gestartet werden können. Dieses Programm soll nur mit äusserster Vorsicht verwendet werden. Im besonderen ist darauf zu achten, dass durch den Aufruf von lpdrestart keine aktiven Drucker betroffen sind. Falls beim Aufruf keine Option angegeben wurde, wird der Drucker 1 reaktiviert.

Optionen

-i dev | Start des Druckers dev.
-I | Start aller vorhandenen Drucker.

Hinweise

Nach dem Aufruf von lpdrestart muss der Drucker in gewissen Fällen zusätzlich mittels css oder csu gestartet werden. Durch lpdrestart werden auch gestoppte (on hold) Drucker aktiviert.

Files

/usr/lib/css/lpd | Despooler
/usr/lib/css/dev | Device Database

Siehe auch

csa, css, csu


Lpr

Spooler Frontend

lpr(U)
Synopsis Plattform Beschreibung Optionen Hinweise Files Siehe auch

Synopsis

lpr [option]... [file...]

Plattform

Unix, Windows NT

Beschreibung

Das Programm lpr liest und komprimiert die angegebenen Files und übergibt seinen Output der Spooler-Verwaltung (lpd). Sind keine Files angegeben oder wird das Argument '-' gefunden, verarbeitet lpr den Standard-Input.

Optionen

-a

die Schreibdichte wird - gemäss der längsten Zeile - automatisch gewählt.
-b text | setzt den Banner-Page Text auf text.
-c n | Anzahl zu druckende Kopien n (Default 1). Die Eingabe von 0 bewirkt, dass der Ausdruck erst nach einem Abruf mittels csu oder css erfolgt (Auswertung in 'hold' Status, siehe auch H-Option). Die Anzahl wird dabei jedoch auf den Defaultwert 1 zurückgesetzt, d.h. -c 0 ist gleichbedeutend mit -H -c 1.
-d dev | Drucker (0..999 oder Name / 0 = beliebiger Drucker / als Default wird der Wert von default_device in CSS.DEFAULT(C) verwendet, dessen Default ist 0).
-e mkz | Mitarbeiter-Kurzzeichen (employee) als Identifikation bei Status-Abfragen mit csu und css. (Bis zu 8 Zeichen / Default Login-Name)
-f f[:s] | Formular-Typ des Ausdruckes. Zwischen Gross- und Kleinschreibweise wird nicht unterschieden. Die optionale Formular-Subtyp s (max. 3 Zeichen) dient als Ordnungsbegriff gemäss css.devices(C) (bo x- und eo x-Eigenschaften). Als Default wird der Wert von default_form in CSS.DEFAULT(C) verwendet, dessen Default ist A
-g group | Setzt die Group-ID des Dokumentes auf group (Name oder ID). Als Default wird die gid (Group ID) des Unix Users verwendet, der die Auswertung erstellt hat resp. der in der u-Option angegeben wurde.
-h | unterdrückt die Ausgabe einer Banner-Page
-k date | Die Auswertung soll bis zum Datum date (yyyymmtt) aufbewahrt werden (keep).
-p pgm | Programm-Name als Identifikation bei Status-Abfragen mit csu. (Bis zu 14 Zeichen)
-r dev | Drucker (Default 0) für Umleitung ('routing', siehe unten).
-t tit | Listen-Titel als Identifikation bei Status-Abfragen mit csu und css. (Bis zu 30 Zeichen / Default file oder '(pipe)' bei Standard-Input). Die t-Option gilt nur für das erste angegebene File.
-u user | Setzt die User-ID des Dokumentes auf user. Ist die e-Option nicht gesetzt, wird auch das Mitarbeiter-Kurzzeichen entsprechend gesetzt. User kann als Nummer oder Name eingegeben werden und muss in /etc/passwd definiert sein.
-B mode Veranlasst CSS das Dokument selbst dann im Binary-Mode (d.h. ohne Escape- und tr-Übersetzung) auszudrucken, wenn der Drucker diesen Modus nicht gesetzt hat (bm-Eigenschaft). Die Angabe des Druckers via d- resp. r-Option ist dabei zwingend vorgeschrieben und ein Umleiten auf andere Drucker ist danach nicht mehr möglich. Mode wird durch die Addition von Werten gebildet und steuert die Ausgabe der beim Drucker definierten Initialisierungs- und Abschluss-Sequenzen (siehe auch css.devices(C)). Ist ein Wert in mode enthalten, wird die entsprechende Sequenz ausgegeben. Folgende Werte werden erkannt:
10 | bor | 01 | eor
20 | if1 | 02 | tf1
40 | if2 | 04 | tf2
-C cond | Setzt die Condition-Flags cond für die Steuerung der conditional bor-, eor-, bop-, eop-, bol-, eol- und tr-Sequenzen (siehe css.devices(C)) auf True. Cond kann als Zeichen- und Zahlenfolge (z.B. abcdAB2) oder als Argument-Liste (a,b,c,B,1) angegeben werden.
-H | Setzt die Auswertung in den 'hold' Status (siehe auch c-Option) d.h. der Ausdruck erfolgt erst nach einem Abruf mittels csu oder css.
-K ndays | Die Auswertung soll bis ndays Tage aufbewahrt werden (keep).
-L lang | Setzt den Sprach-Ordnungsbegriff für die Steuerung der Initialisierungs- und Abschluss-Dateien (bo x- und eo x-Eigenschaften der Drucker-Definitionen). Bis zu 14 Zeichen können angegeben werden. Siehe auch css.devices(C) und fdu.
-O ord | Setzt den allgemeinen Ordnungsbegriff für die Steuerung der Initialisierungs- und Abschluss-Dateien (bo x- und eo x-Eigenschaften der Drucker-Definitionen). Bis zu 60 Zeichen können angegeben werden. Siehe auch css.devices(C) und fdu.
-P n | Im Normalfall ermittelt lpr die Anzahl der Seiten eines Dokumentes anhand der ps-Definition in css.forms(C) und der Anzahl Linefeed- resp. Formfeed-Zeichen im Dokument. Mit dieser Information kann der Benutzer den Ausdruck disponieren, abbrechen und wieder neu aufsetzen. Da bei Laser-Druckern der Einsatz von fdu-Macros zu einer Neudefinition der Anzahl Zeilen pro Seite führen kann, wird die Information aus der Formular-Beschreibung für die entsprechende Auswertung ungültig und somit die ermittelte Seitenzahl fehlerhaft. Mit der P-Option kann die Zeilenzahl der zu druckenden Auswertung(en) korrigiert werden. Ist n als 0 (Null) angegeben, werden zur Bestimmung der Seitenzahl ausschliesslich Formfeed-Zeichen berücksichtigt. Für eine vollständige Beschreibung dieser Option, siehe Hinweise unten.
-S esc | Fügt die angegebenen Escape-Sequenzen am Anfang der Startseite (vor bop) des Ausdruckes ein. Diese Steuerzeichen werden beim späteren Ausdruck gemäss den e x-Definitionen in css.devices(C) für den Zieldrucker übersetzt. Esc wird als Argument-Liste wie z.B. e5,e7,e30 angegeben (Kurzform: 5,7,30).
-T esc | Fügt die angegebenen Escape-Sequenzen am Ende der letzten Seite (nach eop) des Ausdruckes ein. Diese Steuerzeichen werden beim späteren Ausdruck gemäss den e nn-Definitionen in css.devices(C) für den Zieldrucker übersetzt. Esc wird als Argument-Liste wie z.B. e5,e7,e30 angegeben (Kurzform: 5,7,30).
-- Ende der Optionen. Dies erlaubt File-Argumente, deren Name mit dem Zeichen '-' beginnt.

Hinweise

Zur Berechnung der Zeilenlänge (a-Option), werden die Tabulator-Positionen 9, 17, 25, etc. angenommen. Veränderungen der Zeilenlänge durch Zeichenübersetzung (zum Zeitpunkt des Ausdruckes) werden nicht erkannt.

Die Berechnung der Anzahl Seiten eines Dokumentes ist abhängig von mehreren Optionen und Definitionen. Im Normalfall beschreibt der ps Eintrag der Formulardefinition in css.forms(C) die Anzahl Zeilen pro Seite. Dieser Wert kann mit einem positiven Wert (grösser als Null) in der P-Option überschrieben werden. Ein Input Seitenwechsel geschieht immer dann, wenn ein Formfeed Zeichen (ff) erkannt wird, oder die Anzahl Zeilen pro Seite erreicht wird (Seitenüberlauf). Eine P-Option mit dem Wert Null (0) veranlasst CSS eine variable Seitenlänge anzunehmen. In diesem Modus lösen nur ff Zeichen einen Seitenwechsel aus.

Auf ähnliche Art und Weise wird die Top-Of-Form Verarbeitung des Despooler-Daemons lpd gesteuert. Auch hier beschreibt der ps Eintrag der Formulardefinition in css.forms(C) oder ein positiver Wert der P-Option die Anzahl Zeilen pro Seite. Jede Seite wird mit den bop Sequenzen eingeleitet und mit den eop Sequenzen abgeschlossen. Ein Seitenwechsel wird auch bei der Ausgabe durch ein ff Zeichen, oder das Erreichen der Anzahl Zeilen pro Seite, ausgelöst. Falls der pg (Page Printer) Eintrag für den entsprechenden Drucker in css.devices(C) nicht gesetzt ist, werden keine ff Zeichen übermittelt. Die Positionierung auf die nächste Seite (Top-Of-Form) wird durch Ausgabe einer Sequenz von Leerzeilen erreicht. Ist der pg Eintrag jedoch gesetzt, werden keine Leerzeilen generiert und ff Zeichen an den Drucker weitergeleitet. Bei Seitenüberlauf wird jedoch kein ff generiert. Die letzte Seite wird auf jeden Fall mit einem ff abgeschlossen. Um jede Seite mit dem ff Zeichen abzuschliessen, kann die Sequenz :eop -f=...\f...: definiert werden. In beiden Fällen veranlasst eine P-Option mit dem Wert Null (0) CSS eine variable Seitenlänge anzunehmen wobei ein Seitenüberlauf keinen Seitenwechsel auslöst.

Die Verwendung von -P 0 verursacht ein potentielle Problem: Die $ Variable (d.h. ‘letzte Zeile’ wie z.B. :eol ($-3)=...:) wird relativ zur Seitengrösse der Formulardefinition (ps Eintrag) bestimmt und kann deshalb bei Seiten mit variabler Anzahl Zeilen fehlen oder nicht in der korrekten Sequenz ausgelöst werden.

Falls ein Drucker nicht angesprochen werden kann, wird er in den Status 'gestoppt' gesetzt. (Bei parallelen Schnittstellen auch, wenn der angesprochene Drucker nicht 'online' steht).

Lpr-Optionen können auch in der Datei $HOME/.lprrc sowie in der Shell Environment-Variablen LPROPT gesetzt werden. Die Reihenfolge der Evaluation ist unter Abschnitt 'Syntax der Befehlszeilen' auf Seite 1-4 beschrieben.

Aus Kompatibilitäts-Gründen wird die Shell-Variable CSS weiterhin unterstützt. Sie wird vor der Datei $HOME/.lprrc evaluiert, hat also die tiefste Priorität. Wir empfehlen jedoch den Gebrauch der Standartvariablen LPROPT. Um zum Beispiel immer die a-Option zu verwenden und die Ausgabe auf den Drucker 2 umzuleiten, kann im File .profile folgender Shell Befehl eingegeben werden:

LPROPT="-a -r 2"; export LPROPT;

oder im File $HOME/.lprrc:

-a -r 2

Die Optionen werden in der folgenden Reihenfolge interpretiert:

1. | CSS Shell-Variable
2. | File $HOME/.lprrc
3. | LPROPT Shell-Variable
4. | lpr-Aufruf
5. | im Druckfile eingebettete Steuerparameter

Die Optionen im Remote-Control File haben somit das geringste, die Steuerparameter im Dokument das grösste Gewicht.

Zur Druckerwahl bestehen verschiedene Möglichkeiten:

  • ist in der verlangten Formularklasse ein Drucker bestimmt (ld-Eigenschaft), wird dieser ausgewählt. Eine Übersteuerung ist nicht möglich.
  • für die d-Option gilt die oben aufgeführte Options-Priorität.
  • ist die r-Option gesetzt und nach obigen Regeln noch kein Drucker bestimmt, erfolgt die Ausgabe auf dem dabei angegebenen Drucker.

Files

Css: |
/etc/css.banner | Banner page messages
/usr/lib/css/css.errlog | Despooler daemon error log
/usr/lib/css/lpd | Despooler daemon
/usr/lib/css/dev | Device Database
/usr/lib/css/forms | Forms Database
/usr/lib/css/rep | Report Database
/usr/spool/css/* | Spool Area
CssNT: |
etc\css.banner | Banner page messages
lib\CssErrlog.txt | Service error log
lib\CssNTSrv.exe | Despooler daemon
lib\dev | Device Database
lib\forms | Forms Database
lib\rep | Report Database
spool\* | Spool Area

Siehe auch

csa, css, csu, cssdate, css.devices(C), fdu, lpdrestart, pr(1)


SetMode

Line Discipline Utility

setmode(U)
Synopsis Plattform Beschreibung Optionen Hinweise Beispiele Siehe auch

Synopsis

/etc/setmode [-w] dev stty-modes

Plattform

Unix

Beschreibung

Setmode setzt die Schnittstellen-Attribute von seriellen Anschlüssen. Die Aufgabe dieses Programmes ist es, die Übertragungs-Geschwindigkeit, Parity- und Stopbit-Vereinbarungen sowie die Verbindungsart festzulegen. Setmode verwendet die tty-Attribute der Befehlszeile und ruft damit stty(1) auf, um danach für immer zu ruhen. Üblicherweise werden damit Attribute gesetzt, die in der Definitionsdatei css.devices(C) nicht angegeben werden können.

Optionen

-w

(wait) setmode läuft nicht im Hintergrund ab, sondern bleibt dem Aufrufer zugeordnet. Diese Option findet beim Aufruf via /etc/inittab(4) mit dem respawn-Attribut Verwendung (UNIX System V).

Hinweise

Setmode kann mit dem Befehl kill -15 pid abgebrochen werden.

Beispiele

UNIX Version 7 / XENIX 3

Um z.B. einen Drucker mit dem XON/XOFF Protokoll, 8 Datenbits und 1 Stopbit zu betreiben, wird im File /etc/rc folgende Zeile angegeben:

/etc/setmode /dev/lp 9600 clocal -cstopb

UNIX System V

Der gleiche Effekt wird beim System V durch einen Eintrag in /etc/inittab erreicht:

lp:1:respawn:/etc/setmode -w /dev/lp 9600 ixon ixany cs8 -cstopb -opost
Wichtig!

Beim Einsatz von setmode via /etc/inittab mittels respawn muss unbedingt die -w Option gesetzt werden!

Siehe auch

css.devices(C), init(1), initab(4), stty(1), tty(4)


Upl

Underline Utility

ulp(U)
Synopsis Plattform Beschreibung Optionen Hinweise Beispiele Siehe auch

Synopsis

ulp [-f] [-u] [-1] [file...]

Plattform

Unix, Windows NT

Beschreibung

Ulp liest die angegebenen Files (oder den Standard-Input, falls file fehlt) und übersetzt Folgen des Zeichen '_' (underscore) in die CSS Steuersequenzen ESC,13 (Start underline) und ESC,14 (Stop underline). Im weiteren werden die von nroff(1) ausgegebenen 'reverse linefeeds' (ESC,'7'), 'reverse' und 'forward half linefeeds' (ESC,'8' und ESC,'9') in die standart CSS Steuersequenzen ESC,15 und ESC,17 übersetzt.

Kann das verwendete Druckermodell nicht in einem Druckvorgang unterstreichen (z.B. Infoscribe 1000), so kann dies mit der u-Option angegeben werden. Ulp druckt dann die betroffenen Zeilen in zwei Durchgängen.

Da die wenigsten Drucker das BS-Zeichen ('backspace') verarbeiten und damit ein sog. 'overstriking' nicht zulassen, druckt ulp Zeilen welche BS-Zeichen enthalten in mehreren Durchgängen.

Gewisse Druckermodelle erlauben die Verwendung von sog. Fettschrift, wobei dafür jedoch keine entsprechenden Steuerzeichen wie z.B. 'correspondence quality' vorgesehen sind (z.B. Siemens PT 88/PT 89). Vielmehr ist die Fettschrift durch mehrmaliges Ausgeben der einzelnen Zeilen zu erreichen. Ulp bietet mit der n-Option die Möglichkeit, jede Zeile n-Mal ohne Zeilenvorschub (linefeed) zu drucken.

Optionen

-f | Die Umwandlung von 'reverse' und 'half linefeeds' wird unterdrückt.
-u | Unterstreichungen werden in zwei Durchgängen erreicht (Sequenz: Zeile - CR - Unterstreichung).
-1 | Jede Zeile wird n-Mal ohne Zeilenvorschub gedruckt (Fettschrift / Default 1).

Hinweise

Ulp verarbeitet Zeilen bis zu einer Länge von 800 Zeichen.

Ulp-Optionen können auch in der Datei $HOME/.ulprc sowie in der Shell Environment-Variablen ULPOPT gesetzt werden. Die Reihenfolge der Evaluation ist unter Abschnitt 'Syntax der Befehlszeilen' auf Seite 1-4 beschrieben.

Um unerwünschte Effekte zu verhindern, schreibt die Unix Version von ulp nicht auf Bildschirm-Terminals. Für Monitor-Zwecke kann die Ausgabe mit ulp | cat erzwungen werden.

Für Drucker, die beim Empfang eines CR-Zeichens (carriage-return) automatisch einen Zeilenvorschub bewirken, ist ulp nicht geeignet.

Um nach Beendigung der Druckausgabe eine fehlerhafte Seiten-Positionierung zu verhindern, zählt ulp alle Halbzeilen-Vorschübe und versucht diese auszugleichen. Daraus kann eine zusätzliche Leerseite am Ende einer Auswertung resultieren.

Bei Druckern, die Halbzeilen-Vorschübe nur vorwärts durchführen können, sind nroff(1) Ausgaben vor ulp mit col(1) zu filtern. Dabei kann jedoch der Seitenausgleich nicht erreicht werden, da CSS selbst über halbe Zeilen nicht Buch führt.

Beispiele

nroff -m an file | ulp | lpr

nroff -m s file | ulp -u -2 | lpr -d 2

Siehe auch

col(1), css.devices(C), nroff(1), ul(1)


WinCss Übersicht
Copyright

Diese Help Datei beinhaltet das elektronische Handbuch der CSS Windows Benutzerschnittstelle WinCss. Es enthält die vollständige Beschreibung aller Dialogelemente sowie deren Inhalt.

Um Informationen über die Unix und Windows/NT CSS Programme zu erhalten, konsultieren Sie bitte das CSS Online Handbuch, welches einen integrierenden Bestandteil der CSS Dokumentation bildet.

Das Online Handbuch wird nur mit der Server Version von CSS vertrieben. Es kann jedoch von der Unitec Web Seite auf Ihr System geladen werden. Instruktionen dazu finden Sie im Abschnitt Online Manual.

WinCss Highlights

  • Office Look and Feel
  • Drag and Drop Bedienung
  • Kontext Menüs
  • Vorschau der Auswertungen mit Textsuche
  • Strukturierte Ansicht der Drucker- und Warteschlangendaten zur vereinfachten Selektion
  • Implementiert mit dem weit verbreiteten Unitec Communication Manager UCM
  • Installieren und verwenden, keine zusätzliche Konfiguration notwendig

CSS Highlights

Einige der wichtigen Eigenschaften der CSS und CssNT Server Software sind:

  • Unterstützung für mehrere virtuelle Server Umgebungen. Damit kann im Rechenzentrumsbetrieb für jeden Kunden oder jede Benutzergruppe ein eigener Druckserver eingerichtet werden.
  • Möglichkeit der geräteunabhängigen Programmierung
  • Definitionsdatenbank für Drucker und Formulare
  • Formulardefinitions Utility / Laserdrucker Makroverwaltung
  • Einfach zu bedienendes Dialogprogramm für alle Verwaltungsaufgaben
  • Lpr-Optionen innerhalb der Druckdatei
  • Verwaltung von Formularwarteschlangen
  • Report Preview (Anzeige von Druckdateien mit Suchfunktion)
  • Testdruck (Richttest)
  • Integrierte Druckdatei Verwaltung mit Aufbewahrungsdatum
  • Übersetzungstabellen für Zeichen- und Zeichensequenzen
  • Multiuser Tauglichkeit
  • Kompression der CSS Zwischendateien
  • Unterstützung der Netzwerk Druckprotokolle lpd, rtel, pros und raw
  • Grafische Oberfläche für Windows Workstations

Über WinCss lesen.

Back To Top


Über WinCss

Das Produkt CSS Commercial Spooling System ist ein Softwarepaket zur einfachen Verwaltung und Steuerung der gesamten Druckausgabe unter UNIX und Windows/NT Systemen.

Die Funktionen und die Bedienung von CSS sind speziell auf die Bedürfnisse der kommerziellen EDV zugeschnitten.

Das in diesem Help Dokument beschriebene WinCss Programm erlaubt die einfache Bedienung der Unix, resp. Windows/NT Druckverwaltung auf Windows Arbeitsplatz Systemen.

Alle Arbeiten können mit der von Ihren favorisierten Arbeitsmethode wie Drag and Drop, Kontext Menüs, Toolbars und Doppelklick oder Standartmenü Bedienung durchgeführt werden.

Back To Top


WinCss Befehl
Synopsis Beschreibung Optionen Hinweise Files Siehe auch

Synopsis

WinCss [-m] [-h host] [-p port]

Beschreibung

Mit WinCss können alle bei der Druckverwaltung anfallenden Arbeiten wie z.B.: Statusabfragen, Formularwechsel, Prioritätensteuerung usw. von jedem Windows Client System aus erledigt werden. Die Bedienung der grafischen Oberfläche erfolgt unter den in Windows üblichen Standarts. Wo immer möglich, kann mit der rechten Maustaste ein dem aktuellen Kontext entsprechendes Popupmenu geöffnet werden. Die aktuellen Daten werden in Tabellen dargestellt. Bei mehreren Tabellenelementen kann durch Doppelklick mit der linken Maustaste ein Dialogfenster geöffnet werden, um dem Inhalt entsprechende Aktionen auszulösen. Diese Elemente werden in diesem Dokument als Datenfeld-Schalter bezeichnet.

Viele Verwatlungsaufgaben können mittels Drag And Drop erledigt werden. Dabei wird ein Objekt mit der linken Maustaste angewählt und mit der gedrückten Taste über ein anderes Objekt gezogen (Drag). Der Mauszeiger verändert während dieses Vorganges seine Form. Ist das Zielobjekt erreicht, wird die Maustaste losgelassen (Drop) und ein der Aktion entsprechendes Dialogfenster wird geöffnet. Zum Beispiel kann ein Formularwechsel durch Drag einer Datenzeile des Formularfensters und Drop auf ein Element des Druckerfensters ausgelöst werden.

Folgende Hauptfenster sind verfügbar:

Hauptsteuerung | Kleines Fenster mit Schaltern (sog. Toolbar Buttons) zum öffnen der unten aufgeführten Datenfenster.
Formulare | Liste aller in CSS definierter Formulare.
Drucker | Liste aller in CSS definerter Drucker. Aktionen: Drucker stoppen, Druckvorgang abbrechen, Drucker starten, Formularwechsel durchführen.
Auswertungen | Liste der sich in der Warteschlange befindenden Auswertungen. Aktionen: beschleunigen, blockieren (Druck aufschieben), zum Druck freigeben, umleiten, stoppen, Ahnzahl Kopien ändern, anzeigen und löschen

Die Sprache des WinCss Dialoges kann im Menu Ansicht | Sprache ausgewählt werden. Einige Darstellungselemente wie Menü, Statuszeile und Tool Tips (kleine Hinweisfenster) können ebenfalls im Menü Ansicht ein- resp. ausgeschaltet werden. Wurde das Menü selbst ausgeschaltet kann es durch das Betätigen der rechten Maustaste über der Toolbar wieder sichtbar gemacht werden.

Optionen

Die folgenden Optionen werden von WinCss erkannt:

-h host | WinCss verbindet sich mit dem CSS Server auf dem System mit der IP Adresse host.
-m | Normalerweise verzweigt WinCss direkt in das Fenster Warteschlange. Mit der m-Option kann das Minifenster Hauptsteuerung eingeblendet werden.
-p port | Definiert die zu verwendende TCP/IP Portnummer. Default is 6801, resp. der in den Programmoptionen gestzte Wert. Siehe auch unter WinCss(C) und CssWs(U) im Online Handbuch.

Hinweise

Als Optionszeichen kann neben dem Bindestrich '-' auch der Slash '/' verwendet werden.

Das Fenster Drucker zeigt folgende Statusinformationen an:
Drucker Status | Beschreibung
bereit | wartend, ohne Arbeit
start | ein Ausdruck beginnt
aktiv | druckend
besetzt | Drucker wird von einem Software-Paket mit integriertem Spooler benutzt (siehe auch el-Eintrag in css.devices(C) im Online Handbuch)
stopp | Der Drucker ist aktiv, wird jedoch nach der Ausertung gestoppt.
umgeleitet auf dev | Die Ausgabe erfolgt auf den bezeichneten Drucker.
off line | Der Drucker ist nicht eingeschaltet. Dieser Zustand kann nur bei gewissen Schnittstellen erkannt werden.
inaktiv | Drucker gestoppt

Bei der Anzeige von Auswertungen am Bildschirm können Folgen von mehreren Leerzeilen komprimiert dargestellt werden.

Wird in einer Datentabelle eine Zeile durch Mausklick angewählt, wird sie mit einem hellgelben Hintergrund belegt. Ein solcher Eintrag wird in der untenstehenden Beschreibung als aktuelles Element bezeichnet (z.B. aktuelle Auswertung).

Siehe auch

Client Konfiguration, Verbindungsoptionen, Allgemeine Optionen

Files

Windows Registry WinCss Konfiguration unter dem Schlüssel
HKEY_LOCAL_MACHINE\SOFTWARE\Unitec\WinCss


Hauptsteuerung

WinCss Unitec Home Page

X
X

Hauptsteuerung (Mini Toolbar)
Die Hauptsteuerung ist Ihr WinCss Kontrollzentrum bei beschränktem Bildschirmplatz.

Toolbar Schalter
 Popup Menüs
Toolbar Schalter
Schalter | Name | Beschreibung
 | Warteschlange | Mit Hilfe des Warteschlangefensters können die gegenwärtig vorhandenen Auswertungen verwaltet werden.
 | Drucker | Das Druckerfenster dient zur Verwaltung aller im CSS System definierten Drucker.
 | Formulare | In diesem Fenster werden alle dem CSS System bekannten Formulare aufgelistet.
 | Optionen | Erlaubt diverse Programmptionen zu setzen.
 | Hilfe | Startet WinCss Help, Kapitel Hauptsteuerung.
 | Exit | Die Betätigung dieses Schalters beendet WinCss und schliesst alle geöffneten Fenster.
Popup Menüs
Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:
Bereich | Menü
Toolbar | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).

Siehe auch Allgemeine Optionen, Bedienung, WinCss Befehl


Auswertungen, Warteschlange
Mit dem Fenster Auswertungen können Sie auf leichte Art und Weise alle Verwaltungsaufgaben der Warteschlange durchführen.

Toolbar Schalter
 Inhalt der Datentabelle
 Datenfeld Aktionen
 Drag and Drop
 Popup Menüs
Toolbar Schalter
Schalter | Name | Beschreibung
 | Drucker | Das Druckerfenster dient zur Verwaltung aller im CSS System definierten Drucker. Dieser Schalter wird hier nicht angezeigt, falls das Programm mit der m-Option gestartet wurde.
 | Formulare | In diesem Fenster werden alle dem CSS System bekannten Formulare aufgelistet. Dieser Schalter wird hier nicht angezeigt, falls das Programm mit der m-Option gestartet wurde.
 | Anwender Selektion | Darstellen nur eigene / alle Auswertungen
 | Strukturierte Ansicht | Die strukturierte Ansicht erlaubt eine flexible Gruppierung der Daten nach beliebigen Kriterien.
 | Freigeben | Gibt die bezeichnete Auswertung zum Ausdruck frei.
 | Sofortdruck | Wie 'Freigeben', jedoch ohne vorgängiges Dialogfenster zur Feineinstellung der Druckoptionen.
 | Blockieren | Blockiert resp. stoppt den Ausdruck der aktuellen Auswertung.
 | Beschleunigen | Setzt die Auswertung an den Anfang der Warteschlange des entsprechenden Formulars. Hinweis: Auswertungen können nur gegenüber eigenen anderen Auswertungen beschleunigt werden.
 | Anzahl Kopien | Startet einen Dialog zur Änderung der Anzahl Kopien.
 | Umleiten | Startet den Dialog zur Umleitung der Auswertung auf einen anderen Drucker.
 | Anzeigen | Zeigt die Auswertung in einem separaten Fenster an. Diese Funktion ist nur in der 32 Bit Version verfügbar.
 | Löschen | Löscht die aktuelle Auswertung.
 | Hilfe | Startet WinCss Help, Kapitel Auswertungen.
 | Schliessen | Schliesst das aktive Fenster.
Inhalt der Datentabelle

Titel | Zelleninhalt
Nr. | Auswertungsnummer. Eine rote Nummer kennzeichnet, dass auf diese Auswertung keine Zugriffsberechtigung besteht.
Bezeichnung | Vom Applikationsprogramm definierte Auswertungsbezeichnung.
Frm | Das für die Auswertung benötigte Formular.
Status | Auswertungsstatus wie z.B. bereit, druckend, blockiert, usw.
DNr | Nummer des Druckers auf welchem die Auswertung verarbeitet werden soll.
Seiten | Anzahl Seiten im Dokument.
Kopien | Anzahl zu druckende Kopien.
Datum | Erstelldatum der Auswertung.
Zeit | Erstellzeit der Auswertung.
MKZ | Kurzzeichen des Mitarbeiters, der die Auswertung erstellt hat.
Datenfeld Aktionen
Folgende Datenfelder lösen durch Doppelklick eine Aktion aus:
Datenfeld | Aktion
Nr., Bez. | Zeigt den Inhalt der Auswertung in einem separaten Fenster an.
DNr | Startet den Dialog zur Umleitung der Auswertung auf einen anderen Drucker.
Status | Löst je nach aktuellem Auswertungsstatus einen entsprechenden Dialog (freigeben, aktivieren, stoppen) aus.
Kopien | Startet den zur Änderung der Anzahl Kopien bestimmten Dialog.
Drag and Drop

Drag Objekt | Drop Objekt | Aktion
Drucker | Auswertung | Löst je nach aktuellem Drucker- und Auswertungsstatus einen entsprechenden Dialog (freigeben, umleiten, aktivieren, Formularwechsel) aus.
Auswertung | Drucker | Wie oben.
Popup Menüs
Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:
Bereich | Menü
Toolbar | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).
Datenzeile | Menü mit allen auch via Toolbar möglichen Aktionen.
Tabellentitel | Aktivieren und deaktivieren der einzelnen Datenspalten.

Siehe auch Bedienung, Vorschau


Drucker
Mit dem Fenster Drucker können Sie auf leichte Art und Weise alle Verwaltungsaufgaben der Drucker durchführen.

Toolbar Schalter
 Inhalt der Datentabelle
 Datenfeld Aktionen
 Drag and Drop
 Popup Menüs
Toolbar Schalter
Schalter | Name | Beschreibung
 | Strukturierte Ansicht | Die strukturierte Ansicht erlaubt eine flexible Gruppierung der Daten nach beliebigen Kriterien.
 | Formularwechsel | Löst für den aktuellen Drucker den Formularwechsel Dialog aus.
 | Aktivieren | Aktiviert den aktuellen Drucker.
 | Inaktiv setzen | Stoppt den aktuellen Drucker und/oder setzt ihn in den Status inaktiv.
 | Drucker umleiten | Leitet die gesamte Ausgabe auf einen anderen Drucker um.
 | Umleitung aufheben | Hebt die Umleitung des aktuellen Druckers auf.
 | Hilfe | Startet WinCss Help, Kapitel Drucker.
 | Schliessen | Schliesst das aktive Fenster.
Inhalt der Datentabelle

Titel | Zelleninhalt
Nr. | Druckeridentifikation. Eine rote Nummer kennzeichnet, dass im Moment auf diesen Drucker keine Zugriffsberechtigung besteht.
Bezeichnung | Druckerbezeichnung.
Frm | Das im Drucker eingelegte Formular. Auswertungen können nur ausgedruckt werden, wenn der Drucker das entsprechende Formular eingelegt hat und ein Formularwechsel durchgeführt wurde.
Status | Druckerstatus wie z.B. bereit, aktiv, inaktiv, usw.
Auswertung | Bei Druckerstatus aktiv, zeigt dieses Feld die Bezeichnung der momentan druckenden Auswertung an.
Seite/von | Momentan druckende Seite / Total Seiten.
Kopie/von | Momentan druckende Kopie / Total Kopien.
MKZ | Kurzzeichen des Mitarbeiters, der die momentan druckende Auswertung erstellt hat.
Datenfeld Aktionen
Folgende Datenfelder lösen durch Doppelklick eine Aktion aus:
Datenfeld | Aktion
Frm | Löst den Dialog zur Formularwahl aus.
Status | Löst je nach aktuellem Status einen entsprechenden Dialog (freigeben, umleiten, blockieren, stoppen) aus.
Drag and Drop

Drag Objekt | Drop Objekt | Aktion
Formular | Drucker | Löst den Formularwechsel Dialog aus.
Drucker | Auswertung | Löst je nach aktuellem Drucker- und Auswertungsstatus einen entsprechenden Dialog (freigeben, umleiten, aktivieren, Formularwechsel) aus.
Auswertung | Drucker | Wie oben.
Popup Menüs
Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:
Bereich | Menü
Toolbar | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).
Datenzeile | Menü mit allen auch via Toolbar möglichen Aktionen.
Tabellentitel | Aktivieren und deaktivieren der einzelnen Datenspalten.

Siehe auch Bedienung, Formulare, Warteschlange


Formulare
Mit dem Fenster Formulare können Sie mittels Drag and Drop einen Formularwechsel durchführen.

Toolbar Schalter
 Inhalt der Datentabelle
 Drag and Drop
 Popup Menüs
Toolbar Schalter
Schalter | Name | Beschreibung
 | Hilfe | Startet WinCss Help, Kapitel Formulare.
 | Schliessen | Schliesst das aktive Fenster.
Inhalt der Datentabelle

Titel | Zelleninhalt
ID | Formularidentifikation
Bezeichnung | Formularbezeichnung
Drag and Drop

Drag Objekt | Drop Objekt | Aktion
Formular | Drucker | Löst den Formularwechsel Dialog aus.
Popup Menüs
Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:
Bereich | Menü
Toolbar | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).
Tabellentitel | Aktivieren und deaktivieren der einzelnen Datenspalten.

Siehe auch Bedienung, Drucker, Auswertungen


Report Preview, Vorschau
Mit der Vorschau können Sie vor dem Ausdruck Auswertungen betrachten.

Toolbar Schalter
 Popup Menüs
Toolbar Schalter
Schalter | Name | Beschreibung
 | Erste Seite | Ansicht auf erste Seite positionieren.
 | Seite rückwärts | Eine Seite zurück.
 | Seite vorwärts | Eine Seite vorwärts.
 | Letzte Seite | Ansicht auf letzte Seite positionieren.
 | Nach Seite... | Gehe nach Seite.
 | Rückwärts suchen | Mit letztem Suchbegriff rückwärts weitersuchen.
 | Suchen | Text suchen.
 | Weitersuchen | Mit letztem Suchbegriff vorwärts weitersuchen.
 | Kopieren | Markierten Text in die Zwischenablage kopieren.
 | Schrift grösser | Grössere Schrift wählen.
 | Schrift kleiner | Kleinere Schrift wählen.
 | Komprimieren | Eine Folge von mehreren Leerzeilen zu einer Zeile komprimieren.
 | Hilfe | Startet WinCss Help, Kapitel Vorschau.
 | Schliessen | Schliesst das aktive Fenster.
Popup Menüs
Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:
Bereich | Menü
Toolbar | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).
Ansicht | Menü mit allen auch via Toolbar möglichen Aktionen.

Siehe auch Auswertungen, Bedienung


Hinweise zur Bedienung
Die Bedienung der WinCss Dialogfenster erfolgt im allgemein bekannten Windows Standart. Eine Ausnahme bildet der Sortiermechanismus von Datentabellen.

Zur Erinnerung sind nachfolgend die wichtigsten Aktionen aufgeführt:

Popup Menüs
Sortierung
Selektion
Popup Menüs
Popup Menüs werden durch die Betätigung der linken Maustaste ausgelöst. Der Inhalt der Menüs richtet sich nach dem Kontext, d.h. dem Bereich, in welchem sich der Mauszeiger befindet.
Sortierung
Im Gegensatz zu bekannten Windows Programmen, wie z.B. dem Explorer, erlaubt WinCss das Sortieren der in Tabellen dargestellten Daten nach mehreren Kolonnen. Durch Mausklick auf den gewünschten Kolonnentitel wird die Sortierung eingestellt. Es gibt drei verschiedene Zustände:
Symbol | Sortierung
 | Keine spezielle Sortierung.
 | Aufsteigende Sortierung, d.h. der kleinste Wert zuerst, der grösste Wert zuletzt.
 | Absteigende Sortierung, d.h. der grösste Wert zuerst, der kleinste Wert zuletzt.

Die Gewichtung der an einer Sortierung beteiligten Kolonnen ist von links nach rechts. Wird eine andere Gewichtung gewünscht, können die Kolonnen durch Klick und Drag neu angeordnet werden.

Tipp: Um die Sortierung aller Kolonnen aufzuheben, kann das Popup Menü, welches durch Betätigung der rechten Maustaste auf dem Titelbereich erscheint, verwendet werden.

Selektion mehrerer Elemente
Die Selektion mehrerer Datenzeilen einer Tabelle erfolgt mit der linken Maustaste:
Methode | Selektion
ziehen (drag) | Ziehen mit gedrückter Maustaste selektiert mehrere sich folgende Datenzeilen.
Umschalttaste | Klicken mit gedrückter Umschalttaste selektiert den Bereich von der letzten Mauszeigerposition bis zur Klickposition.
Steuerungstaste | Klicken mit gedrückter Steuerungstaste fügt die betroffene Zeile zur Selektion hinzu. Ein zweiter Klick entfernt die Zeile von der Selektion.

Tipp: Mit dem Popup Menü, welches durch Betätigung der rechten Maustaste auf einem Strukturknoten erscheint, können alle Elemente dieses Knotens selektiert werden.


WinCss Options - Allgemein

WinCss Unitec Home Page

X
X

WinCss Optionen - Allgemein
Der Abschnitt Allgemein des Fensters Optionen erlaubt die Verwaltung der allgemeinen Einstellungen von WinCss.

Allgemeine Optionen
Allgemeine Optionen
Option | Beschreibung
Starten mit Mini Toolbar Fenster | Ist diese Option gesetzt startet WinCss mit dem Toolbar Fenster Toolbar Fenster (siehe Hauptsteuerung).
Feldaktion durch Einfachklick | Das Setzen dieser Option erlaubt es, Feldaktionen mit einem einfachen Maustastenklick auszulösen (Standarteinstellung ist der Doppelklick).
Schaltflächen für Feldaktionen anzeigen | Das Setzen dieser Option bewirkt die Darstellung einer kleinen Schaltfläche in jedem Feld, welchem eine Aktion zugeordnet ist.
Automatischer Mauszeiger | Ist diese Option gesetzt, springt beim öffnen eines Fensters der Mauszeiger auf die Default-Schaltfläche.
Löschen mit Bestätigung | Das Ausschalten dieser Option verhindert den üblichen Bestätigungsdialog beim Löschen von Auswertungen. Die Verwendung erfolgt auf eigenes Risiko.

Siehe auch Farboptionen, Verbindungsoptionen


WinCss Options - Allgemein

WinCss Unitec Home Page

X
X

WinCss Optionen - Farben
Der Abschnitt Allgemein des Fensters Optionen erlaubt die Verwaltung der allgemeinen Einstellungen von WinCss.

Farboptionen
Farboptionen
Option | Beschreibung
Default | Wählt die WinCss Standardfarbe für den gewählten Bereich.
Normal | Wechselt zur Standard-Farbpalette
System | Wechselt zur System-Farbpalette
Mehr Farben | Öffnet das erweiterte Farbwahlfenster um zusätzliche Farben zu wählen oder eine eigene Palette zu definieren

Siehe auch Allgemeine Optionen, Verbindungsoptionen


WinCss Options - Verbindung

WinCss Unitec Home Page

X
X

WinCss Optionen - Verbindung
Der Abschnitt Verbindung des Fensters Optionen erlaubt die Einstellungen der Netzwerkverbindung von WinCss.

Verbindungsoptionen
Verbindungsoptionen
Option | Beschreibung
IP Adresse | The IP address of the CSS server system.
Port Nummer | Die TCP/IP Port Nummer unter welcher die CSS Interface Dienste angeboten werden. Für eine Beschreibung der IP Adresse und der Port Nummer siehe nächster Abschnitt.
Server IP Adresse bei jedem Programmstart wählen | Das Setzen dieser Option erlaubt es dem Anwender, bei jedem Programmstart die CSS Server IP Adresse zu wählen.
Loginnamen für CSS Server auf Kleinschreibweise konvertieren | Mit dieser Option können Konflikte durch unterschiedliche Schreibweise der Windows und Unix Loginnamen vermieden werden.

Bitte beachten Sie, dass diese Optionen beim Programmende in der Windows Registry gespeichert werden und erst beim nächsten Aufruf von WinCss aktiv werden.

Siehe auch Allgemeine Optionen, Farboptionen, Client Konfiguration


WinCss Client Konfiguration

Die Installation von WinCss folgt den unter Windows üblichen Standards. Beim ersten Programmstart verlangt WinCss die Eingabe der IP Adresse des CSS Print Servers und schlägt die TCP/IP Portnummer 6801 als Default vor. Wird diese Portnummer in Ihrem Netzwerk schon für andere Zwecke verwendet, muss ein anderer, von Ihrem Netzwerk Administrator festgelgter Wert, eingegeben werden. In diesem sehr unwahrscheinlichen Fall müssen zusätzlich manuelle Konfigurationen durchgeführt werden.

TCP/IP Ports und Services
 Zusätzliche CSS Client Konfiguration
 Starten von WinCss / Fehlerbehebung
TCP/IP Ports und Services

Beim Aufbau einer TCP/IP Client-Server Verbindung muss dem Client (WinCss) die Rechneradresse (IP Adresse) des Rechners, welcher die Serverdienste anbietet bekannt sein. Zusätzlich wird jeder Verbindungstyp (z.B. cssws zu WinCss) durch eine eindeutige Portnummer identifiziert. Das TCP/IP services File definiert symbolische Bezeichnungen für die meisten in einem Netzwerk verwendeten Ports. Bei der Verwendung dieser Service-Namen muss die services Datei auf jedem Knoten, d.h. auf dem Host- und auf allen Client-Systemen, vorhanden sein. Bei Unix Systemen ist services im Directory /etc gespeichert. Bei Windows Systemen variiert das Directory je Betriebsssytem. Jede Zeile in der services Datei enthält den Service Namen, eine Portnummer und einen Porttyp (CSS verwendet immer den Typ tcp). Um Konflikte mit standart TCP/IP Ports zu vermeiden, sollten Portnummern > 5000 verwendet werden. Unitec Produkte verwenden Portnummern im Bereich von 6800 bis 6999.

Da die Verwaltung von services Datein in heterogenen Netzwerken mit einem erheblichen administrativen Aufwand verbunden ist, ist man in letzter Zeit vermehrt dazu übergegangen, für jeden Verbindungstyp Portnummern festzulegen (sog. well known ports). Für die WinCss Verbindung wurde Port 6801 als Default definiert. Um Konflikte mit Software von anderen Herstellern zu vermeiden, kann beim Setup von WinCss eine andere Portnummer angegeben werden. Dieser Wert wird in der Windows Registry unter dem Schlüssel

HKEY_LOCAL_MACHINE\SOFTWARE\Unitec\WinCss\CurrentVersion

im Bezeichner CssPort abgelegt.

Für alle CSS Server (Unix und Windows NT) ist die Portnummer in der Konfigurationsdatei css.default im Parameter WINCSS_PORT definiert.

Die Programme cssws und WinCss erlauben zusätzlich die TCP/IP Konfiguration auf der Befehlszeile anzugeben. Beispiel:

cssws -p 7001 | der Unix WinCss Server soll die Portnummer 7001 verwenden
WinCss -h 128.41.1.1 -p 7001 | der WinCss Client verbindet sich mit dem CSS Server auf dem Host mit der IP Adresse 128.41.1.1 unter Verwendung der Portnummer 7001

Für Informationen betreffend der Konfiguration des Unix und Windows/NT Servers siehe in den entsprechenden Abschnitten und im CSS Online Handbuch.
Zusätzliche CSS Client Konfiguration

Das Windows CSS Programm kann in zwei unterschiedlichen Arten betrieben werden. Beim Standartbetrieb wird das Window Warteschlange zur Hauptsteuerung verwendet. Mit der Option -m oder /m kann dazu auch das Mini Toolbar Fenster verwendet werden. Die Option kann nach der Installation in den Properties des Programmes WinCss.exe im WinCss Folder als Default definiert werden.

Zusätzlich kann mit der Option -h oder /h die IP Adresse des Servers und mit -p oder /p die TCP/IP Portnummer angegeben werden. Damit ist es möglich, von einem Client auf mehrere CSS Server gleichzeitig zuzugreifen.
Starten von WinCss / Fehlerbehebung

Es muss sichergestellt werden, dass alle oben beschriebenen Schritte durchgeführt wurden und das Programm setup.exe ohne Fehler abgelaufen ist. WinCss ist nun für den ersten Einsatz bereit. Treten beim Aufstarten Fehler auf, überprüfen Sie bitte nochmals Ihre TCP/IP Eingaben. Nachdem die notwendigen Änderungen gemacht wurden, muss der Unitec Communication Manager Ucm.exe gestoppt werden. Dieser Prozess wird auf dem Windows System automatisch gestartet und läuft unsichtbar im Hintergrund. Um das Programm zu stoppen, geben Sie Ctrl-Alt-U ein um das UCM Icon auf der Windows Taskbar sichtbar zu machen. Durch Betätigung der rechten Maustaste wird ein Popup-Menü sichtbar auf welchem Sie die Aktion Close auswählen sollten. Wird eine Warnung ausgegeben bestätigen Sie diese mit dem Close Schalter. WinCss kann nun neu gestartet werden.

Das Hilfsprogramm CssVerCk.exe kann verwendet werden um Versionskonflikte mit den installierten Windows Komponenten zu erkennen.

Siehe auch Verbindungsoptionen, Allgemeine Optionen


Unix CSS Server Konfiguration

Die Installation von Unix CSS erfordert einige System Administrator Kenntnisse. Die folgenden Abschnitte vermitteln weitere nützliche Informationen.

TCP/IP Ports und Services
 Starten des Server Prozesses
TCP/IP Ports und Services

Für alle CSS Server (Unix und Windows NT) ist die WinCss TCP/IP Portnummer 6801 vordefiniert, kann jedoch in der Konfigurationsdatei css.default im Parameter WINCSS_PORT geändert werden.

Die Programme cssws(U) und WinCss erlauben zusätzlich die TCP/IP Konfiguration auf der Befehlszeile anzugeben.
Starten des Server Prozesses

Beim Systemstart muss - wie jeder andere Server Prozess auch - das Programm /usr/lib/css/cssws aufgerufen werden. Dazu stehen verschiedene Systemdienste, wie z.B. /etc/rc(4) oder /etc/inittab(4) zur Verfügung.

/etc/rc:

/usr/lib/css/cssws 2>/dev/null 1>&2

Nuf Unix System V:

Dieselbe Verarbeitung kann unter System V durch folgenden Eintrag in /etc/inittab(4) erreicht werden:

cssws:1:respawn:/usr/lib/css/cssws 2>/dev/null 1>&2

Internet Super Server (inetd):

Da der Internet Super Server inetd(1) symbolische Service Namen erwartet, muss in der Datei /etc/services folgende Zeile eingefügt werden:

cssws 6801/tcp # WinCss server

Fügen Sie danach folgende Zeilen in der Datei /etc/inetd.conf ein:

# CSS Service
cssws stream tcp nowait root /usr/lib/css/cssws -i

Der inetd(1) Prozess liest beim Aufstarten die Datei /etc/inetd.conf, um sich selbst zu initialisieren. Dies macht die Dienste des cssws Servers für Verbindungen des Windows Client Programmes WinCss.exe verfügbar.

Wird cssws nicht vom init(1) Programm gestartet, setzt sich der cssws(U) Prozess automatisch in den Hintergrund (detach).

Hinweis:

Die WinCss Software muss mit dem Unitec License Manager ulm(I) Programm registriert und serialisiert werden.

Siehe auch Client Konfiguration, Verbindungsoptionen


Windows/NT CSS Server Konfiguration

Die WinCss Server Dienste werden vom Programm CssNTSrv zur Verfügung gestellt. Dieses Programm wird von Setup als NT Service installiert und startet beim Systemboot automatisch.

Für alle CSS Server (Unix und Windows NT) ist die WinCss TCP/IP Portnummer 6801 vordefiniert, kann jedoch in der Konfigurationsdatei css.default im Parameter WINCSS_PORT geändert werden.

Die Programme cssws(U)und WinCss erlauben zusätzlich die TCP/IP Konfiguration auf der Befehlszeile anzugeben.

Hinweis:

Die WinCss Software muss mit dem Unitec License Manager ulm(I) Programm registriert und serialisiert werden.

Siehe auch Client Konfiguration, Verbindungsoptionen


Über Unitec

Unitec Informatik ist eine kleine, 1980 gegründete Schweizer Software Firma, die sich auf die Entwicklung von Unix und Windows System-Programmen spezialisiert hat.

Unsere Hauptprodukte sind CSS (Commercial Spooling System), ein speziell für kommerziele Anwendungen konzipierter Spooler (Druckverwaltung) für Unix und Windows/NT, sowie UCM (Unitec Communication Manager) für Client-Server Kommunikation in heterogenen Netzwerken.

Wir sind stolz darauf, von unseren Kunden als beste Quelle für Druckverwaltungssoftware und Kommunikationstechnik gewählt zu sein. Unitec Software hat eine bekannt hohe Qualität.

Unser Support-Telefon läutet praktisch nie und wir setzen alles daran, dass es auch in Zukunft dabei bleibt.


Technische Unterstützung

Diese Help Datei und das Online Handbuch wurden im Bestreben, möglichst vollständige und präzise Informationen über die WinCss Software zu bieten, erstellt.

Falls Sie eine Frage haben, beginnen Sie bitte damit die Online Dokumentation zu konsultieren.

Kann Ihre Frage damit nicht beantwortet werden, können Sie sich via E-Mail an unseren Support unter support@unitec.ch wenden. Da wir nicht für durchgehenden Telefon-Support eingerichtet sind, ist der Kontakt via E-Mail die beste Wahl um schnell eine Lösung für Ihre Probleme zu erhalten.


Unitec kontaktieren

Postadresse: | Unitec Informatik Leerueti 797 CH-8625 Gossau, Switzerland
Telefon: | +41 1 935 4064
Fax: | +41 1 935 4466
Home Page: | http://www.unitec.ch
E-Mail: | info@unitec.ch
Verkauf: | sales@unitec.ch
Support: | support@unitec.ch

Für Informationen über internationale Vertretungen, besuchen Sie bitte unsere Web Site.


Unitec Produkte

CSS Commercial Spooling System

Der viel beachtete und stark verbreitete Spooler (Druckverwaltung) für Unix und Windows/NT, speziell für die Bedürfnisse der kommerziellen EDV geeignet, wird weltweit von mehr als 25'000 Benutzern angewendet.

WinCss

Die grafische Schnittstelle für Unix CSS und CssNT.

UCM Unitec Communication Manager

Die einfachste Art, um in heterogenen Netzwerken komplexe Client-Server Applikationen sowie lokale Interprozess Kommunikation zu implementieren.

Um aktuelle Informationen zu allen Unitec Produkten zu erhalten, besuchen Sie bitte unsere Home Page unter www.unitec.ch.


CSS Online Handbuch

Das in diesem Help Dokument verschiedentlich erwähnte CSS Online Handbuch wird nicht mit allen Paketen ausgeliefert.

Es kann jedoch Online im Support Bereich konsultiert oder vom Download Bereich unserer Web Site unter www.unitec.ch heruntergeladen werden. Es stehen mehrere verschiedene Formate zur Verfügung.


Konfiguration

Kapitel 4 - Konfiguration

4.1. Übersicht

In diesem Kapitel sind die vielfältigen Konfigurations-Möglichkeiten von CSS beschrieben:

  • allgemeine, systemweit geltende Parameter werden in /etc/css.default gesetzt.
  • mehrere Dateien sind beteiligt an der Konfiguration von virtuelllen CSS Servern.
  • die Parameter von virtuellen CSS Servern werden in der Datei $CSS_ENV/etc/css.default definiert.
  • die verfügbaren Drucker, deren Eigenschaften und Steuersequenzen werden in /etc/css.devices definiert.
  • die verwendeten Formulare und deren Dimensionen werden in /etc/css.forms definiert.
  • die Parameter für den Lizenz Manager werden in /etc/ulm.default gesetzt.
  • mehrere Dateien sind beteiligt an der Konfiguration von WinCss.

Wichtig!

Drucker- und Formular-Definitionen werden erst nach erfolgreicher Kompilation mit dem Programm csa(U) wirksam.


Css.Default

CSS Environment

css.default(C)
Name Plattform Beschreibung Parameter Hinweise

Name

css.default

Plattform

Unix, Windows NT

Beschreibung

Css.default enthält die Definition von systemweit gültigen CSS Parametern. Beim Betrieb von virtuellen CSS Drucker Servern, hat jeder dieser Server eine zusätzliche Defaultdatei innerhalb seiner mittels CSS_ENV gesetzten Verzeichnisstruktur. Jeder CSS Befehl konsultiert die hier beschriebene Datei beim Programmstart. Die Datei enthält eine oder mehrere Zeilen, welche Defaultinformation enthalten. Das Format der Parameterzeilen ist:

Name=Value

wobei Name den Informationstyp und Value dessen Wert bezeichnet. Die genaue Schreibweise von Name und die dazugehörenden Werte Value sind in der folgenden Tabelle beschrieben.

Zeilen, welche mit dem Zeichen '#' beginnen, gelten als Kommentar.

Beim Parameter-Name wird, im Gegensatz zum Parameter-Wert, zwischen Gross- und Kleinschreibweise nicht unterschieden.

In der aktuellen CSS Version sind folgende Konfigurationsmöglichkeiten gegeben:

Parameter

Die folgende Tabelle beschreibt systemabhängige Parameter, die nur in speziellen Umgebungen Anwendung finden:

Name | Beschreibung | Default-Wert
AUTO_REORG Automatische Reorganisation der Warteschlange beim ersten Aufruf von css(U) je Kalendertag (löschen der Auswertungen, deren Keep-Datum abgelaufen ist):

no: | keine Reorg
all: | alle abgelaufenen
printed: | alle abgelaufenen und vollständig ausgedruckten

Siehe auch csa(U), k- und K-Option.

no
BANNER_MARGIN | Normalerweise bedrucken Banner Seiten die erste bis zur letzten Zeile der Seite. Bei ungenau eingestellten Formularen kann dies dazu führen, dass auch Seiten der Auswertung teilweise mit Banner Zeilen bedruckt werden. Um dies zu vermeiden, kann der BANNER_MARGIN Parameter dazu verwendet werden, einen oberen und unteren Rand der Banner Seite zu definieren. | 0
BINARY_VIEW | Anzeige von binären Auswertungen im css(U) Dialog: true oder false. Wir empfehlen diese Option für Endanwender auszuschalten. | false
CSS_BASE_DIR Basis-Directory mit allen CSS Steuerdateien, der Lizenz-Informationsdatei und dem Drucker-Daemon lpd. Der gewünschte Pfad kann beim Setup Programm angegeben werden. /usr/lib/css

CssNT:

lib
CSS_SPOOL_DIR Directory zur Aufnahme der Druckaufträge. Der gewünschte Pfad kann beim Setup Programm angegeben werden. /usr/spool/css
CssNT:

spool
CSS_VERSION | Version des installierten CSS Systemes. Dieser Eintrag wird von setup(I) generiert und sollte nie geändert werden.
DATE_TYPE Form der Datum-Darstellung im css(U) Dialog:

AM, US: | MM/DD/YY
EU: | DD.MM.YY
IN: | YY/MM/DD
 EU
DEFAULT_FORM | Definiert das Default Formular, falls beim lpr(U) Aufruf keine f-Option angegeben wird. | A
DEFUALT_DEVICE | Definiert den Default Drucker, falls beim lpr(U) Aufruf keine d-Option angegeben wird. | 0
DEV_STOP_TIMEOUT | Dieser Parameter kontrolliert das Verhalten des lpd Programmes bei Stop Aktionen von einem aktiven Ausdruck. Wird der Wert ungleich Null gesetzt, stoppt der Despooler Prozess nach der angegebenen Anzahl Sekunden auch dann, wenn die aktuelle Seite nicht vollständig ausgedruckt wurde. Der Drucker und die Auswertung werden in den Status 'blockiert'gesetzt. Es ist zu beachten, dass selbst mit einem gesetzten DEV_STOP_TIMEOUT Parameter, der Prozess nicht in jedem Falle in der Lage ist, sich zu beenden. Viele Unix Systeme erlauben es einem Prozess nicht abzuschliessen, solange pendente Ausgabeoperationen noch nicht abgeschlossen wurden (typisch bei ausgeschaltetem Drucker). Sobald der Drucker wieder eingeschaltet wird, sollte die Verarbeitung wie erwartet abgeschlossen werden können. Um CSS die Gelegenheit zu geben, nach dem Druck der aktuellen Seite zu stoppen, sollte dieser Parameter auf einen vernünftigen Wert gesetzt werden (z.B. 90). | 0
ERRLOG_SIZE | Legt die Grösse der CSS lpd Fehler Log Datei css.errlog in KB fest. Erreicht die Datei die angegebene Grösse, wird sie zurückgesetzt und alle zuvor aufgezeichnete Information geht verloren. | 4
EXT_LOCK Legt die Methode für die Verarbeitung des el-Parameters in css.devices fest:

lock: | Das Lockfile wird durch internes UNIX Locking belegt und durch den Kernel automatisch entfernt falls der lpd Daemon nicht korrekt abschliesst. Das File bleibt erhalten. Dies ist die sicherere Methode.
sema: | Das Locking wird mit Hilfe einer File-Semaphore durchgeführt. Diese Methode kommt bei der Synchronisation mit anderen Software-Paketen häufig zur Anwendung
 lock
JOB_FLAGS | Dieser Parameter kann auf den Wert true gesetzt werden, um das Verhalten von älteren CSS Versionen als Release 3.4 zu simulieren. Für Details, siehe unter den Hinweisen zur Migration in Kapitel 1. | false
LANGENV | Mit diesem Parameter kann der Name einer Umgebungs-Variable angegeben werden, welche von css(U) zur Steuerung der Dialogsprache verwendet werden soll. Wenn angegeben, hat der entsprechende Wert vor dem LANGUAGE Parameter Vorrang, kann jedoch mit der L-Option von css(U) überschrieben werden.
LANGUAGE Sprache des Dialoges von css(U):

dutch, english, french, italian oder german 		english
PROTECTION Berechtigungs-Schutz der Auswertungen:

user: | User-ID
group: | Group-ID, resp. Gruppenzugehörigkeit unter Windows NT
none: | kein Schutz
 user
PUBLIC_GROUP | Ungeachtet des Berechtigungs-Schutzes, der mit dem PROTECTION Parameter definiert ist, haben alle Benutzer Zugriff auf Auswertungen, welche einer Gruppe (Unix group) gehören, die in diesem Parameter aufgelistet ist. Besitzer einer neue Auswertung ist der User und die damit assoziierte Group. Die Zughörigkeit kann auch mit der u- und g-Option von lpr(U) gesteuert werden. In diesem Parameter kann eine oder mehrere Gruppen (Name oder Nummer), welche durch das Zeichen '|' oder durch Kommas ',' getrennt sind, angegeben werden. Unter Windows NT können nur Gruppennamen verwendet werden.
PUBLIC_USER | Ungeachtet des Berechtigungs-Schutzes, der mit dem PROTECTION Parameter definiert ist, haben alle Benutzer Zugriff auf Auswertungen, welche einem Benutzer (Unix user) gehören, der in diesem Parameter aufgelistet ist. Es kann ein oder mehrere Benutzer (Name oder Nummer), welche durch das Zeichen '|' oder durch Kommas ',' getrennt sind, angegeben werden. Unter Windows NT können nur Benuzernamen verwendet werden.
SHOW_CSSFLAGS | Veranlasst das Programm css(U) die d-, u- und x-Option, falls gesetzt, in den entsprechenden Bildschirm-Titelzeilen anzuzeigen. | true
TEST_PRINT Frage nach Testdruck beim Formular-Wechsel via css(U):

true oder false 		true
TEST_PRINT_ACHAR | Text Substitutions-Zeichen beim Testdruck via css(U). | X
TEST_PRINT_NCHAR | Zahlen Substitutions-Zeichen beim Testdruck via css(U). | 9
VIEW_CONTROL_CHAR Definiert das Substitutions-Zeichen für nicht druckbare Zeichen im Dialog von css(U) (Befehl Anzeigen). Solche Zeichen sind von 0x00 bis 0x19, 0x7f und 0xff, ausser CR, LF, BS und TAB. Die folgenden Werte sind möglich:

space: | Leerzeichen 0x20
null: | nicht anzeigen
x: | benutze Zeichen x
VIEW_DEVICE | Bezeichnet die für die Aufbereitung der Auswertungsdaten zur Vorschau in css(U) zu verwendende Druckerdefinition.
WINDOWS_SERVER | Definiert den Service Namen des Windows Servers cssws(U). Derselbe Name muss auch in /etc/services vorhanden sein. | cssws
WINCSS_PORT | Definiert die vom Windows Server cssws(U) resp. dem NT Service Prozess CssNTSrv(U) zu verwendende TCP/IP Portnummer. | 6801
WINCSS_VIEW_DEVICE | Bezeichnet die für die Aufbereitung der Auswertungsdaten zur Vorschau in WinCss(U) zu verwendende Druckerdefinition. | Wert in VIEW_DEVICE
WRAP_SCREEN | Ein- / ausschalten des Defaults zur Navigation von Bildfolgen im css(U) Dialog von der letzten zur ersten Seite. | false

Die folgende Tabelle beschreibt systemabhängige Parameter, die nur in speziellen Umgebungen Anwendung finden:

Name | Beschreibung | Default-Wert
INT_LOCK Interne Lock Methode welche CSS für seine Datenbanken anwendet. Dieser Parameter wurde wegen eines Fehlers im lockd(1) Daemon von Ultrix Rel. 4.30 eingeführt. Wenn z.B. der Befehl csu -i1 blockiert, versuchen Sie mit INT_LOCK=sema den Fehler zu beheben. Wir empfehlen jedoch, den lockd Daemon von Rel. 4.2a oder 4.3a zu verwenden, der ohne Fehler arbeitet. Mögliche Werte:

lock: Die normale Lock Methode.
sema: Veranlasst CSS für sein internes Locking, File-Semaphoren zu verwenden. Bitte beachten Sie, dass ein CSS Prozess, wenn überhaupt, immer mit dem Signal 15 gestoppt werden sollte (d.h. mit kill oder kill -15). Falls aus bestimmtem Grunde trotzdem mit kill -9 abgebrochen wird, sollten im CSS Spool Directory (norm. /usr/spool/css) folgende Dateien gelöscht werden:

lck..dev | (Devices)
lck..form | (Forms)
lck..rep | (Reports)

Der Befehl rm -f /usr/spool/css/lck..* kann im Systemstart Ablauf eingebaut werden.

lock
LOCAL_TIME | Schaltet die Zeitzonen und Sommerzeit Berechnung mittels der localtime(3) Library Funktion ein / aus: true oder false. Der false Wert kann verwendet werden um fehlerhafte Zeitinformation in der Warteschlange zu korrigieren. Solche Fehler treten durch inkorrekte TZ Umgebung oder durch Systeme welche ohne Zeitzonen-Anpassung generiert wurden auf. | true
Beim Einsatz von Drucker- oder Terminalservern wurden einige Probleme gemeldet. Um den Betrieb in speziellen Umgebungen zu erleichtern, wurde die strenge Statusprüfung der IO Funktionen im CSS Despooler lpd aufgehoben. Sie können jedoch mit dem true Wert in den folgenden Parameter wieder aktiviert werden. Zur Analyse werden Fehlermeldungen von IO Funktionen in der Datei css.errlog im Basis-Directory (normalerweise /usr/lib/css) protokolliert.
LPD_CLOSE_CHECK | Prüfe den Status der close(2) Funktion, true oder false | false
LPD_CLOSE_DLAY | Warte n Sekunden vor dem Aufruf der close(2) Funktion. | 0
LPD_DV_MULTY_OPEN | Führe für jede Auswertung eine open(2) / close(2) Kombination durch, true oder false. Keine Wirkung für Output-Pipes. | false
LPD_FLUSH_CHECK | Prüfe den Status der fflush(3) Funktion, true oder false | false
LPD_FLUSH_DELAY | Warte n Sekunden vor dem Aufruf der fflush(3) Funktion. | 0
LPD_OP_CLOSE_CHECK | Prüfe den Status der pclose(3) Funktion für Output-Pipes, true oder false | false
LPD_SIGPIPE_CHECK | Prüfe das broken pipe Signal sigpipe, true or false | false
LPD_WRITE_CHECK | Prüfe den Status der write(2) Funktion, true oder false | false

Hinweise

Ausser TIME werden unter CssNT die systemabängigen Parameter zwar akzeptiert, sind jedoch ohne Wirkung.

Ist /etc/css.default auf dem System nicht vorhanden, arbeitet CSS mit der Default-Konfiguration.
Wichtig!

Stimmen die Directory-Beschreibungen nicht mit den tatsächlichen Gegebenheiten überein, kann CSS nicht betrieben werden!


Css.Devices

Device Definition Data Base

css.devices(C)
Name Plattform Beschreibung Eigenschaften Typen Allgemeine Eigenschaften Formfeed / Linefeed Zeichenübersetzung Escapeübersetzung Remote Printing Hinweise Files Siehe auch

Name

css.devices

Plattform

Unix, Windows NT

Beschreibung

Css.devices beschreibt die vom CSS Spooling System verwendeten Geräte (Drucker). Die Drucker werden durch die Beschreibung ihrer Eigenschaften und Steuersequenzen definiert.

Die Definitionen in css.devices setzen sich aus einer Anzahl von durch ':' getrennten Einträgen zusammen (analog termcap(5)). Der erste Eintrag jeder Druckerdefinition bestimmt die logische Device-Nummer (1..999) und nach dem Trennzeichen '|' eine bis zu 20 Stellen lange Geräte Bezeichnung (Leerzeichen sind darin erlaubt). Sind mehrere Definitionen mit gleicher logischer Device-Nummer vorhanden, so gilt die letzte Definition. Definitionen mit der Device-Nummer '0' sind inaktiv und werden ignoriert. Im Gegensatz zu termcap(5) dienen die Definitionen in css.devices nicht als Referenz-Datei. Sie werden vielmehr mittels csa(U) in eine effizienter organisierte Datei (/usr/lib/css/dev) umgewandelt. Folglich werden Änderungen in css.devices erst nach erfolgter Umwandlung aktiv.

Eigenschaften

Name | Typ | Beschreibung | Default
as | bool | automatische Druckerwahl | false
bm | bool | binärer Modus | false
bol | str | Steuerzeichen vor jeder Zeile (begin of line)
bop | str | Steuerzeichen vor jeder Seite (begin of page)
bor | str | Steuerzeichen vor Auswertung (begin of report)
bp | bool | Deckblatt (banner page) | false
cr | bool | LF » CR/LF Umwandlung | false
dn | str | Drucker-Name als alternatives Identifikations-Merkmal zur Drucker-Nummer
dt | str | Drucker-Typ
dv | str | UNIX Device-File
el | str | UNIX Lock-File (external lock)
eol | str | Steuerzeichen nach jeder Zeile (end of line)
eop | str | Steuerzeichen nach jeder Seite (end of page)
eor | str | Steuerzeichen nach Auswertung (end of report)
es | bool | Breitschrift (e9, e10) durch einfügen von Leerzeichen (elongate by spaces) | false
et | bool | Nimmt für das tab Zeichen standart Tabulatorpositionen an (expand tabs). Nützlich für Schnittstellen, welche nicht mit stty(1) konfiguriert werden können, wie z.B. Parallel Ports.
e1..e127 | str | Escape-Übersetzung
fp | num | Formfeed-Padding (veraltet) | 0
if1 | str | Drucker Initialisierungs-File 1
if2 | str | Drucker Initialisierungs-File 2
lp | num | Linefeed-Padding (veraltet) | 0
map | str | Formular-Klassen Zusammenfassung
mp | num | Max. Pages. Beschränkt die Ausgabe auf maximal num Seiten pro Report. Setzt die Auswertung auf den Status ‘blockiert’, falls die Limite erreicht wird.
op | str | Filter-Programm (output thru pipe)
pg | bool | Page-Printer | false
ps | num | Page-Size (gemäss Geräte-Switches) | 0
rpm str Remote print mode:
Mode | Protokoll
lpd | standard BSD lpd
rlpd | relaxed lpd
rtel | reverse telnet
pros | Axis Pros
raw | TCP/IP direct port addressing

Für eine detaillierte Beschreibung siehe Abschnitt Remote Printing weiter unten.

rph | str | Remote print Host Name oder IP Adresse
rpp str Remote print Port Nummer oder Service Name
Mode | Default
lpd | 515
rlpd | 515
rtel | 2000
pros | 35
raw | none
rpq | str | Remote print Queue Name. In einigen Druckerbox Handbüchern wird dieser Wert auch als 'remote port', 'remote service name' oder 'remote printer name' bezeichnet.
rpr | str | Remote Port
rpw str Remote Passwort
Mode | Default
pros | netprinter
tf1 | str | Drucker Abschluss-File 1
tf2 | str | Drucker Abschluss-File 2
tr | str=str | Zeichenübersetzung (translate)
vd | bool | View Device | false
wfc | str | Write fail command
wft | num | Write fail timeout in Sekunden | 3600
xmap | str | Formular-Klassen Zusammenfassung (exclusive map)
# str Kommentar

Der folgende Eintrag beschreibt einige der Eigenschaften eines Brother HL-8 im LaserJet II Modus:

1|HL-8 (LaserJet Mode):dn=HL8:as:pg:cr:\
:dv=/dev/tty04:dt=HPGL:map=a,a4h,a4q:\
:bor=\EE\E&l0O\E&l68P\E&l66F\E&l2E\E*t300R:\
:bor <A4L>=\E&l1O\E&l48P\E&l46F:\
:eor=\EE:\
:e1=\E&k0S:#10 cpi:e2=\E&k4S:#12 cpi:\
:e3=\E&k2S:#16.5 cpi:e4=\E&k2S:#16.5 cpi:\
:e11=\E(s1S:e12=\E(s0S:#italic on/off:\
:e15=\E&a-0.5R:\e16=\E=:#superscript on/off:\
:e17=\E=:e18=\E&a-0.5R:#subscript on/off:

Definitionen können sich über mehrere Zeilen erstrecken. Das letzte Zeichen einer Zeile muss dabei ein '\' (Backslash) sein. Zur Verbesserung der Lesbarkeit sind leere Einträge erlaubt.

Mit Hilfe des include Befehles können Druckerdefinitionen auch aus mehreren Dateien zusammengesetzt werden:

1|Drucker 1:include=file:

Include-Dateien können sich nicht über mehrere Druckerdefinitionen erstrecken, d.h. sie dürfen nur Eigenschaften des Druckers enthalten, für welchen der include Befehl eingegeben wurde. Include Dateien können verschachtelt sein und mehrere include Befehle pro Druckerdefinition sind erlaubt. Der Name der Datei file kann absolut (Name beginnt mit ‘/’) oder relative definiert werden. Letztere werden in $base_dir/include (normalerweise /usr/lib/css/include) gesucht. Das Zeilen-Forsetztungszeichen ‘\’ kann innerhalb von include Dateien weggelassen werden.

Typen

Jeder Eintrag hat einen Zwei- bis Vier-Zeichen Namen. Zum Beispiel wird die Tatsache, dass ein Drucker automatisch angewählt werden soll, mit dem Eintrag as (automatic printer selection) gesteuert. Bei numerischen und bei String-Einträgen ist der Name gefolgt vom Zeichen '=' und dem entsprechenden Wert. Numerische Werte werden dezimal angegeben. In String-Werten können folgende Escape-Sequenzen angegeben werden:

\E | Escape-Zeichen
^x | Control-X (x = jedes beliebige Zeichen)
\n | Linefeed
\r | Carriage Return
\t | Tabulator
\a | Audible Alarm
\b | Backspace
\f | Formfeed
\v | Vertical Tab

Jedes beliebige Zeichen kann nach dem Backslash '\' mit drei oktalen Zahlen oder nach '\x' mit zwei hexadezimalen Zahlen eingegeben werden. Mit Hilfe der Tilde '~' kann das erste Bit gesetzt werden (high-order Bit / \200). Dabei sind auch Kombinationen wie '~^x' oder '~\E' möglich. Die Zeichen '=', '%', ':', '^', '~', '/' und '\' können als \=, \%, \:, \^, \~, \/ und \\, oder in ihrer oktalen resp. hexadezimalen Form eingegeben werden.

Allgemeine Eigenschaften

Um die Verbindung CSS-Devices zu UNIX-Devices zu definieren, dient die dv-Eingabe. Beginnt der String mit dem Zeichen '/' wird die Eingabe unverändert als UNIX Filename übernommen. Andernfalls gilt die Zusammenfassung von '/dev/lp' und dem dv-Eintrag (z.B. dv=02 ergibt '/dev/lp 02'). Ist kein dv-Eintrag angegeben, so wird der entsprechende Drucker via /dev/lp (Drucker-Nr 1) resp. /dev/lp x (Drucker-Nr x <> 1) angesprochen. Die Einstellung der Schnittstelle (wie Baud-Rate, Anzahl Datenbits etc.) wird mit setmode(U) vorgenommen.

Unter Windows NT werden die Devices in der Universal Naming Convention (UNC) definiert:

dv=//host-name/printer-share-name

Bitte beachten Sie, dass innerhalb css.devices alle Dateinamen mit dem Unix Separator '/' eingegeben werden müssen. Nach dem Laufwerkbezeichner muss dem ':' ein Backslash '\' (BS) vorgestellt werden, da andernfalls das Ende des Parameters angenommen wird, z.B.

C\:/dev/printer1

Als Ausgabedevice kann auch eine Diskdatei angegeben werden. Diese Möglichkeit wird häufig verwendet, um zu überprüfen welchen Output eine Device Definition bewirkt. Der Inhalt dieser Datei wird durch jede Ausgabe überschrieben. Der beim CssNT Setup installierte Drucker hat z.B. den Eintrag:

dv=C\:/CssDev1.txt

wodurch die Ausgabe auf C:\CssDev1.txt erfolgt.

Bei allen CSS Programmen kann anstelle der Drucker-Nummer auch ein symbolischer Name verwendet werden. Dabei wird jeweils zwischen Gross- und Kleinschreibweise nicht unterschieden. Der Name kann mit dem dn-Eintrag definiert werden, muss mit einem Buchstaben beginnen und darf keine Leerzeichen enthalten. Die maximale Länge beträgt 16 Zeichen.

Mit dem dt-Eintrag kann der Drucker einem bestimmten Typ zugeordnet werden. CSS erlaubt das Umleiten einer binären Auswertung nur auf Drucker desselben Typs. Ein identischer Typ sollte demzufolge nur Druckern mit identischen Steuereigenschaften zugeordnet werden (z.B. HPGL4, PostScript). Die maximale Länge beträgt 14 Zeichen.

Muss CSS einen Drucker mit einem Software-Paket mit integriertem Spooler teilen, kann mittels el-Eintrag ein Lock-Filename angegeben werden. Ein solcher Drucker wird nur benutzt, falls das entsprechende Lockfile dies eraulaubt. Die Lock-Methode wird durch den ext_lock Parameter in css.default bestimmt. Ist der Drucker frei, zeigt CSS seine Belegung durch das Erstellen resp. das Locking des Lockfiles für die Dauer des Ausdruckes an. Der Name muss in absoluter Form, d.h. mit dem Zeichen '/' beginnend, angegeben werden (z.B. /usr/spool/lock/lck_lp2). Filenamen die mit '/usr/spool/css/LCK..' beginnen, dürfen nicht verwendet werden.

Der Zugriffspfad für Lockfiles muss existieren und allgemein benutzbar sein (siehe mkdir(1) und chmod(1)). Es liegt in der Verantwortung des System-Administrators, dafür zu sorgen, dass kein Drucker durch "herrenlose" Lockfiles unansprechbar wird. Insbesonders sind kill(1)-Befehle mit der -9 Option zu vermeiden. Zur Wiederherstellung eines gültigen Zustandes nach Power-Fails, können entsprechende rm(1)-Befehle im File /etc/rc vorgesehen werden.

Der el-Eintrag kann auch dazu verwendet werden, mehrere logische Drucker (mit unterschiedlichen Definitionen) auf einem physischen Drucker abzubilden. Soll ein Drucker automatisch angesteuert werden, sofern das gewünschte Formular eingespannt ist, muss der as-Eintrag gesetzt sein.

Der as-Eintrag ist für den/die Hauptdrucker anzugeben. Soll ein Drucker jedoch nur durch explizite Druckerwahl angesteuert werden, sollte as nicht angegeben werden (typisch für Typenraddrucker / Off-Site Drucker).

Kann ein Drucker Breitschrift nicht unterstützen (Sequenzen e9 und e10), kann dieser Druckmodus mit dem es-Eintrag simuliert werden. Elongate by spaces fügt nach jedem Zeichen ein Leerzeichen ein.

Sollen Tab Zeichen auf standart Tabulatorpositionen erweitert werden, kann dies mit dem et-Eintrag (expand tabs) erreicht werden.

Da bei Laserdruckern die Formular-Dimensionen oft mittels bor-Eintrag definiert werden, können ohne Formular-Wechsel auf dieselbe Papiersorte verschiedene Formular-Typen ausgegeben werden (automatischer Formular-Wechsel). Solche Formular-Gruppen werden mit dem map-Eintrag definiert. Zum Beispiel fasst map=a,b,e,f die Formulare A, B, E und F zusammen und löst somit einen Ausdruck auf eines dieser Formulare auch dann aus, wenn ein anderes derselben Gruppe als aktuelles Drucker-Formular gilt. Zur Bestimmung der Seiten- resp. Zeilenlänge gelten jedoch immer die Daten des angesprochenen Formulars. Es können pro Drucker mehrere map-Definitionen eingegeben werden.

Der xmap-Eintrag (exclusive map) dient dazu, alle Formulare zusammenzufassen, ausser jenen, welche unter xmap definiert sind. Bei der Verwendung von xmap, sind map-Definitionen erlaubt, jedoch auf Gruppierungen von den unter xmap angegebenen Formularen beschränkt.

Der Ausdruck eines oder mehrerer Deckblätter (Banner-Pages), wird durch den bp-Eintrag gesteuert. Deckblätter werden jedoch nur erzeugt, falls in der Definition des verwendeten Formulars der gleichnamige Eintrag ebenfalls gesetzt ist.

Css bietet die Möglichkeit, zu bestimmten Zeitpunkten eines Ausdruckes, Zeichensequenzen (Text und Steuerzeichen) in die Ausgabe an den Drucker einzumischen:
bor | am Anfang einer Auswertung
bop | am Anfang jeder Seite
bol | am Anfang jeder Zeile
eor | am Ende einer Auswertung
eop | am Ende jeder Seite
eol | am Ende jeder Zeile

Die Syntax der bo x und eo x Definitionen ist:

name [<form>][/flag...][%var.eq.val...][{copy}][[page]][(line)][-option...]=value

Es können beliebig viele der obigen Einträge definiert werden. Die Ausgabe erfolgt streng in der Reihenfolge der Definition. Durch die Angabe von einer oder mehrerer Bedingungen kann die Wirkungsweise der Definitionen eingeschränkt werden.

Die möglichen Bedingungen sind:

Bedingung | Die Definition ist gültig falls...
<form> | ...der Ausdruck auf das Formular form erfolgt
/flag ...die Condition-Flag Bedingung zutrifft. Flags können via C-Option beim lpr(U) Aufruf oder dynamisch während des Ausdruckes gesetzt wurden. Durch die Eingabe eines Operators kann die logische Verknüpfung definiert werden:
/&flags | And-Verknüpfung (Default): alle definierten Flags müssen gesetzt sein
/|flags | Or-Verknüpfung: mind. ein Flag muss gesetzt sein
/!flags | Not-Verknüpfung: kein Flag darf gesetzt sein
/(expr) Flag Expression. Es stehen die Opera-toren '!' (unary not), '&' (and) und '|' (or) zur Verfügung. Die Operatoren haben eine abnehmende Gewichtung von '!', '&' bis '|'. Mit Klammern kann die Gewichtung umgestellt wer-den. Beispiele:
/(a & b) | wie /ab oder /&ab
/(a | b) | wie /|ab
/(!a & !b) | wie /!ab
/(! (a | b)) | dito.
/(a | b & c) | ist /(a | (b & c))
%V.eq.val
%V.ne.val 		...der gegenwärtige Inhalt der Ordnungsvariablen %V ist gleich oder ungleich (Operator .ne.) wie der Wert val. Für eine Aufstellung aller möglichen Variablen siehe unten. Val muss dem Vergleichsoperator unmittelbar folgen. Enthält val Leerzeichen, kann er mit einfachen oder doppelten Anführungszeichen umschlossen werden, welche selbst als \' oder \" eingegeben werden können, um als Teil von val zu gelten. Ist die i-Option gesetzt, wird die Vergleichsoperation ohne Berücksichtigung der Gross- und Kleinschreibweise ausgeführt. Beispiele: Neujahrstag eines neuen Jahrzehnts:

%'d'd.eq.1 %'m'd.eq.1 %[1]'yy'd.eq.0 %1'yy'd.ne.0

Neujahrstag eines neuen Jahrhunderts:

%'d'd.eq.1 %'m'd.eq.1 %'yy'd.eq.00 %[1]1'yyyy'd.ne.0

Neujahrstag eines neuen Jahrtausends:

%'d'd.eq.1 %'m'd.eq.1 %[1]'yyyy'd.eq.000
{copy} ...die aktuelle Kopie im Bereich copy liegt. Bereiche werden wie folgt angegeben:
9 | Kopie vom Beginn des aktuellen Druckjobs gerechnet
-9 | Kopie vom Ende des Druckjobs gerechnet
9,99 | von-bis Kopie
$ | letzte Kopie
o | ungerade (odd) Kopienummern
e | gerade (even) Kopienummern

Beispiele:

{e} | alle geraden Kopien: 2,4,...
{2,$} | ab Kopie 2 (alle Kopien ausser der ersten)
{o -5,$} | die ungeraden Kopien der letzten sechs
{1,-1} | alle Kopien, ohne die erste und letzte
[page] ...die aktuelle Seite im Bereich page liegt. Seitenbereiche werden wie Copybereiche angegeben:
9 | Seite vom Anfang gerechnet
-9 | Seite vom Ende gerechnet
9,99 | von-bis Seite
$ | letzte Seite
o | ungerade (odd) Seitennummern
e | gerade (even) Seitennummern

Beispiele:

[e] | alle geraden Seiten: 2,4,...
[2,$] | ab Seite 2
[o -5,$] | die ungeraden Seiten der letzten sechs
[1,-1] | alle Seiten, ohne die erste und letzte
(line) ...die aktuelle Zeile im Bereich line liegt. Zeilenbereiche werden wie Seitenbereiche angegeben:
9 | Zeile vom Seitenanfang gerechnet
-9 | Zeile vom Seitenende gerechnet
9,99 | von-bis Zeile
$ | letzte Zeile
o | ungerade (odd) Zeilennummern
e | gerade (even) Zeilennummern

Beispiele:

(e) | alle geraden Zeilen: 2,4,...
(2,$) | ab Zeile 2 (alle Zeilen, ausser der ersten)
(o -5,$) | die ungeraden Zeilen der letzten sechs
(1,-1) | alle Zeilen, ohne die erste und letzte

Die folgende Tabelle gibt eine Übersicht der erlaubten Bedingungen:

 | bor | eor | bop | eop | bol | eol
form | ¤ | ¤ | ¤ | ¤ | ¤ | ¤
flag | ¤ | ¤ | ¤ | ¤ | ¤ | ¤
value | ¤ | ¤ | ¤ | ¤ | ¤ | ¤
copy | ¤ | ¤ | ¤ | ¤ | ¤ | ¤
page |  |  | ¤ | ¤ | ¤ | ¤
line |  |  |  |  | ¤ | ¤

Optionen:

Durch die Angabe von Optionen kann die Verarbeitung beeinflusst werden. Neben den allgemeinen Optionen, sind für die eol- und eop-Parameter spezielle Optionen verfügbar. Zur Verdeutlichung ihrer Funktionsweise verwenden wir die folgende Druckerdefinition:

1|Test (Page Printer):pg:\
:eol=<eol>:eop=<eop>:eor=<eor>

Die Druckdatei
Zeile1 linefeed
Zeile2 linefeed formfeed
generiert die Ausgabe
Zeile1 <eol> linefeed
Zeile2 <eol> <eop> linefeed formfeed <eor>

eol und eop l-Option: Diese Option verhindert die Ausgabe von Linefeeds (Hex 0x0A) bei allen Zeilen, für welche eine oder mehrere eol-Definitionen mit gesetzter l-Option als aktiv evaluiert wurden. Wird die l-Option bei der eop-Definition angegeben, wird das Linefeed Zeichen der letzten Zeile unterdrückt (dies ist gleich wie eol ($) -l). Selbstverständlich kann das Linefeed Zeichen innerhalb der eo x Sequenz explizit ausgegeben werden. eop f-Option: Diese Option verhindert die Ausgabe von Formfeeds (Hex 0x0C) auch wenn der Drucker als Page-Printer (pg-Parameter) definiert wurde. Dies ist hilfreich bei Modellen, die für den Seitenabschluss eine spezielle Kontrollsequenz verlangen (z.B. bei Einzelblatt Einzug). Auch bei der Entwicklung von PostScript Definitionen kann die f-Option verwendet werden. Die Unterdrückung von Formfeeds ist bei allen Seiten wirksam, für welche eine oder mehrere eop-Definitionen mit gesetzter f-Option als aktiv evaluiert wurden.

Beispiel:
:eop [1,-1] -f=... : # suppress formfeed:\
:eop [$]=...: # except last page:

Allgemeine Optionen:

Optionen ohne Argument können nach einem einzelnen ‘–’ Zeichen zusammengefasst werden. Argumente können unmittelbar nach dem Options-Zeichen oder nach einem Leerzeichen angegeben werden.

Option | Beschreibung
-i | Keine Berücksichtigung der Gross- und Kleinschreibweise bei Vergleichsoperationen von Ordnungsvariablen.
-p | Pipe Option: Der Standard-Output des Befehles der in value angegeben ist, ergibt den Wert des Eintrages. Der Befehlsname muss mit dem Zeichen ‘/’ beginnen und die angegebene Datei sollte das Execution Flag gesetzt haben. Hinweis: die p-Option ist in CssNT nicht verfügbar.
Die folgenden Optionen werden durchgeführt, wenn die Bedingung der Definition erfüllt ist und nachdem die Ausgabe von value abgeschlossen ist. Falls value eine Datei- oder Pipe-Operation definiert, werden die Optionen nur durchgeführt, falls die Datei existiert und ausführbar ist (Pipe). Um lediglich Flags zu setzen, sind leere value Definitionen erlaubt
-c cond | Clear, setzt die Flags cond auf false.
-s cond | Set, setzt die Flags cond auf true.
-t cond | Toggle, setzt die Flags cond von true auf false resp. von false auf true.
Hinweis! Um volle Flexibilität zu gewährleisten, gelten für die Verwendung der p-Option keine Einschränkungen. Es muss jedoch beachtet werden, dass gewisse Verwendungsarten das System erheblich belasten können. Es wäre z.B. unvernünftig, :bol -p=/usr/css/bol.sh: zu verwenden, wogegen die Definition :bol [$] ($) -p=/usr/css/bol.sh: für die letzte Zeile der letzten Seite im Dokument, durchaus sinnvoll sein kann.

Im Datenteil der bo x und eo x Definitionen stehen auch Ordnungsgrössen (spezielle Zeichensequenzen, welche durch einen zur Laufzeit ermittelten Wert substituiert werden) zur Verfügung. Beginnt ein Eintrag mit dem Zeichen '/' wird der Wert als absoluter Pfadname auf eine UNIX Datei interpretiert. Ist die entsprechende Datei vorhanden und allgemein lesbar (siehe chmod(1)), wird deren Inhalt auf den Drucker ausgegeben. Auch die Dateinamen könne mit Hilfe von Ordnungsgrössen zusammengesetzt werden. Alle definierten bo x- resp. eo x-Einträge werden in der Reihenfolge ihrer Definition verarbeitet. Sind Bedingungen spezifiziert, findet vorgängig eine Evaluation statt. Mit Hilfe von dynamischen Condition Flags können auch if, elseif, else Bedingung programmiert werden. Diese dienen speziell der Definition von mehreren Varianten mit einem Default:
:bor <a4h> -s H=\Ex: # if form = A4H:\
:bor <a4q> -s Q=\Ey: # elseif form = A4Q:\
:bor /!HQ=\Ez: # else all other forms:

Zum Ablauf eines Ausdruckes siehe auch fdu(U).
Vorsicht: Bei gewissen Druckerfabrikaten werden durch den Steuerbefehl "reset device" auch bereits empfangene, jedoch noch nicht ausgedruckte Daten gelöscht. Typische eor-Angaben sind '\r' (Carriage Return) und eventuell umstellen auf 10 Cpi.

Folgende Ordnungsgrössen werden unterstützt:

%a | Nummer der ersten gedruckte Seite, 1 bei vollständigem Ausdruck.
%c | Erstell-Datum der aktuellen Auswertung
%d | System-Datum (Datum des Ausdruckes)
%f | File-Name der beim lpr-Aufruf für die aktuelle Auswertung angegeben wurde. Falls die Eingabe via Pipe erfolgte, wird der Null-String oder der Wert des format-Parameters (siehe unten) ausgegeben.
%h | Auswertungstitel (lpr t-Option)
%i | Total Anzahl zu druckende Kopien
%k | Aktuelle Kopie Nummer
%l | Anzahl Zeilen pro Seite gemäss ps-Eintrag in css.forms resp. lpr P-Option
%m | Aktuelle Zeile innerhalb der Seite
%n | Total Anzahl Seiten der aktuellen Auswertung
%p | Aktuelle Seite
%r | Interne CSS Auswertungsnummer
%s | Erstell-Zeit der aktuellen Auswertung
%t | System-Zeit
%z | Nummer der letzten gedruckte Seite, identisch mit %n bei vollständigem Ausdruck.
%A | Generiert die auf den Zieldrucker übersetzten Steuersequenzen, welche via S-Option beim lpr(U) Aufruf angegeben wurden. S-Optionen, welche Escape-Definitionen mit einer e- oder s-Option enthalten, werden übersprungen und sind deshalb in %A nicht enthalten. Beispiel: :e40 -e=%A:
%C | Bedingungs-Flags (lpr C-Option) in der Reihenfolge a..zA..Z0..9
%D | Device-Nummer (lpr d-Option)
%E | Mitarbeiter-Kurzzeichen (lpr e- oder u-Option, resp. Login-Name)
%F | Formular-Typ (lpr f-Option)
%L | LANG(UAGE) Environment-Variable oder lpr L-Option
%N | Device-Name gemäss dn-Eintrag in css.devices resp. lpr d-Option
%O | lpr O-Option
%P | Programm-Name (lpr p-Option)
%S | Formular-Zusatz (lpr f-Option)
%T | Device-Typ gemäss dt-Eintrag in css.devices
%V | Device-File gemäss dv-Eintrag in css.devices
%Z | Generiert die auf den Zieldrucker übersetzten Steuersequenzen, welche via T-Option beim lpr(U) Aufruf angegeben wurden. T-Optionen, welche Escape-Definitionen mit einer e- oder s-Option enthalten, werden übersprungen und sind deshalb in %Z nicht enthalten. Beispiel: :e41 -e=%Z:

Die Syntax für Ordnungsgrössen ist:

%[flags][(field)][[offset]][max][.min]['format']name

flags es können die Werte - (Minuszeichen) für 'lower-case', + für 'uppercase', < für 'left justify' und '*' für 8-Bit binär angegeben werden. Dadurch werden alle Zeichen der Ordnungsgrösse in Klein- (-), oder Gross-Schreibweise (+) umgewandelt und falls das Resultatfeld durch min grösser als der Substitutionswert definiert wird, linksbündig (<) ausgegeben. Der Flag '*' bewirkt, dass numerische Werte 8-bit binär generiert werden. Dies ist speziell bei der Variablen %l (Anzahl Zeilen pro Seite) hilfreich. Z.B. ergibt bor=\EC%*l mit ps=66 die Ausgabe
0x1b (ESC) 0x43 ('C') 0x42 (66).
field Felder sind speziell beim Ordnungsbegriff %O (Herkunft lpr O-Option) sinnvoll. Sie bezeichnen einen durch das Trennzeichen ':' begrenzten Teilbereich des Optionswertes. Eine Felddefinition reduziert das Resultat des Ordnungsbegriffes auf das entsprechende Feld (ohne Trennzeichen):
Beispiel:

:op=/usr/css/outpipe -t %(0)O -n %(1)O -x %(2)[1]2O:

Der Aufruf lpr -O abc:12:defg erzeugt

/usr/css/outpipe -t abc -n 12 -x ef
offset | das Resultat wird um offset führende Zeichen reduziert.
max | maximale Anzahl Zeichen welche von der Ordnungsgrösse übernommen und für die Namensbildung verwendet werden.
min | minimale Grösse des Resultatfeldes in Anzahl Zeichen. Belegt der Wert der Ordnungsgrösse weniger Positionen, wird er rechtsbündig im Feld positioniert. Das Füllzeichen ist dabei Space (0x20). Beginnt der Wert min oder max mit der Ziffer Null '0', wird diese als Füllzeichen verwendet. Mit dem flag '<' kann eine linksbündige Ausgabe erreicht werden.
format Formatangabe zur Darstellung der Zeit- und Datum-Variablen %c, %d, %s und %t:
d, dd | Tag, d=1..9 einstellig, dd=zweistellig
m, mm | Monat (Datum), ein- resp. zweistellig
yy, yyyy | Jahr, zwei- resp. vierstellig
h, hh | Stunde, ein- resp. zweistellig
m, mm | Minuten (Zeit), ein- resp. zweistellig
s, ss | Sekunden, ein- resp. zweistellig

Beispiel: | 'mm/dd/yy' | Datum-Format USA
Default: | 'dd.mm.yy' 'hh:mm' | Datum Zeit
name | Name der Ordnungsgrösse (D, F, etc).

Der Eintrag bor=/usr/lib/css/mac/%+1L/%P wird z.B. umgesetzt in /usr/lib/css/mac/G/prog_xy (Annahme: LANG=german). Auch falls keine LaserJet Macros ausgegeben werden sollen, kann der Inhalt von bor- und eor-Dateien mit Hilfe des data-Befehles von fdu(U) generiert werden. Beispiel:

fdu -o /usr/css/if1 <<#eof#
data esc, '[', 12, 'X';
#eof#

Die Möglichkeiten der bedingten bo x und eo x Definitionen sind derart vielfältig, dass sie in diesem Dokument unmöglich erschöpfend behandelt werden können. In der Folge finden Sie einige typische Anwendungsbeispiele:

1. Ein Doppelschacht Laserdrucker wird speziell für Korrespondenz verwendet. Die erste Seite eines Briefes soll vom ersten, die Folgeseiten vom zweiten Schacht bezogen werden:

...
:bop <kor> [1]=\E&l1H: # select tray 1:\
:bop <kor> [2,$]=\E&l4H: # select tray 2:\
...

2. Ein zweiter Doppelschacht Drucker enthält im ersten Schacht A4 und im zweiten Schacht A5 Papier. Der Druck auf beide Papiersorten soll jeweils im Hoch- und Querformat ohne Formularwechsel möglich sein:
...
:map=a4h,a4q,a5h,a5q:\
:bor <a4h>=...: # setup A4H, tray 1:\
:bor <a4q>=...: # setup A4Q, tray 1:\
:bor <a5h>=...: # setup A5H, tray 2:\
:bor <a5q>=...: # setup A5Q, tray 2:\
...

3. Bei der Verwendung des Standartformulars A soll der Befehl lpr -C s file auf jeder Seiten die aktuelle Seitennummer (Text Seite x von y) gefolgt von einer Leerzeile ausgegeben werden. Damit der Seitenumbruch korrekt abläuft, müssen beim bor-Setup die zwei zusätzlichen Zeilen mit berücksichtigt werden.

Annahme: Formular A ps=64
...
:bor <a>/!s=..: # setup for 64 lines:\
:bor <a>/s=...: # setup for 64 + 2 lines:\
:bop <a>/s=Seite %p von %n \r\n\n:
...

4. Beim Druck von Einzahlungsscheinen soll die Codierzeile in OCR Schrift ausgegeben und zusätzlich die PTT Teilnehmer-Nummer angefügt werden: Variante 1 / das Programm gibt Zeilen mit variabler Länge aus:
...
:bol <vsr>(46)=\Eon: # start OCR font:\
:eol <vsr>(46)= 012000576>\Eoff:\
...

Variante 2 / das Programm gibt Zeilen mit fixer Länge aus, d.h. vor dem Druck der Teilnehmer-Nummer muss mit Backspace nach links positioniert werden:
...
:bol <vsr>(46)=\Eon: # start OCR font:\
:eol <vsr>(46)=\b\b\b\b\b\b\b\b\b\b:\
:eol <vsr>(46)=012000576>\Eoff:\
...

Mit dem if1-, if2-, tf1- und tf2-Eintrag können Namen von UNIX Dateien angegeben werden (absolute Pfadnamen). Sind die entsprechenden Dateien vorhanden und allgemein lesbar (siehe chmod(1)), wird deren Inhalt nach den bor-Sequenzen (if1- und if2-Datei) resp. vor den eor-Sequenzen (tf1- und tf2-Datei) auf den Drucker ausgegeben. Die Dateinamen könne mit Hilfe von Ordnungsgrössen, die zur Laufzeit dynamisch gebildet werden, zusammengesetzt werden. Da diese Eigenschaften mit bor resp. eor identisch definiert werden können, werden sie in zukünftigen CSS Versionen nicht mehr unterstützt. In dieser Version sind sie aus Kompatibilitätsgründen noch verfügbar.

Mit dem op-Eintrag kann der Name eines Prozesses (Programm, Shell-Script) angegeben werden, der von CSS gestartet wird und via Standard-Input die zu druckende Auswertung übermittelt erhält. Der Zugriffspfad ist absolut, d.h. vom Root-Directory '/' ausgehend, einzugeben. Auch muss sichergestellt sein, dass der Zugriff erlaubt und 'execute' Berechtigung gesetzt ist. Dem op Programm können Parameter übergeben werden. Vor dem Aufruf wird eine Evaluation von Ordnungsbegriffen durchgeführt. Der CSS Despooler sendet danach die Auswertung in den Standard-Output des angegebenen Programms. Die dadurch gegebenen Möglichkeiten erlauben es dem Systemintegrator Arbeiten wie das Öffnen von Netzwerkverbindungen, das Anwählen eines via Modem verbundenen Systems, das Umleiten der Auswertung in einen Prozess, das Nachführen von Accounting Informationen oder das Versenden von E-Mail an den Benutzer nach erfolgtem Ausdruck.

Beispiel:

/etc/css.devices:

:op=/usr/css/lp_filter %V %E '%h' %m %C:\
:dv=/dev/tty05:...

/usr/css/lp_filter:

: /bin/sh
device=$1
user=$2
title="$3"
pages=$4
cond=$5
# store accounting info
echo "$user $title $pages" >>/usr/css/acct
# write to device and store exit status
cat >$device
rc=$?
# inform user if the M flag has been set
case "$cond" in
*M*) mail -s CSS -r $user <<!!
Your report '$title' has been printed.
!!
esac
# and return exit status
exit $rc

Gibt der op Prozess eine Return-Code <> 0 zurück, verbleibt die Auswertung in der Warteschlange mit dem Status 'blockiert'. Der op Parameter ist in CssNT nicht verfügbar.

Mit dem wfc-Eintrag (write fail command) kann ein Befehl definiert werden, welcher ausgeführt wird, falls die Schreiboperation auf den Drucker für mehr als wft (write fail timeout) Sekunden scheitert. Der Zugriffspfad ist absolut, d.h. vom Root-Directory '/' ausgehend, einzugeben. Auch muss sichergestellt sein, dass der Zugriff erlaubt und 'execute' Berechtigung gesetzt ist.

Beispiel:

/etc/css.devices:

:wfc=/usr/css/printerFail %V %D %N %d %t %r '%h':\
:dv=/dev/tty05:...

/usr/css/printerFail:

: /bin/sh
deviceFile=$1
deviceNo=$2
deviceName=$3
date=$4
time=$5
reportNo=$6
title="$7"
# store logging info
echo "- $date, $time: $deviceNo $deviceFile" >>/usr/css/failLog
case "$deviceNo" in
1) routeDevice=2
2) routeDevice=1
esac
# route device
csu -o$deviceNo:$routeDevice 2>&1 >>/usr/css/failLog
# inform root
mail -s CSS -u root <<!!
Printout of report $reportNo '$title' has failed.
Device $deviceNo routed to device $routeDevice.
!!

Mit dem vd-Eintrag (view device) werden Druckerdefinitionen gekennzeichnet, welche dafür bestimmt sind, die Auswertungsdaten für die Vorschau von css(U) und WinCss(U) aufzubereiten. Drucker die vd gesetzt haben, sind für alle CSS Programme unsichtbar, können jedoch dem VIEW_DEVICE und WINCSS_VIEW_DEVICE Parameter in css.default zugewiesen werden. Solche Drucker können dazu verwendet werden, um fest programmierte Steuersequenzen mittels tr-Definitionen auszufiltern. Haben wir zum Beispiel ein Applikation geschrieben, welche Druckausgabe für ein ganz bestimmtes Druckermodell generiert, uns jedoch die Zeit fehlt, die Programme an das hypothetisch CSS Druckermodell anzupassen, ist die naheliegende Lösung, mittels tr-Definitionen die e1..e127 Eigenschaften zu ersetzten:

# print reports written for my-printer-model on brand x model y
1|Brand X / Model Y:dn=pr1:dv=/dev/lp:\
:tr=\EI1=\E(s1S: # italic on, use instead of e11=... :\
:tr=\EI0=\E(s0S: # italic off, use instead of e12=... :\
...

Um das italic Schriftattribut einzuschalten, gibt unser druckerabhängige Programm 'ESC I 1' (0x1b4931) aus. Die obige Druckerdefinition veranlasst CSS diese Steuersequenz während der Ausgabe in 'ESC ( s 1 S' (den HP Code um italic einzuschalten) zu übersetzen. Ohne eine Zeile Code zu ändern, wurde unser Programm druckerunabhängig (device independent). Ein Problem muss jedoch noch gelöst werden: die Aufbereitung der Auswertungsdaten zur Vorschau mittels css(U) und WinCss(U) verwendet ein sehr einfaches Druckermodell, welches keine Eigenschaften definiert hat und demzufolge alle 2-Byte Steuercodes des hypothetischen CSS Druckers stillschweigend ignoriert. Dieses Druckermodell ist nicht geeignet, die Ausgabe unserer Beispielapplikation korrekt aufzubereiten und die Vorschau wird seltsame Zeichen enthalten, die von den fest einprogrammierten Steuersequenzen herrühren. Wir benötigen ein Modell, welches alle Steuersequenzen eliminiert:

# view device for reports written for my-printer-model
901|View Device:vd:\
:tr=\EI1=: # italic on :\
:tr=\EI0=: # italic off :\
...

Die Verwendung des obigen Druckers ersetzt 'ESC I 1' und 'ESC I 0' durch Nichts (den Leerstring). Um die Verbindung eines vd Druckers (view device) zum css(U) Programm herzustellen, muss der VIEW_DEVICE Parameter in css.default auf die entsprechende Druckerdefinition gesetzt werden, z.B. VIEW_DEVICE=901.

Das WinCss Vorschaumodul erkennt folgende Formatierungscodes:

Code | CSS Notation | Formatierung
ESC b | \Eb | bold on
ESC B | \EB | bold off
ESC i | \Ei | italic on
ESC I | \EI | italic off
ESC u | \Eu | underline on
ESC U | \EU | underline off

Demzufolge kann der WinCss Vorschaudrucker wie folgt definiert werden:

# view device for reports written for my-printer-model
902|WinCss View Device:vd:\
:tr=\EI1=\Ei: # italic on :\
:tr=\EI0=\EI: # italic off :\
...

Um diesen Vorschaudrucker mit dem WinCss(U) Programm zu verbinden, kann der WINCSS_VIEW_DEVICE Parameter in css.default gesetzt werden, z.B. WINCSS_VIEW_DEVICE=902. Der Default von WINCSS_VIEW_DEVICE ist der Wert welcher in VIEW_DEVICE angegeben wurde, in welchem Falle keine Formatierungscodes verwendet werden sollten.

Formfeed / Linefeed

Mit dem ps-Eintrag wird die Anzahl Zeilen bei 6 LPI angegeben, welche zwischen zwei sich folgenden Formfeed's vorgeschoben werden. Bei Druckern, die beim Empfang des zweiten Formfeed's auf der Home-Position verbleiben, sollte kein ps-Eintrag (oder ps=1) gemacht werden, da sonst die Page-Parity Steuerung nicht korrekt arbeiten kann. ps=0 oder ps=1 bewirken, dass nie ein Formfeed gesendet wird, sondern jede Formularlänge mit Linefeed-Zeichen gesteuert wird. Bei allen anderen ps-Werten werden dann Formfeed-Zeichen verwendet, wenn die Formularlänge (siehe css.forms / ps-Eintrag) mit dem ps-Wert identisch ist.

Mit dem cr-Eintrag kann die Umsetzung von Linefeed-Zeichen in Carriage-Return / Linefeed Sequenzen bewirkt werden.

Drucker mit pg-Eintrag gelten als Seitendrucker, d.h. die letzte Seite einer Auswertung wird immer mit einem Formfeed-Zeichen abgeschlossen. Dieser Eintrag ist bei Laserdruckern in der Regel anzugeben.

Zeichen- übersetzung

Mit dem tr-Eintrag können Übersetzungen definiert werden. Nach dem ersten '=' Zeichen wird die 1- oder mehrstellige Eingabesequenz angegeben, nach dem zweiten '=' Zeichen die gewünschte 1- oder mehrstellige Übersetzung. Im Übersetzungsteil stehen wie bei bo x und eo x auch Ordnungsgrössen und Dateiausgabe zur Verfügung. Im Weiteren können auch bei tr-Definitionen Formular-, Flag-, Seiten- und Zeilen-Bedingungen sowie allgemeine Optionen angegeben werden (Syntax siehe bo x). Bei sich überschneidenden tr-Eingabesequenzen ist deren Länge bestimmend:

tr=1=A:tr=12=AB:

Die zweite tr-Sequenz wird nie übersetzt!

Mit Hilfe der dynamischen Condition Flags können Kontext sensitive Verarbeitungen definiert werden. Soll z.B. ein Condition Flag gesetzt werden, falls pattern im Dokument gefunden wird, kann folgende Definition verwendet werden:

:tr -s f=pattern=pattern:# retain pattern:\
:eop /f -c f=value...:# next eop, then clear flag:

Escape- übersetzung

Damit die vielfältigen Möglichkeiten moderner Drucker ausgenützt werden können, ohne dabei eine Abhängigkeit von bestimmten Fabrikaten zu bewirken, werden die Zeichensequenzen ESC,1 bis ESC,127 (Hex 1B01 bis 1B7F) durch die mittels e1- bis e127-Einträge definierten Steuerzeichen ersetzt. Bei e5=^N: bewirkt z.B. eine Programmausgabe von ESC,5 die CSS Ausgabe des Control-N Zeichens. Es ist sinnvoll, eine Standartbelegung der ESC-Sequenzen (für die Programmsicht) vorzunehmen. Die Bedeutung von e1 bis e4 ist von CSS bereits definiert und vorgeschrieben:

e1 | Umschaltung auf 10 cpi
e2 | Umschaltung auf 12 cpi
e3 | Umschaltung auf 16.5 cpi
e4 | Umschaltung auf mehr als 16.5 cpi

Ist keinerlei Umschaltung der Schreibdichte möglich so werden e1 bis e4 nicht definiert. Sind bestimmte Umschaltungen nicht möglich, so ist die Steuersequenz der nächst höheren Schreibdichte anzugeben. Ist keine Umschaltung auf eine höhere Schreibdichte möglich, so ist die Steuersequenz der höchst möglichen Schreibdichte anzugeben. Bei der automatischen Bestimmung der Schreibdichte (siehe lpr(U) a-Option und css(P) lpr-Parameter) erfolgt die Berechnung abhängig der Zeilenlänge (siehe css.forms / ll-Eintrag) des aktuellen Formulars. CSS verwendet immer die kleinst mögliche Schreibdichte, d.h. die grösst möglichen Zeichen.

Die Syntax der e nn Definitionen ist:

name [-option...]=value

Optionen ohne Argument können nach einem einzelnen ‘–’ Zeichen zusammengefasst werden. Argumente können unmittelbar nach dem Options-Zeichen oder nach einem Leerzeichen angegeben werden.

Option | Beschreibung
-e | Expand Option: Der value Wert der Definition wird in derselben Art wie die bo x und eo x Definitionen verarbeitet, d.h. die %-Variablen werden aufgelöst und/oder Datei Input ist möglich.
-p | Pipe Option: Der Standard-Output des Befehles der in value angegeben ist, ergibt den Wert des Eintrages. Der Befehlsname muss mit dem Zeichen ‘/’ beginnen und die angegebene Datei sollte das Execution Flag gesetzt haben. Diese Option impliziert die e-Option. Hinweis: die p-Option ist in CssNT nicht verfügbar.
Die folgenden Optionen werden durchgeführt, wenn die Bedingung der Definition erfüllt ist und nachdem die Ausgabe von value abgeschlossen ist. Falls value eine Datei- oder Pipe-Operation definiert, werden die Optionen nur durchgeführt, falls die Datei existiert und ausführbar ist (Pipe). Um lediglich Flags zu setzen, sind leere value Definitionen erlaubt
-c cond | Clear, setzt die Flags cond auf false.
-s cond | Set, setzt die Flags cond auf true.
-t cond | Toggle, setzt die Flags cond von true auf false resp. von false auf true.

Zusammenfassung

Da der hypothetische CSS Drucker Steuersequenzen für Druckereigenschaften erlaubt, die nicht auf jedem physischen Drucker verfügbar sind, werden während der Ausgabe alle beim angesteuerten Drucker nicht definierten Escape-Sequenzen zwischen ESC,1 und ESC,127 (e1..e127) ausgefiltert. Dieser Effekt ist bei Druckern, die z.B. von Textverarbeitungs-Software angesteuert werden, nicht erwünscht. Der bm-Eintrag (binary mode) bewirkt, dass von CSS alle nicht definierten Steuersequenzen transparent an den entsprechenden Drucker weitergeleitet werden. Im weiteren wird im 'binary mode' die lpr(U) a-Option ignoriert und der automatische Abschluss der letzten Seite (pg-Eintrag) nicht durchgeführt.

Wichtiger Hinweis!

Im normalen Betrieb eines hypothetischen CSS Druckers, ignoriert der Despooler nicht definierte Escape Sequenzen. Wenn z.B. das lpd Programm in der Auswertung die Sequenz ESC,9 (hex 0x1b 0x09) erkennt und kein entsprechender e9 Eintrag für den Zieldrucker vorhanden ist, wird die aus zwei Zeichen bestehende Steuersequenz ignoriert und nicht an den Drucker weitergeleitet. Ist ein transparenter Ausdruck erwünscht, müssen 'binary' Auswertungen verwendet werden.

Remote Printing

Die Definition der rpm Eigenschaft veranlasst CSS den dv und op Parameter zu ignorieren und sich mittels TCP/IP Socket mit einem Netzwerkdrucker zu verbinden. Die möglichen Werte für rpm sind:
Wert | Protokoll | Beschreibung
lpd | BSD lpd | Dies ist das meist verbreitete Protokoll für die Steuerung von im Netzwerk verteilten Druckern. Praktisch alle Druckerserver unterstützen lpd.
rlpd | relaxed lpd | Relaxed lpd ist eine Unitec Variante von BSD lpd. Speziell bei grossen Auswertungen arbeitet es effizienter als das standad Pendant, wird aber nicht von jeder Druckerbox unterstützt. Wenn immer möglich, sollte zuerst dieses Protokoll versucht werden, bevor BSD lpd eingesetzt wird. Ist das Protokoll mit der eingesetzten Hardware nicht kompatibel, erfolgt keine Ausgabe oder Auswertungen werden nicht vollständig gedruckt.
rtel | reverse telnet | Rtel wird von diversen Druckerboxen unterstützt, existiert jedoch in verschiedenen Varianten. Die CSS Implementation von rtel wurde mit dem Lantronix MPS Druckerserver getestet.
pros | Axis Pros | Pros kann mit der Hardware von Axis Communications verwendet werden.
raw | raw TCP/IP | Einige Druckerserver erlauben es, mittels spezieller Port Nummer direkt auf die Getäteschnittstelle zuzugreifen. Mit dem raw Protokoll können solche Ports angesteuert werden.

Der rph Eintrag spezifiziert die Hostadresse des Druckerservers und ist für alle Protokolle erforderlich. Die Adresse kann in der numerischen Standartnotation (z.B. "128.41.1.11") oder als symbolischer Aliasname aus der TCP/IP hosts Datei angegeben werden. Bei Unix Systemen ist hosts im Directory /etc gespeichert. Bei Windows Systemen variiert der Pfad je nach Betriebssystem und Version. Jede Zeile in hosts enthält die numerische IP Adresse sowie einen oder mehrere symbolische Aliasnamen.

Die rpp Eigenschaft spezifiziert die TCP/IP Portnummer, welche für die Verbindung zum mittels rph Eintrag definierten Host verwendet wird. Der Wert kann numerisch (z.B. "515") oder als symbolischer Aliasname aus der TCP/IP services Datei angegeben werden. Bei Unix Systemen ist services im Directory /etc gespeichert. Bei Windows Systemen variiert der Pfad je nach Betriebssystem und Version. Jede Zeile in services enthält einen Service Namen, eine Portnummer und den Porttyp (meistens tcp). Portnummern sind in der Regel vom Druckerserver Hersteller oder durch das verwendete Protokoll vorgegeben. Es macht deshalb wenig Sinn, symbolische Werte zu verwenden. Ausser für das raw Protokoll, sind die gebräuchlichen Portnummern als Default vordefiniert.

Die rpq Eigenschft spezifiziert den Namen der anzusteuernden sog. Queue des Druckservers. Im Server Handbuch kann der einzugebende Wert ev. auch unter der Bezeichnung 'remote port', 'remote service name' oder 'remote printer name' ermittelt werden. Sind mehrere Queues vorgegebenen, sollte diejenige ausgewählt werden, welche keinerlei Zusatzverarbeitung an den Druckdaten durchführt. Wird z.B. am Ende jeder Auswertung eine leere Seite ausgedruckt, haben Sie vielleicht eine Queue gewählt, die jedem Dokument automatisch ein Formfeed Zeichen anfügt. Der rpq Parameter ist für alle Protokolle ausser raw vorgeschrieben.

Die rpr Eigenschaft definiert die Portnummer im Druckserver. Sie wird im rtel Protokoll zum Server übermittelt, ist jedoch fakultativ. Sie kann auch im pros Protokoll als Alternative zum rpq Parameter verwendet werden um die Druckernummer der Axis Box festzulegen (z.B. ist rpr=2 identisch mit rpq=pr2).

Die rpw Eigenschaft definiert das Passwort, welches den Zugriff zum Druckerserver erlaubt. Es wird nur im pros und im rtel (fakultativ) Protokoll verwendet. Das Default Passwort für pros ist 'netprinter',

Die Remote Print Definition für ein Lantronix MPS Server (z.B. mit der Bezeichnung MPS_0d242f) könnte wie folgt angegeben werden:

:rpm=rlpd:rph=128.41.1.11:rpq=MPS_0d242f_TEXT:...

Und für eine Axis Box:

:rpm=pros:rph=128.41.1.12:rpq=pr1:...

Oder äquivalent:

:rpm=pros:rph=128.41.1.12:rpr=1:...

Hinweis:

Die implementierten Protokolle wurden mit einigen weit verbreiteten Druckerboxen ausgetestet. Unitec ist nicht in der Lage, ausser für lpd, relaxed lpd, pros und raw, für diese und zukünftige Protokolle, Support zu gewähren.

Hinweise

Obwohl die Belegung der Escape-Sequenzen e5..e127 frei ist, schlagen wir aus Kompatibilitäts-Gründen (u.a. mit ulp(U)) folgenden Standart vor:

e5 | Drucker auf Korrespondenz-Qualität setzen
e6 | Korrespondenz-Qualität ausschalten
e7 | Drucker auf 'Near-letter'-Qualität setzen
e8 | 'Near-letter'-Qualität ausschalten
e9 | Breitschrift einschalten (elongated)
e10 | Breitschrift ausschalten
e11 | Drucker auf Schrift 'italic' (oder andere Zweitschrift) setzen
e12 | auf Normalschrift zurückschalten
e13 | Unterstreichen einschalten
e14 | Unterstreichen ausschalten
e15 | Halbzeile rückwärts (superscript)
e16 | Halbzeile vorwärts (reset superscript)
e17 | Halbzeile vorwärts (subscript)
e18 | Halbzeile rückwärts (reset subscript)
e19 | Zweit-Zeichensatz laden
e20 | Erst-Zeichensatz zurückladen
e21..e127 | freie Verwendung für Spezialanwendungen.

Für die Halbzeilen-Sprünge sind deshalb vier Einträge vorgesehen, da es Druckermodelle gibt, welche für e15/e18 und e16/e17 unterschiedliche Steuerzeichen verlangen.

Sind Druckereigenschaften beim beschriebenen Modell nicht möglich, wird der entsprechende Eintrag weggelassen.

Files

Css: |
/usr/lib/css/dev | (Device Database)
CssNT: |
lib\dev | (Device Database)

Siehe auch

csa(U), css(P), css.forms, lpr(U), setmode(U)


Css.Forms

Form Definition Data Base

css.forms(C)
Name Plattform Beschreibung Eigenschaften Typen Files Siehe auch

Name

css.forms

Plattform

Unix, Windows NT

Beschreibung

Css.forms beschreibt die vom CSS Spooling System verwendeten Formulare. Die Formulare werden durch die Beschreibung ihrer Ausmasse definiert.

Die Definitionen in css.forms setzen sich aus einer Anzahl von durch ':' getrennten Einträgen zusammen (analog termcap(5)). Der erste Eintrag jeder Formulardefinition bestimmt die Formularklasse (max. 3 Zeichen, mit einem Buchstaben beginnend) und nach dem Trennzeichen '|' eine bis zu 30 Stellen lange Formular Bezeichnung (Leerzeichen sind erlaubt). Sind mehrere Definitionen mit gleicher Formularklasse vorhanden, so gilt die letzte Definition.

Im Gegensatz zu termcap(5) dienen die Definitionen in css.forms nicht als Referenz-Datei. Sie werden vielmehr mittels csa(U) in eine effizienter organisierte Datei (/usr/lib/css/form, resp. lib\form unter Windows NT) umgewandelt. Folglich werden Änderungen in css.forms erst nach erfolgter Umwandlung aktiv.

Eigenschaften

Name | Typ | Beschreibung | Default
bp | bool | Deckblatt (Banner-Page) | false
ilf | bool | Leerseiten-Unterdrückung | false
ld | num | logischer CSS-Device | 0
ll | num | Line-Length bei 10 CPI |
nbp | num | Anzahl Deckblätter | 1, 2 (pp)
pp | bool | Page-Parity | false
ps | num | Page-Size bei 6 LPI |
# | str | Kommentar |

Definitionen können sich über mehrere Zeilen erstrecken. Das letzte Zeichen einer Zeile muss dabei ein '\' (Backslash) sein. Zur Verbesserung der Lesbarkeit sind leere Einträge erlaubt.

Typen

Jeder Eintrag hat einen Zwei-Zeichen-Namen. Zum Beispiel wird die Tatsache, dass Page-Parity angewandt werden soll, mit dem Eintrag pp gesteuert. Bei numerischen und bei String Eintragungen ist der Name gefolgt vom Zeichen '=' und dem entsprechenden Wert. Numerische Werte werden dezimal angegeben.

Soll ein Formular nur auf einem bestimmten CSS Device (Drucker) ausgegeben werden, so wird dies mit dem ld-Eintrag spezifiziert. Dabei bedeutet '0': es sind alle CSS Devices als Ausgabegerät erlaubt. Eine typische Anwendung dieser Funktion ist bei Formularen mit optisch lesbaren Zeichen gegeben; diese Formulare können nur durch bestimmte Drucker (Typenrad) bedruckt werden.

Die physische Seitenlänge eines Formulars wird mit dem ps-Eintrag definiert. Die Länge wird in Anzahl Zeilen (bei 6 Zeilen pro Inch) angegeben.

Die physische Zeilenlänge wird mit dem ll-Eintrag definiert. Die Länge wird in Anzahl Zeichen (bei 10 Zeichen pro Inch) angegeben.

Die Angabe des pp-Eintrages bewirkt, dass jede Auswertung auf eine durch zwei teilbare Anzahl Seiten ergänzt wird.

Um führende Leerseiten eines Dokumentes zu unterdrücken, kann der ilf-Eintrag (ignore leading formfeeds) gesetzt werden. Damit kann z.B. in Cobol auch der Titel der ersten Seite mit dem Vorschub AFTER PAGE ausgegeben werden, ohne eine leere Seite zu generieren.

Der Ausdruck eines oder mehrerer Deckblätter (Banner-Page), wird durch den bp-Eintrag gesteuert. Deckblätter werden jedoch nur generiert, falls in der Definition des verwendeten Druckers der gleichnamige Eintrag ebenfalls gesetzt ist. Mit dem nbp-Eintrag kann die Anzahl der zu druckenden Deckblätter bestimmt werden. Der Default-Wert ist eine, falls der pp-Eintrag gesetzt ist jedoch zwei Seiten.

Files

Css: |
/usr/lib/css/form | (Forms Database)
CssNT: |
lib\form | (Forms Database)

Siehe auch

csa(U), css(P), css.device, lpr(U)


Ulm.Default

ULM Environment

ulm.default(C)
Name Plattform Beschreibung Parameter Hinweise Siehe auch

Name

ulm.default

Plattform

Unix, Windows NT

Beschreibung

Ulm.default enthält die Definition von systemweit gültigen ULM Lizenz Manager Parametern. Jedes ULM Programm liest diese Datei beim Aufstarten. Sie enthält eine oder mehrere Zeilen, welche Default Informationen enthalten. Das allgemeine Format von Parameter-Zeilen ist:

NAME=Value

wobei NAME den Typ und value den Wert der Information bezeichnet. NAME und value müssen aus Buchstaben, Zahlen und Interpunktionszeichen zusammengesetzt sein. Beim Parameter-Namen wird, im Gegensatz zum Parameter-Wert, zwischen Gross- und Kleinschreibweise nicht unterschieden. Die genaue Schreibweise von NAME und der entsprechende Wert value sind in der folgenden Tabelle beschrieben.

Alle Zeilen, welche mit dem Zeichen '#' beginnen, gelten als Kommentar und werden ignoriert.

Parameter

Name | Beschreibung | Default
ULM_VERSION | Version des installierten Lizenz Managers. Dieser Eintrag wird von setup(I) generiert und sollte nie geändert werden. |
ULM_BASE_DIR | Basis-Directory mit allen ULM Programmen und Steuerdateien Der gewünschte Pfad kann beim Setup Programm angegeben werden. | /usr/lib/ulm CssNT: ulm

Hinweise

Ist /etc/ulm.default auf dem System nicht vorhanden, arbeitet ULM mit der Default-Konfiguration.
Wichtig!

Stimmen die Directory-Beschreibungen (x_dir) nicht mit den tatsächlichen Gegebenheiten überein, kann ULM nicht korrekt arbeiten!

Siehe auch

setup(I), ulm(I)


WinCss

Windows Interface

WinCss(C)
Name Plattform Beschreibung Hinweise Siehe auch

Name

WinCss

Plattform

Win32 (Windows 95/98, Windows NT)

Beschreibung

Die Installation von WinCss folgt den unter Windows üblichen Standards. Beim ersten Programmstart verlangt WinCss die Eingabe der IP Adresse des CSS Print Servers und schlägt die TCP/IP Portnummer 6801 als Default vor. Wird diese Portnummer in Ihrem Netzwerk schon für andere Zwecke verwendet, muss ein anderer, von Ihrem Netzwerk Administrator festgelgter Wert, eingegeben werden. Zusätzlich müssen in diesem sehr unwahrscheinlichen Falle auf dem Server manuelle Konfigurationen durchgeführt werden.

Die folgenden Abschnitte beschreiben das dazu notwendige Vorgehen:

1. TCP/IP Ports und Services

Beim Aufbau einer TCP/IP Client-Server Verbindung muss dem Client (WinCss) die Rechneradresse (IP Adresse) des Rechners, welcher die Serverdienste anbietet bekannt sein. Zusätzlich wird jeder Verbindungstyp (z.B. cssws zu WinCss) durch eine eindeutige Portnummer identifiziert. Das TCP/IP services File definiert symbolische Bezeichnungen für die meisten in einem Netzwerk verwendeten Ports. Bei der Verwendung dieser Service-Namen muss die services Datei auf jedem Knoten, d.h. auf dem Host- und auf allen Client-Systemen, vorhanden sein. Bei Unix Systemen ist services im Directory /etc gespeichert. Bei Windows Systemen variiert das Directory je Betriebsssytem. Jede Zeile in der services Datei enthält den Service Namen, eine Portnummer und einen Porttyp (CSS verwendet immer den Typ tcp). Um Konflikte mit standart TCP/IP Ports zu vermeiden, sollten Portnummern > 5000 verwendet werden. Unitec Produkte verwenden Portnummern im Bereich von 6800 bis 6999.

Da die Verwaltung von services Datein in heterogenen Netzwerken mit einem erheblichen administrativen Aufwand verbunden ist, ist man in letzter Zeit vermehrt dazu übergegangen, für jeden Verbindungstyp Portnummern festzulegen (sog. well known ports). Für die WinCss Verbindung wurde Port 6801 als Default definiert. Um Konflikte mit Software von anderen Herstellern zu vermeiden, kann beim Setup von WinCss eine andere Portnummer angegeben werden. Dieser Wert wird in der Windows Registry unter dem Schlüssel

HKEY_LOCAL_MACHINE\SOFTWARE\Unitec\WinCss\CurrentVersion

im Bezeichner CssPort abgelegt.

Für alle CSS Server (Unix und Windows NT) ist die Portnummer in der Konfigurationsdatei css.default im Parameter WINCSS_PORT definiert.

Die Programme cssws und WinCss erlauben zusätzlich die TCP/IP Konfiguration auf der Befehlszeile anzugeben. Beispiel:

cssws -p 7001 | der Unix WinCss Server soll die Portnummer 7001 verwenden
WinCss -h 128.41.1.1 -p 7001 | der WinCss Client verbindet sich mit dem CSS Server auf dem Host mit der IP Adresse 128.41.1.1 unter Verwendung der Portnummer 7001

2. CSS Server Konfiguration (Unix)

Beim Systemstart muss - wie jeder andere Server Prozess auch - das Programm /usr/lib/css/cssws aufgerufen werden. Dazu stehen verschiedene System Dienste, wie z.B. /etc/rc(4) oder /etc/inittab(4), zur Verfügung:

/etc/rc

/usr/lib/css/cssws 2>/dev/null 1>&2

Nur Unix System V

Dieselbe Verarbeitung kann unter System V durch folgenden Eintrag in /etc/inittab(4) erreicht werden:

cssws:1:respawn:/usr/lib/css/cssws 2>/dev/null 1>&2

Internet Super Server (inetd)

Da der Internet Superserver inetd(1) symbolische Service Namen erwartet, muss in der Datei /etc/services folgende Zeile eingefügt werden:

cssws 6801/tcp # WinCss server

Danach fügen Sie folgende Zeilen in der Datei /etc/inetd.conf ein:

# CSS Service
cssws stream tcp nowait root /usr/lib/css/cssws -i

Der inetd(1) Prozess liest beim Aufstarten die Datei /etc/inetd.conf, um sich selbst zu initialisieren. Dies macht die Dienste des cssws(U) Servers für Verbindungen des Windows Programmes WinCss.exe verfügbar.

Wird cssws nicht vom init(1) Programm gestartet, setzt sich der Prozess automatisch in den Hintergrund (detach).

3. CssNT Server Konfiguration (Windows NT)

Die WinCss Server Dienste werden vom Programm CssNTSrv zur Verfügung gestellt. Dieses Programm wird von Setup als NT Service installiert und startet beim Systemboot automatisch.

4. CSS Client Konfiguration (Win32)

Das Windows CSS Programm kann in zwei unterschiedlichen Arten betrieben werden. Beim Standartbetrieb wird das Window Warteschlange zur Hauptsteuerung verwendet. Mit der Option -m oder /m kann dazu auch die im Windows Help File beschriebene Mini-Toolbar verwendet werden. Die Option kann nach der Installation in den Properties des Programmes WinCss.exe im WinCss Folder als Default definiert werden. Zusätzlich kann mit der Option -h oder /h die IP Adresse des Servers und mit -p oder /p die TCP/IP Portnummer angegeben werden. Damit ist es möglich, von einem Client auf mehrere Server gleichzeitig zuzugreifen.

CssNT Server verwenden zur Überprüfung der Zugriffsberechtigung das NT Security Modell.

Beim Zugriff auf Unix CSS Server muss die WinCss Software den Unix User Namen oder die User ID (UID) kennen. Bei 32 Bit Systemen wird diese Information mit Hilfe der GetUserName API Funktion und bei 16 Bit Systemen von der Umgebungs-Variablen USER gelesen. Soll eine andere Variable verwendet werden (z.B. UNIXUSER), muss dies in der Windows Registry (Windows 95 und NT), resp. in der Datei css.ini (Windows 3.1x) angegeben werden:

HKEY_LOCAL_MACHINE\SOFTWARE\Unitec\WinCss\CurrentVersion\UserEnv

resp.

...
[Environment]
UserEnv=UNIXUSER
...

Die Unix User Information kann auch von einer anderen .ini Datei gelesen werden. Die folgende css.ini Definition veranlasst WinCss.exe, die Information aus dem Eintrag USERNAME in der Sektion Network der Datei system.ini zu lesen:

...
[Environment]
UserIniFile=system.ini
UserIniSection=Network
UserIniKeyWord=USERNAME
...

Kann WinCss nach den oben beschriebenen Regeln keine User Informationen erhalten, wird die Verbingung unter der Berechtigung von guest aufgebaut.

Wird im Zieldirectory einer File Server Installation manuell eine css.ini Datei erstellt, werden die darin enthaltenen Definitionen bei jeder nachfolgenden Workstation Installation automatisch in die Registry resp. in die Datei css.ini im Windows Directory (Win 3.1x) übernommen. Der Registry Key aller WinCss Parameter ist

HKEY_LOCAL_MACHINE\SOFTWARE\Unitec\WinCss\CurrentVersion

Starten von WinCss / Fehlerbehebung

Es muss sichergestellt werden, dass alle oben beschriebenen Schritte durchgeführt wurden und das Programm setup.exe ohne Fehler abgelaufen ist. WinCss ist nun für den ersten Einsatz bereit. Treten beim Aufstarten Fehler auf, überprüfen Sie bitte nochmals Ihre TCP/IP Eingaben. Nachdem die notwendigen Änderungen gemacht wurden, muss der Unitec Communication Manager Ucm.exe gestoppt werden. Dieser Prozess wird auf dem Windows System automatisch gestartet und läuft unsichtbar im Hintergrund. Um das Programm zu stoppen, geben Sie Ctrl-Alt-U ein um das UCM Icon auf der Windows Taskbar sichtbar zu machen. Durch Betätigung der rechten Maustaste wird ein Popup-Menü sichtbar auf welchem Sie die Aktion Close auswählen sollten. Wird eine Warnung ausgegeben bestätigen Sie diese mit dem Close Schalter. WinCss kann nun neu gestartet werden.

Das Hilfsprogramm CssVerCk.exe kann verwendet werden um Versionskonflikte mit den installierten Windows Komponenten zu erkennen.

5. Automatisieren der WinCss Installation

Das Installationsprogramm (z.B. WinCss400.exe) erkennt folgende Optionen:
/S Silent mode, automatische Installation ohne Benutzerinteraktion. Alle Aktionen und Installationsfehler werden in der Datei INSTALL.LOG im Zielverzeichnis protokolliert.
/M=filename Spezifiziert eine Textdatei mit Parameterwerten. Jede Variable belegt eine Zeile im NAME="VALUE" Format. Die Hochkommas sind nur notwendig, falls der Wert Leerzeichen enthält. Der NAME kann in Gross- oder Kleinschreibweise angegeben werden. Folgende Parameter werden erkannt:
Name | Wert
CssHost | Spezifiziert die IP Adresse oder den Hostnamen des CSS Servers. Bereits in der Registry gespeicherte Werte werden nicht überschrieben, d.h. der Parameter hat keine Wirkung bei Upgrade Installationen.
CssPort | Spezifiziert die Portnummer oder den Servicenamen welcher für die Verbindung zum CSS Server verwendet wird. Bereits in der Registry gespeicherte Werte werden nicht überschrieben. Der Vorgabewert für die Portnummer ist 6801.

Hinweise

Die WinCss Software muss mit dem ulm(I) Programm registriert und serialisiert werden.

Siehe auch

init(1), setup(I), ulm(I)


Virtual Server Konfiguration

Virtual CSS Server

VirtualServer(C)
Name Plattform Beschreibung Hinweise

Name

Virtual CSS Server

Plattform

Unix

Beschreibung

CSS kann auf einem System mehrere unabhängige Druckserver zur Verfügung stellen. Um in einer solchen Serverumgebung zu arbeiten, muss die CSS_ENV Umgebungsvariable auf den Verzeichnisbaumpfad des virtuellen CSS Servers gesetzt werden. Ein CSS_ENV Wert von "/" veranlasst die CSS Programme die Standart-, resp. Hauptumgebung zu verwenden.

Setzen von CSS_ENV

• Bourne Shell sh(1), Bourne Again Shell bash(1)

.profile (sh) .bashrc (bash) | CSS_ENV=/usr/css1 export CSS_ENV
Shell Prompt | CSS_ENV=/usr/css1 export CSS_ENV
temporär | CSS_ENV=/usr/css1 command [option...]

• C-Shell csh(1)

.login | setenv CSS_ENV /usr/css1
Shell Prompt | setenv CSS_ENV /usr/css1
temporär | NA

Verzeichnisstruktur von virtuellen CSS Servern

Der Verzeichnisbaum jedes virtuellen Servers muss die folgenden Unterverzeichnisse enthalten:

Verzeichnis | Inhalt
etc
Datei | Inhalt | Optional
css.default | Konfigurationsparameter |
css.devices | Druckerdefinitionen |
css.forms | Formulardefinitionene |
css.banner | Meldung des Tages für Bannerseiten | ja
lib | Interne CSS Steuerdateien wie kompilierte Drucker- und Formularbeschreibungen, die Warteschlange und weitere.
spool | Optionales Verzeichnis für die Zwischenspeicherung von Auswertungsdateien. Kann mittels CSS_SPOOL_DIR Parameter in $CSS_ENV/etc/css.default übersteuert werden.

Eine typische Setup Sitzung:

# if not registered yet, enter virtual server license (type CVS)
CSS_ENV=/  /etc/ulm
# setup directory structure:
umask 0
mkdir /usr/css2
cd /usr/css2
mkdir etc lib
# register user activation keys (type CSS and WinCss)
CSS_ENV=/usr/css2  /etc/ulm
# copy and modify CSS configuration files
cp /etc/css.*  ./etc
vi ./etc/css.*
# compile device and form definitions, initialize report queue
CSS_ENV=/usr/css2  /etc/csa -d -f -R

Device Sharing

Um Drucker zwischen mehreren virtuellen CSS Umgebungen zu teilen, muss das 'external lock' Feature von css.devices (el-Eigenschaft) verwendet werden. Es ist zwingend vorgeschrieben, dass alle logischen Drucker, die denselben physischen Drucker verwenden, identische el-Eigenschaftswerte gesetzt haben. Drucker, welche von einem anderen virtuellen Server oder Softwareprodukt verwendet werden, zeigen im css(U) Interfaceprogramm den Status besetzt.

Konfigurationsparameter welche spezielle Beachtung benötigen

Wird der CSS_SPOOL_DIR unterschiedlicher CSS Umgebungen auf denselben Pfad gesetzt, resultiert Datenverlust.

Der WINCSS_PORT Konfigurationsparameter sollte für jede virtuelle CSS Umgebung auf unterschiedliche Portnummern gesetzt werden. Als Alternative kann die p-Option von cssws(U) verwendet werden. Beim Systemstart muss für jede virtuelle Umgebung ein cssws(U) Windows Server gestartet werden.

/etc/rc Beispiel:

• WINCSS_PORT in jeder css.default Datei gesetzt

...
CSS_ENV=/ /usr/lib/css/cssws
CSS_ENV=/usr/css2 /usr/lib/css/cssws
...

• WINCSS_PORT nicht gesetzt

...
CSS_ENV=/ /usr/lib/css/cssws -p 6851
CSS_ENV=/usr/css2 /usr/lib/css/cssws -p 6852
...

Hinweise

Jeder virtuelle Server benötigt eine separate Lizenz. Der Unitec Produktcode ist CVS. FreeCSS kann nicht im virtuellen Modus betrieben werden.


Virtual Server Css.Default

Virtual CSS Environment

css.default(C)
Name Plattform Beschreibung Parameter Hinweise

Name

$CSS_ENV/etc/css.default

Plattform

Unix

Beschreibung

Css.default für virtuelle CSS Server enthält die Definition von Parametern welche Defaultwerte der virtuelle Umgebung festlegen. Viele Parameter erben, falls nicht angegeben, den in der globalen css.default Datei angegebenen Wert. Jeder innerhalb der virtuellen Umgebung ausgeführte CSS Befehl konsultiert diese Datei beim Programmstart.

Css.default für virtuelle Server enthält eine oder mehrere Zeilen, welche Defaultinformation enthalten. Das Format der Parameterzeilen ist:

Name=Value

wobei Name den Informationstyp und Value dessen Wert bezeichnet. Die genaue Schreibweise von Name und die dazugehörenden Werte Value sind in der folgenden Tabelle beschrieben.

Zeilen, welche mit dem Zeichen '#' beginnen, gelten als Kommentar.

Beim Parametername wird, im Gegensatz zum Parameterwert, zwischen Gross- und Kleinschreibweise nicht unterschieden.

Parameter

In der aktuellen CSS Version sind folgende Konfigurationsmöglichkeiten gegeben:

Name | Beschreibung | Default-Wert
AUTO_REORG Automatische Reorganisation der Warteschlange beim ersten Aufruf von css(U) je Kalendertag (löschen der Auswertungen, deren Keep-Datum abgelaufen ist):

no: | keine Reorg
all: | alle abgelaufenen
printed: | alle abgelaufenen und vollständig ausgedruckten

Siehe auch csa(U), k- und K-Option.

Wert von /etc/css.default

BANNER_MARGIN | Normalerweise bedrucken Banner Seiten die erste bis zur letzten Zeile der Seite. Bei ungenau eingestellten Formularen kann dies dazu führen, dass auch Seiten der Auswertung teilweise mit Banner Zeilen bedruckt werden. Um dies zu vermeiden, kann der BANNER_MARGIN Parameter dazu verwendet werden, einen oberen und unteren Rand der Banner Seite zu definieren. | Wert von /etc/css.default
BINARY_VIEW | Anzeige von binären Auswertungen im css(U) Dialog: true oder false. Wir empfehlen diese Option für Endanwender auszuschalten. | Wert von /etc/css.default
CSS_SPOOL_DIR | Directory zur Aufnahme der Druckaufträge. | $CSS_ENV/spool
DATE_TYPE Form der Datum-Darstellung im css(U) Dialog:

AM, US: | MM/DD/YY
EU: | DD.MM.YY
IN: | YY/MM/DD
 Wert von /etc/css.default
DEFAULT_FORM | Definiert das Default Formular, falls beim lpr(U) Aufruf keine f-Option angegeben wird. | Wert von /etc/css.default
DEFUALT_DEVICE | Definiert den Default Drucker, falls beim lpr(U) Aufruf keine d-Option angegeben wird. | Wert von /etc/css.default
DEV_STOP_TIMEOUT | Dieser Parameter kontrolliert das Verhalten des lpd Programmes bei Stop Aktionen von einem aktiven Ausdruck. Wird der Wert ungleich Null gesetzt, stoppt der Despooler Prozess nach der angegebenen Anzahl Sekunden auch dann, wenn die aktuelle Seite nicht vollständig ausgedruckt wurde. Der Drucker und die Auswertung werden in den Status 'blockiert'gesetzt. Es ist zu beachten, dass selbst mit einem gesetzten DEV_STOP_TIMEOUT Parameter, der Prozess nicht in jedem Falle in der Lage ist, sich zu beenden. Viele Unix Systeme erlauben es einem Prozess nicht abzuschliessen, solange pendente Ausgabeoperationen noch nicht abgeschlossen wurden (typisch bei ausgeschaltetem Drucker). Sobald der Drucker wieder eingeschaltet wird, sollte die Verarbeitung wie erwartet abgeschlossen werden können. Um CSS die Gelegenheit zu geben, nach dem Druck der aktuellen Seite zu stoppen, sollte dieser Parameter auf einen vernünftigen Wert gesetzt werden (z.B. 90). | Wert von /etc/css.default
ERRLOG_SIZE | Legt die Grösse der CSS lpd Fehler Log Datei css.errlog in KB fest. Erreicht die Datei die angegebene Grösse, wird sie zurückgesetzt und alle zuvor aufgezeichnete Information geht verloren. | Wert von /etc/css.default
JOB_FLAGS | Dieser Parameter kann auf den Wert true gesetzt werden, um das Verhalten von älteren CSS Versionen als Release 3.4 zu simulieren. Für Details, siehe unter den Hinweisen zur Migration in Kapitel 1. | Wert von /etc/css.default
LANGENV Mit diesem Parameter kann der Name einer Umgebungs-Variable angegeben werden, welche von css(U) zur Steuerung der Dialogsprache verwendet werden soll. Wenn angegeben, hat der entsprechende Wert vor dem LANGUAGE Parameter Vorrang, kann jedoch mit der L-Option von css(U) überschrieben werden. Wert von /etc/css.default

LANGUAGE Sprache des Dialoges von css(U):

dutch, english, french, italian oder german 		Wert von /etc/css.default
PROTECTION Berechtigungs-Schutz der Auswertungen:

user: | User-ID
group: | Group-ID, resp. Gruppenzugehörigkeit unter Windows NT
none: | kein Schutz
 Wert von /etc/css.default
PUBLIC_GROUP | Ungeachtet des Berechtigungs-Schutzes, der mit dem PROTECTION Parameter definiert ist, haben alle Benutzer Zugriff auf Auswertungen, welche einer Gruppe (Unix group) gehören, die in diesem Parameter aufgelistet ist. Besitzer einer neue Auswertung ist der User und die damit assoziierte Group. Die Zughörigkeit kann auch mit der u- und g-Option von lpr(U) gesteuert werden. In diesem Parameter kann eine oder mehrere Gruppen (Name oder Nummer), welche durch das Zeichen '|' oder durch Kommas ',' getrennt sind, angegeben werden. Unter Windows NT können nur Gruppennamen verwendet werden.
PUBLIC_USER | Ungeachtet des Berechtigungs-Schutzes, der mit dem PROTECTION Parameter definiert ist, haben alle Benutzer Zugriff auf Auswertungen, welche einem Benutzer (Unix user) gehören, der in diesem Parameter aufgelistet ist. Es kann ein oder mehrere Benutzer (Name oder Nummer), welche durch das Zeichen '|' oder durch Kommas ',' getrennt sind, angegeben werden. Unter Windows NT können nur Benuzernamen verwendet werden.
SHOW_CSSFLAGS | Veranlasst das Programm css(U) die d-, u- und x-Option, falls gesetzt, in den entsprechenden Bildschirm-Titelzeilen anzuzeigen. | Wert von /etc/css.default
TEST_PRINT Frage nach Testdruck beim Formular-Wechsel via css(U):

true oder false 		Wert von /etc/css.default
TEST_PRINT_ACHAR | Text Substitutions-Zeichen beim Testdruck via css(U). | Wert von /etc/css.default
TEST_PRINT_NCHAR | Zahlen Substitutions-Zeichen beim Testdruck via css(U). | Wert von /etc/css.default
VIEW_CONTROL_CHAR Definiert das Substitutions-Zeichen für nicht druckbare Zeichen im Dialog von css(U) (Befehl Anzeigen). Solche Zeichen sind von 0x00 bis 0x19, 0x7f und 0xff, ausser CR, LF, BS und TAB. Die folgenden Werte sind möglich:

space: | Leerzeichen 0x20
null: | nicht anzeigen
x: | benutze Zeichen x
 Wert von /etc/css.default

VIEW_DEVICE | Bezeichnet die für die Aufbereitung der Auswertungsdaten zur Vorschau in css(U) zu verwendende Druckerdefinition.
WINCSS_PORT | Definiert die vom Windows Server cssws(U) resp. dem NT Service Prozess CssNTSrv(U) zu verwendende TCP/IP Portnummer.
WINCSS_VIEW_DEVICE | Bezeichnet die für die Aufbereitung der Auswertungsdaten zur Vorschau in WinCss(U) zu verwendende Druckerdefinition. | Wert in VIEW_DEVICE
WRAP_SCREEN | Ein- / ausschalten des Defaults zur Navigation von Bildfolgen im css(U) Dialog von der letzten zur ersten Seite. | Wert von /etc/css.default

Hinweise

Ist $CSS_ENV/etc/css.default auf dem System nicht vorhanden, arbeitet CSS mit der Default-Konfiguration.

Wichtig! Zeigt der CSS_SPOOL_DIR Parameterwert auf einen Pfad, welcher von einem weiteren virtuellen CSS Server verwendet wird, resultiert Datenverlust!


Programmierung

Kapitel 5 - Programmierung

5.1. Übersicht

Dieses Kapitel dient zur Referenz für Software-Entwickler, welche die erweiterten Möglichkeiten der Druck-Aufbereitung von CSS nutzen möchten. Eine sehr spezielle Steuerung bietet document embedded control, das einbetten von lpr(U) Optionen innerhalb der Druckdatei. Zur geräteunabhängigen Programmierung von speziellen Druckeffekten steht das hypothetische CSS Druckermodell zur Verfügung.

Wichtig!

Zur Wahrung der Kompatibilität zu früheren Versionen wird das C-Interface css_fstat weiterhin unterstützt. Da ab Release 2.7 erweiterte Formular-Bezeichnungen möglich sind, übernimmt neu das Modul css_formstat dessen Aufgabe.


CssFormstat

C-Interface / Get Form Status

css_formstat(P)
Name Plattform Synopsis Beschreibung Diagnose Beispiele Files Siehe auch

Name

css_formstat

Plattform

Unix, Windows NT

Synopsis

#include "css.h"

struct css_forminfo
    *css_formstat(f);
char *f;

Beschreibung

Css_formstat gibt als Funktionswert einen Pointer auf eine statische Struktur css_forms zurück, die durch jeden Aufruf neu gefüllt wird.

struct css_forminfo
{
    char  cfi_form[4];       /* form-id / strlen=3 */
    char  cfi_name[31];      /* form-name / strlen=30 */
    char  cfi_pp;            /* page-parity T/FALSE */
    short cfi_ps;            /* page-size */
    short cfi_ll;            /* line-length at 10 CPI */
    short cfi_devnr;         /* mount only on devnr */
                             /* (0 = any) */
};

Diagnose

Css_formstat gibt einen NULL-Pointer zurück, falls das Formular "f" nicht gefunden werden kann.

Beispiele
#include "css.h"

struct css_forminfo *cfi;
int ps = 48;       /* default page size */

if (cfi = css_formstat("A4q"))
    ps = cfi->cfi_ps;

Files

Css: |
/usr/lib/css/form | (Forms Database)
CssNT: |
lib\form | (Forms Database)

Siehe auch

css, css.forms(C)


Programm Interface

CSS Programm Interface

CSS(P)
Name Plattform Beschreibung Files Siehe auch

Name

css

Plattform

Unix, Windows NT

Beschreibung

Druckprogramme können mit CSS auf drei Arten kommunizieren:

1.) Lpr-Parameter

Lpr-Parameter können als 1. Zeile einer Liste übergeben werden.

Freiformat:

Position | Inhalt
1..7 | '++CSS++' / CSS-Parameter Identifikation
8..n | ab Position 8 beliebige lpr(U) Optionen

Der Parameter-Record muss mit einem Linefeed oder Carriage-Return abgeschlossen werden. Dieses Format sollte favorisiert werden, da es die Eingabe aller lpr(U) Optionen erlaubt.

Beispiel:

++CSS++ -a -f B -d Laser1 -t 'Bestellungen'

Fix-Format:

Position | Inhalt
1..9 | ##CSS03## / CSS-Parameter Identifikation (Version 3)
10..12 | Formular-Typ
13..13 | Formular-Unterbegriff (siehe auch fdu(U))
14..14 | Automatische Wahl der Schreibdichte: Space = nein / <> Space = ja
15..30 | 0..999 / Drucker-Nr (dreistellig) / 0 = beliebiger Drucker, oder Drucker-Name (16-stellig)
31..32 | 0..99 / Anzahl zu druckende Kopien / 0 = 'hold'
33..62 | Listen-Bezeichung
63..63 | Disposition nach Druck: Space, E, e = erase / D, d = keep until date
64..73 | Keep-Datum TT.MM.JJJJ
74..81 | Mitarbeiter-Kurzzeichen
82..95 | Programm-ID
96..107 | Banner-Page Titel

Der Parameter-Record kann beliebig verkürzt sein, muss jedoch mit einem Linefeed oder Carriage-Return abgeschlossen werden.

Beispiel:

##CSS03##A4qA00 02

Dieser Text wird auf Formular A / Drucker 0 (beliebiger Drucker) in zweifacher Ausführung gedruckt. Die Schreibdichte wird automatisch gewählt.

Beispiel Cobol:

*
*    COMMERCIAL-SPOOLING-SYSTEM PARAMETER
*
  01     CSS.
     02  FILLER           PIC X(9)   VALUE "##CSS03##".
     02  CSS-FORM         PIC X(3)   VALUE "A".
     02  CSS-SUBFORM      PIC X      VALUE SPACE.
*                        .FORMULAR-TYP
     02  CSS-AUTOCPI      PIC X      VALUE SPACE.
*                        .A = AUTOMATISCHE WAHL
*                             DER SCHREIBDICHTE
*                             GEMÄSS DER
*                             LÄNGSTEN ZEILE
     02  CSS-DEVICE-NAME.
      03 CSS-DEVICE       PIC 9(3)   VALUE ZERO.
      03 FILLER           PIC X(13)  VALUE SPACE.
*                        .DRUCKER-NR / -NAME
*                         0 = AUTO-SELECT
     02  CSS-COPYS        PIC 99     VALUE 1.
*                        .ANZAHL KOPIEN
*                         0 = HOLD
     02  CSS-RNAME        PIC X(30)  VALUE SPACE.
*                        .LISTEN-BEZEICHNUNG
     02  CSS-KEEP         PIC X      VALUE "E".
*                        .E,SPACE = PRINT, ERASE
*                        .D = KEEP UNTIL DATE
     02  CSS-KDAT         PIC X(10)  VALUE SPACE.
*                        .KEEP-DATE (TT.MM.JJJJ)
     02  CSS-MKZ          PIC X(8)   VALUE SPACE.
*                        .MITARBEITER-KURZZ.
     02  CSS-PGMNAME      PIC X(14)  VALUE SPACE.
*                        .PROGRAMM-NAME
     02  CSS-BANNER       PIC X(12)  VALUE SPACE.
*                        .BANNER-PAGE TITLE
* *****END CSS.P
.....
    MOVE "A" TO CSS-AUTOCPI.
    MOVE 2 TO CSS-COPYS.
    MOVE "KUNDEN-STAMMBLATT" TO CSS-RNAME.
    OPEN OUTPUT R0.
    WRITE R0-LINE FROM CSS AFTER 0.
.....

Die Parameter-Formate früherer CSS-Versionen (##CSS##, ##CSS01## und ##CSS02##) werden weiterhin unterstützt.

2.) Escape-Sequenzen

Wie unter css.devices(C) beschrieben, werden die verschiedenen Drucker-Optionen mit Escape-Sequenzen (ESC,1 bis ESC,127) gesteuert.

Beispiel Basic:

10 REM ELONGATED PRINTING
20 LPRINT CHR$(27); CHR$(9);  "wide Text"
30 LPRINT CHR$(27); CHR$(10); "normal Text"

Beispiel Cobol:

*
*    CSS-STEUERUNG
*
  01     CSS-CONTROL.
     02  CSS10CPI.
      03 FILLER          PIC 9(4) COMP-1 VALUE 6913.
*                       .=ESC,1
*                       .=(27 * 256) + 1
     02  CSS12CPI.
      03 FILLER          PIC 9(4) COMP-1 VALUE 6914.
     02  CSS16CPI.
      03 FILLER          PIC 9(4) COMP-1 VALUE 6915.
     02  CSS18CPI.
      03 FILLER          PIC 9(4) COMP-1 VALUE 6916.
......
     02  CSSEL.
      03 FILLER          PIC 9(4) COMP-1 VALUE 6921.
     02  CSSNOEL.
      03 FILLER          PIC 9(4) COMP-1 VALUE 6922.
......
     WRITE R0-LINE FROM CSSEL AFTER 0.
     MOVE "elongated Text" TO R0-LINE.
     WRITE R0-LINE AFTER 1.
     WRITE R0-LINE FROM CSSNOEL AFTER 0.
     MOVE "normal Text" TO R0-LINE.
     WRITE R0-LINE AFTER 1.

Beispiel C:

/* eprint: print stdin elongated */

#include "css.h"

#define CSS(f,p) fprintf(f, "\033%c", p)
#define ELON 9
#define ELOFF 10

char *progName;
char *lpr = "lpr -p eprint";

main(argc, argv)

int argc;
char *argv[];
{
    FILE *pFp, *popen();
    register int c;

    progName = argv[0];
    if ((pFp = popen(lpr, "w")) == NULL)
    {
        fprintf(stderr, "%s: can't run %s\n", progName, lpr);
        exit(1);
    }
    CSS(pFp, ELON); /* start elong. */
    while ((c = getchar()) != EOF)
        putc(c, pFp);
    CSS(pFp, ELOFF); /* stop elong. */
    pclose(pFp);
    return 0;
}

3.) Formular-Informationen

Formular-Informationen, die mittels css.forms(C) beschrieben wurden, können mit Hilfe des C-Interfaces css abgefragt werden. Zusammen mit dem Autocpi-Parameter (siehe Punkt 1.) ist es somit möglich, Programme von Formulardimensionen unabhängig zu erstellen:

#include "css.h"

struct css_forminfo *cfi;
int ps;   /* page size */

if (cfi = css_formstat("b"))
    ps = cfi->cfi_ps;
else
    /* unknown form, use default */
    ps = 48;

Bei der Kompilation ist das mitgelieferte Object-Module css_fstat.o auf der Befehlszeile anzugeben:

cc -o prog prog.c css_fstat.o ...

Bei Systemen mit Small-, Medium- und Large-Compilern werden jeweils alle entsprechenden Object-Module geliefert, wobei der Compiler-Typ dem Filenamen als Prefix (S, M und L) beigefügt ist.

Files

Css: |
/usr/lib/css/form | (Forms Database)
CssNT: |
lib\form | (Forms Database)

Siehe auch

lpr(U), css.forms(C)


WinCss Options - Verbindung

WinCss Unitec Home Page

X
X

WinCss Optionen - Verbindung
Der Abschnitt Verbindung des Fensters Optionen erlaubt die Einstellungen der Netzwerkverbindung von WinCss.

Verbindungsoptionen
Verbindungsoptionen
Option | Beschreibung
IP Adresse | The IP address of the CSS server system.
Port Nummer | Die TCP/IP Port Nummer unter welcher die CSS Interface Dienste angeboten werden. Für eine Beschreibung der IP Adresse und der Port Nummer siehe nächster Abschnitt.
Server IP Adresse bei jedem Programmstart wählen | Das Setzen dieser Option erlaubt es dem Anwender, bei jedem Programmstart die CSS Server IP Adresse zu wählen.
Loginnamen für CSS Server auf Kleinschreibweise konvertieren | Mit dieser Option können Konflikte durch unterschiedliche Schreibweise der Windows und Unix Loginnamen vermieden werden.

Bitte beachten Sie, dass diese Optionen beim Programmende in der Windows Registry gespeichert werden und erst beim nächsten Aufruf von WinCss aktiv werden.

Siehe auch Allgemeine Optionen, Client Konfiguration


WinCss Options - Allgemein

WinCss Unitec Home Page

X
X

WinCss Optionen - Allgemein
Der Abschnitt Allgemein des Fensters Optionen erlaubt die Verwaltung der allgemeinen Einstellungen von WinCss.

Allgemeine Optionen
Allgemeine Optionen
Option | Beschreibung
Starten mit Mini Toolbar Fenster | Ist diese Option gesetzt startet WinCss mit dem Toolbar Fenster Toolbar Fenster (siehe Hauptsteuerung).
Feldaktion durch Einfachklick | Das Setzen dieser Option erlaubt es, Feldaktionen mit einem einfachen Maustastenklick auszulösen (Standarteinstellung ist der Doppelklick).
Schaltflächen für Feldaktionen anzeigen | Das Setzen dieser Option bewirkt die Darstellung einer kleinen Schaltfläche in jedem Feld, welchem eine Aktion zugeordnet ist.
Automatischer Mauszeiger | Ist diese Option gesetzt, springt beim öffnen eines Fensters der Mauszeiger auf die Default-Schaltfläche.
Löschen mit Bestätigung | Das Ausschalten dieser Option verhindert den üblichen Bestätigungsdialog beim Löschen von Auswertungen. Die Verwendung erfolgt auf eigenes Risiko.

Siehe auch Verbindungsoptionen


WinCss Übersicht
Copyright

Diese Help Datei beinhaltet das elektronische Handbuch der CSS Windows Benutzerschnittstelle WinCss. Es enthält die vollständige Beschreibung aller Dialogelemente sowie deren Inhalt.

Um Informationen über die Unix und Windows/NT CSS Programme zu erhalten, konsultieren Sie bitte das CSS Online Handbuch, welches einen integrierenden Bestandteil der CSS Dokumentation bildet.

Das Online Handbuch wird nur mit der Server Version von CSS vertrieben. Es kann jedoch von der Unitec Web Seite auf Ihr System geladen werden. Instruktionen dazu finden Sie im Abschnitt Online Manual.

WinCss Highlights

  • Office Look and Feel
  • Drag and Drop Bedienung
  • Kontext Menüs
  • Vorschau der Auswertungen mit Textsuche
  • Implementiert mit dem weit verbreiteten Unitec Communication Manager UCM
  • Installieren und verwenden, keine zusätzliche Konfiguration notwendig

CSS Highlights

Einige der wichtigen Eigenschaften der CSS und CssNT Server Software sind:

  • Möglichkeit der geräteunabhängigen Programmierung
  • Definitionsdatenbank für Drucker und Formulare
  • Formulardefinitions Utility / Laserdrucker Makroverwaltung
  • Einfach zu bedienendes Dialogprogramm für alle Verwaltungsaufgaben
  • Lpr-Optionen innerhalb der Druckdatei
  • Verwaltung von Formularwarteschlangen
  • Report Preview (Anzeige von Druckdateien mit Suchfunktion)
  • Testdruck (Richttest)
  • Integrierte Druckdatei Verwaltung mit Aufbewahrungsdatum
  • Übersetzungstabellen für Zeichen- und Zeichensequenzen
  • Multiuser Tauglichkeit
  • Kompression der CSS Zwischendateien
  • Unterstützung der Netzwerk Druckprotokolle lpd, rtel, pros und raw
  • Grafische Oberfläche für Windows Workstations

Über WinCss lesen.

Back To Top


WinCss

Windows User Interface

WinCss(U)
Synopsis Plattform Beschreibung Optionen Hinweise Siehe auch Dialog

Synopsis

WinCss [-m] [-h host] [-p port]

Plattform

Win32

Beschreibung

Mit WinCss können alle bei der Spooler-Verwaltung anfallenden Arbeiten wie z.B.: Status-Abfragen, Formular-Wechsel, Prioritäten-Steuerung usw. von jedem Windows Client System aus erledigt werden. Die Bedienung der grafischen Oberfläche erfolgt unter den in Windows üblichen Standarts. Wo immer möglich, kann mit der rechten Maustaste ein dem aktuellen Kontext entsprechendes Popupmenu geöffnet werden. Die aktuellen Daten werden in Tabellen dargestellt. Bei mehreren Tabellenelementen kann durch Doppelklick mit der linken Maustaste ein Dialogfenster geöffnet werden, um dem Inhalt entsprechende Aktionen auszulösen. Diese Elemente werden in diesem Dokument als Datenfeld-Schalter bezeichnet.

Viele Verwatlungsaufgaben können mittels Drag And Drop erledigt werden. Dabei wird ein Objekt mit der linken Maustaste angewählt und mit der gedrückten Taste über ein anderes Objekt gezogen (Drag). Der Mauszeiger verändert während dieses Vorganges seine Form. Ist das Zielobjekt erreicht, wird die Maustaste losgelassen (Drop) und ein der Aktion entsprechendes Dialogfenster wird geöffnet. Zum Beispiel kann ein Formularwechsel durch Drag einer Datenzeile des Formularfensters und Drop auf ein Element des Druckerfensters ausgelöst werden.

Folgende Hauptfenster sind verfügbar:

Hauptsteuerung | Kleines Fenster mit Schaltern (sog. Toolbar Buttons) zum öffnen der unten aufgeführten Datenfenster.
Formulare | Liste aller bekannten Formulare.
Drucker | Liste aller bekannten Drucker. Aktionen: Drucker stoppen, Druckvorgang abbrechen, Drucker starten, Formularwechsel durchführen.
Auswertungen | Liste der sich in der Warteschlange befindenden Auswertungen. Aktionen: beschleunigen, blockieren (Druck aufschieben), zum Druck freigeben, umleiten, stoppen, Ahnzahl Kopien ändern, anzeigen und löschen.

Die Sprache des WinCss Dialoges kann im Menu Ansicht | Sprache ausgewählt werden. Einige Darstellungselemente wie Menü, Statuszeile und Tool Tips (kleine Hinweisfenster) können ebenfalls im Menü Ansicht ein- resp. ausgeschaltet werden. Wurde das Menü selbst ausgeschaltet kann es durch das Betätigen der rechten Maustaste über der Toolbar wieder sichtbar gemacht werden.

Optionen

-h host | WinCss verbindet sich mit dem CSS Server auf dem System mit der IP Adresse host.
-m | Normalerweise verzweigt WinCss direkt in das Fenster Warteschlange. Mit der m-Option kann das Minifenster Hauptsteuerung eingeblendet werden.
-p port | Definiert die zu verwendende TCP/IP Portnummer. Default is 6801, resp. der in den Programmoptionen gestzte Wert. Siehe auch unter WinCss(C) und CssWs.

Hinweise

Als Optionszeichen kann neben dem Bindestrich '-' auch der Slash '/' verwendet werden.

Das Fenster Drucker zeigt folgende Statusinformationen an:

Status | Bedeutung
bereit | wartend, ohne Arbeit
start | ein Ausdruck beginnt
aktiv | druckend
besetzt | Drucker wird von einem Software-Paket mit integriertem Spooler benutzt (siehe auch el-Eintrag im css.devices(C))
umgeleitet auf x | Die Ausgabe erfolgt auf den bezeichneten Drucker.
off line | der Drucker ist nicht eingeschaltet. Dieser Zustand kann nur bei gewissen Schnittstellen erkannt werden.
inaktiv | Drucker gestoppt

Bei der Anzeige von Auswertungen am Bildschirm können Folgen von mehreren Leerzeilen komprimiert dargestellt werden.

Wird in einer Datentabelle eine Zeile durch Mausklick angewählt, wird sie mit einem hellgelben Hintergrund belegt. Ein solcher Eintrag wird in der untenstehenden Beschreibung als aktuelles Element bezeichnet (z.B. aktuelle Auswertung).

Siehe auch

CssWs, WinCss(C)

Dialog

Hauptsteuerung (Miniwindow)

FrmMain.gif (1974 bytes)

Schalter | Name | Beschreibung
BtnRep.gif (872 bytes) | Warteschlange | Mit Hilfe des Warteschlangefensters können die gegenwärtig vorhandenen Auswertungen verwaltet werden.
BtnDev.gif (868 bytes) | Drucker | Das Druckerfenster dient zur Verwaltung aller im CSS System definierten Drucker.
BtnForms.gif (868 bytes) | Formulare | In diesem Fenster werden alle dem System bekannten Formulare aufgelistet.
BtnOpt.gif (879 bytes) | Optionen | Setzen diverse Programmoptionen.
BtnHelp.gif (865 bytes) | Hilfe | Startet WinCss Help, Kapitel Hauptsteuerung.
BtnExit.gif (876 bytes) | Exit | Die Betätigung dieses Schalters beendet das Programm und schliesst alle geöffneten Fenster.

Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:

Bereich | Menü
Schalter | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).

Warteschlange (Auswertungen)

Schalter | Name | Beschreibung
BtnDev.gif (868 bytes) | Drucker | Das Druckerfenster dient zur Verwaltung aller im CSS System definierten Drucker. Dieser Schalter wird hier nicht angezeigt, falls das Programm mit der m-Option gestartet wurde.
BtnForms.gif (868 bytes) | Formulare | In diesem Fenster werden alle dem System bekannten Formulare aufgelistet. Dieser Schalter wird hier nicht angezeigt, falls das Programm mit der m-Option gestartet wurde.
BtnRepGo.gif (880 bytes) | Freigeben | Gibt die bezeichnete Auswertung zum Ausdruck frei.
BtnRepPrint.gif (876 bytes) | Sofortdruck | Wie 'Freigeben', jedoch ohne vorgängiges Dialogfenster zur Feineinstellung der Druckoptionen.
BtnRepStop.gif (882 bytes) | Blockieren | Blockiert resp. stoppt den Ausdruck der aktuellen Auswertung.
BtnRepAccell.gif (889 bytes) | Beschleunigen | Setzt die Auswertung an den Anfang der Warteschlange des entsprechenden Formulars. Hinweis: Auswertungen können nur gegenüber eigenen anderen Auswertungen beschleunigt werden.
BtnRepCopys.gif (881 bytes) | Anzahl Kopien | Startet einen Dialog zur Änderung der Anzahl Kopien.
BtnRepRoute.gif (883 bytes) | Umleiten | Startet den Dialog zur Umleitung der Auswertung auf einen anderen Drucker.
BtnRepView.gif (887 bytes) | Anzeigen | Zeigt die Auswertung in einem separaten Fenster an. Diese Funktion ist nur in der 32 Bit Version verfügbar.
BtnRepDel.gif (876 bytes) | Löschen | Löscht die aktuelle Auswertung.
BtnHelp.gif (865 bytes) | Hilfe | Startet WinCss Help, Kapitel Warteschlange.
BtnClose.gif (855 bytes) | Schliessen | Schliesst das aktive Fenster.

Folgende Daten werden angezeigt:

Titel | Inhalt
Nr. | Auswertungsnummer. Eine rote Nummer kennzeichnet, dass auf diese Auswertung keine Zugriffsberechtigung besteht.
Bezeichnung | Vom Applikationsprogramm definierte Auswertungsbezeichnung.
Frm | Das von der Auswertung verlangte Formular.
Status | Auswertungsstatus wie z.B. bereit, druckend, blockiert, usw.
DNr | Nummer des Druckers auf welchem die Auswertung verarbeitet werden soll.
Seiten | Anzahl Seiten im Dokument.
Kopien | Anzahl zu druckende Kopien.
Datum | Erstelldatum der Auswertung.
Zeit | Erstellzeit der Auswertung.
MKZ | Kurzzeichen des Mitarbeiters, der die Auswertung erstellt hat.

Folgende Datenfelder lösen durch Doppelklick eine Aktion aus:

Datenfeld | Aktion
Nr., Bezeichnung | Zeigt den Inhalt der Auswertung in einem separaten Fenster an.
DNr | Startet den Dialog zur Umleitung der Auswertung auf einen anderen Drucker.
Status | Löst je nach aktuellem Auswertungsstatus einen entsprechenden Dialog (freigeben, aktivieren, stoppen) aus.
Kopien | Startet den zur Änderung der Anzahl Kopien bestimmten Dialog.

Drag And Drop Möglichkeiten:

Drag Objekt | Drop Objekt | Aktion
Drucker | Auswertung | Löst je nach aktuellem Drucker- und Auswertungsstatus einen entsprechenden Dialog (freigeben, umleiten, aktivieren, Formularwechsel) aus.
Auswertung | Drucker | Wie oben.

Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:

Bereich | Menü
Schalter | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).
Datenzeile | Menü mit allen auch via Toolbar möglichen Aktionen.
Tabellentitel | Aktivieren und deaktivieren der einzelnen Datenspalten.

Drucker

Schalter | Name | Beschreibung
BtnFormChg.gif (877 bytes) | Formularwechsel | Löst den Dialog zur Formularwahl aus.
BtnDevGo.gif (862 bytes) | Aktivieren | Aktiviert den aktuellen Drucker.
BtnDevStop.gif (882 bytes) | Inaktiv setzen | Stoppt den aktuellen Drucker und/oder setzt ihn in den Status inaktiv.
 | Drucker umleiten | Leitet die gesamte Ausgabe auf einen anderen Drucker um.
 | Umleitung aufheben | Hebt die Umleitung des aktuellen Druckers auf.
BtnHelp.gif (873 bytes) | Hilfe | Startet WinCss Help, Kapitel Drucker.
BtnClose.gif (855 bytes) | Schliessen | Schliesst das aktive Fenster.

Folgende Daten werden angezeigt:

Titel | Inhalt
Nr. | Druckeridentifikation. Eine rote Nummer kennzeichnet, dass im Moment auf diesen Drucker keine Zugriffsberechtigung besteht.
Bezeichnung | Drucker Bezeichnung
Frm | Das im Drucker eingelegte Formular. Auswertungen können nur ausgedruckt werden, wenn der Drucker das entsprechende Formular eingelegt hat und ein Formularwechsel durchgeführt wurde.
Status | Druckerstatus wie z.B. bereit, aktiv, inaktiv, usw.
Auswertung | Bei Druckerstatus aktiv, zeigt dieses Feld die Bezeichnung der momentan druckenden Auswertung an.
Seite/von | Momentan druckende Seite / Total Seiten.
Kopie/von | Momentan druckende Kopie / Total Kopien.
MKZ | Kurzzeichen des Mitarbeiters, der die momentan druckende Auswertung erstellt hat.

Folgende Datenfelder lösen durch Doppelklick eine Aktion aus:

Datenfeld | Aktion
Frm | Löst den Dialog zur Formularwahl aus.
Status | Löst je nach aktuellem Status einen entsprechenden Dialog (freigeben, umleiten, blockieren, stoppen) aus.

Drag And Drop Möglichkeiten:

Drag Objekt | Drop Objekt | Aktion
Formular | Drucker | Löst den Formularwechsel Dialog aus.
Auswertung | Drucker | Löst je nach aktuellem Drucker- und Auswertungsstatus einen entsprechenden Dialog (freigeben, umleiten, aktivieren, Formular-Wechsel) aus.
Drucker | Auswertung | Wie oben.

Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:

Bereich | Menü
Schalter | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).
Datenzeile | Menü mit allen auch via Toolbar möglichen Aktionen.
Tabellentitel | Aktivieren und deaktivieren der einzelnen Datenspalten.

Formulare

Schalter | Name | Beschreibung
BtnHelp.gif (873 bytes) | Hilfe | Startet WinCss Help, Kapitel Formulare.
BtnClose.gif (855 bytes) | Schliessen | Schliesst das aktive Fenster.

Folgende Daten werden angezeigt:

Titel | Inhalt
ID | Formularidentifikation
Bezeichnung | Formularbezeichnung

Drag And Drop Möglichkeiten:

Drag Objekt | Drop Objekt | Aktion
Formular | Drucker | Löst den Formularwechsel Dialog aus.

Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:

Bereich | Menü
Schalter | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).
Tabellentitel | Aktivieren und deaktivieren der einzelnen Datenspalten.

Auswertung anzeigen

Schalter | Name | Beschreibung
Btn1stPg.gif (856 bytes) | Erste Seite | Ansicht auf erste Seite positionieren.
BtnBackPg.gif (840 bytes) | Seite rückwärts | Eine Seite zurück.
BtnNextPg.gif (840 bytes) | Seite vorwärts | Eine Seite vorwärts.
BtnLastPg.gif (855 bytes) | Letzte Seite | Ansicht auf letzte Seite positionieren.
BtnGotoPg.gif (867 bytes) | Nach Seite... | Gehe nach Seite.
BtnSrchBw.gif (868 bytes) | Rückwärts suchen | Mit letztem Suchbegriff rückwärts weitersuchen.
BtnSrch.gif (868 bytes) | Suchen | Text suchen.
BtnSrchFw.gif (868 bytes) | Weitersuchen | Mit letztem Suchbegriff vorwärts weitersuchen.
BtnCopy.gif (876 bytes) | Kopieren | Markierten Text in die Zwischenablage kopieren.
BtnFontUp.gif (873 bytes) | Schrift grösser | Grössere Schrift wählen.
BtnFondDn.gif (849 bytes) | Schrift kleiner | Kleinere Schrift wählen.
BtnCmpr.gif (869 bytes) | Komprimieren | Eine Folge von mehreren Leerzeilen zu einer Zeile komprimieren.
BtnHelp.gif (873 bytes) | Hilfe | Startet WinCss Help, Kapitel Hauptsteuerung.
BtnClose.gif (863 bytes) | Schliessen | Schliesst das aktive Fenster.

Die Betätigung der rechten Maustaste löst auf bestimmten Bereichen ein Popup Menü aus:

Bereich | Menü
Schalter | Ein- resp. ausschalten des Menüs sowie der Schalter (Toolbar).
Ansicht | Menü mit allen auch via Toolbar möglichen Aktionen.


Copyright

WinCss Unitec Home Page

Copyright / Trademarks

WinCss CSS Windows Interface

Copyright © 1996-2002 by Unitec Informatik. All rights reserved.

Die in diesem Dokument enthaltene Information kann ohne vorherige Ankündigung geändert werden und beinhaltet keinerlei verpflichtende Zusagen der Firma Unitec Informatik. Die hier beschriebene und durch Copyright geschützte Software wird mit einer Garantie von 90 Tagen geliefert und darf nur im Rahmen des Lizenzvertrages benutzt oder kopiert werden. Es ist ungesetzlich, diese Software zu benutzen oder zu kopieren, ausser wen im Lizenzvertrag dieses Recht ausdrücklich zugestandenen ist.

Warning: Unauthorized reproduction or distribution of this program, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the maximum extent possible under law.

Unitec Informatik
Im Lot 10
CH-8610 Uster

Switzerland

Unix is a registered trademark of AT&T Bell Labs Incorporated.
Unitec is a registered trademark of Unitec Informatik, Switzerland.
Windows and Windows NT are registered trademarks of Microsoft Corporation

Zurück zum Anfang

Copyright Notice